aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-10-17 05:59:31 +0800
committernemysis <nemysis@FreeBSD.org>2013-10-17 05:59:31 +0800
commit1c36ea34a11e2499e6f664ad59408d719c40ea94 (patch)
tree4f8359ec5c3efdb1ece1c17a696cc2afdafb6c27 /security
parent219b1c140c64c912b8851e1949d681ccead22c69 (diff)
downloadfreebsd-ports-gnome-1c36ea34a11e2499e6f664ad59408d719c40ea94.tar.gz
freebsd-ports-gnome-1c36ea34a11e2499e6f664ad59408d719c40ea94.tar.zst
freebsd-ports-gnome-1c36ea34a11e2499e6f664ad59408d719c40ea94.zip
Figaro's Password Manager 2 is a program that allows you to securely store the
passwords using GTK2 interface. Features include: - Passwords are encrypted with the AES-256 algorithm. - Copy passwords or usernames to the clipboard/primary selection. - If the password is for a web site, FPM2 can keep track of the URLs of your login screens and can automatically launch your browser. In this capacity, FPM2 acts as a kind of bookmark manager. - You can teach FPM2 to launch other applications, and optionally pass hostnames, usernames or passwords to the command line. - FPM2 also has a password generator that can choose passwords for you. It allows you to determine how long the password should be, and what types of characters (lower case, upper case, numbers and symbols) should be used. You can even have it avoid ambiguous characters such as a capital O or the number zero. - Auto-minimise and/or auto-locking passwords database after configurable time to the tray icon. WWW: http://als.regnet.cz/fpm2/ PR: ports/179096 Submitted by: nemysis (self) Approved by: wg/pawel (mentors)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/fpm2/Makefile55
-rw-r--r--security/fpm2/distinfo2
-rw-r--r--security/fpm2/files/pkg-message.in8
-rw-r--r--security/fpm2/pkg-descr18
-rw-r--r--security/fpm2/pkg-plist15
6 files changed, 99 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 34096c9ea12d..9f21551cfad6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -139,6 +139,7 @@
SUBDIR += flawfinder
SUBDIR += fpc-hash
SUBDIR += fpc-openssl
+ SUBDIR += fpm2
SUBDIR += fprint_demo
SUBDIR += fragroute
SUBDIR += fragrouter
diff --git a/security/fpm2/Makefile b/security/fpm2/Makefile
new file mode 100644
index 000000000000..b301aee816c3
--- /dev/null
+++ b/security/fpm2/Makefile
@@ -0,0 +1,55 @@
+# Created by: Rusmir Dusko <nemysis@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= fpm2
+PORTVERSION= 0.79
+CATEGORIES= security
+MASTER_SITES= http://als.regnet.cz/fpm2/download/
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Program that allows you to securely store the passwords
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+
+USE_BZIP2= yes
+USES= gmake pathfix pkgconfig
+USE_GNOME= gtk20
+INSTALLS_OMF= yes
+GNU_CONFIGURE= yes
+
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= DOCS NLS
+
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+
+.include <bsd.port.options.mk>
+
+# Restrict to stable (even) versions, indicated by the second component.
+PORTSCOUT= limit:^0.7\..*
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|^Icon.*|Icon=${PREFIX}/share/pixmaps/${PORTNAME}/logo.png|' \
+ -e 's|^Categories=.*|Categories=GTK;Utility;System;|' \
+ ${WRKSRC}/data/${PORTNAME}.desktop.in
+
+post-patch:
+ @${REINPLACE_CMD} -E -e "s@encrypt\(@bfishencrypt\(@g" ${WRKSRC}/src/blowfish.c
+ @${REINPLACE_CMD} -e 's|gdk_pixbuf_unref|g_object_unref|g' \
+ ${WRKSRC}/src/interface.c
+
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's|USE_NLS=yes|USE_NLS=no|' ${WRKSRC}/configure
+.endif
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/fpm2/distinfo b/security/fpm2/distinfo
new file mode 100644
index 000000000000..00642ecd0e05
--- /dev/null
+++ b/security/fpm2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fpm2-0.79.tar.bz2) = d55e9ce6be38a44fc1053d82db2d117cf3991a51898bd86d7913bae769f04da7
+SIZE (fpm2-0.79.tar.bz2) = 230189
diff --git a/security/fpm2/files/pkg-message.in b/security/fpm2/files/pkg-message.in
new file mode 100644
index 000000000000..d6ff8caefa0c
--- /dev/null
+++ b/security/fpm2/files/pkg-message.in
@@ -0,0 +1,8 @@
+===============================================================================
+
+Figaro's Password Manager 2 has been installed.
+
+Make sure you set up a few IRQ's for random generation with rndcontrol before
+expecting password generation to work well.
+
+===============================================================================
diff --git a/security/fpm2/pkg-descr b/security/fpm2/pkg-descr
new file mode 100644
index 000000000000..0ad56786ca33
--- /dev/null
+++ b/security/fpm2/pkg-descr
@@ -0,0 +1,18 @@
+Figaro's Password Manager 2 is a program that allows you to securely store the
+passwords using GTK2 interface. Features include:
+- Passwords are encrypted with the AES-256 algorithm.
+- Copy passwords or usernames to the clipboard/primary selection.
+- If the password is for a web site, FPM2 can keep track of the URLs of your
+ login screens and can automatically launch your browser. In this capacity,
+ FPM2 acts as a kind of bookmark manager.
+- You can teach FPM2 to launch other applications, and optionally pass
+ hostnames, usernames or passwords to the command line.
+- FPM2 also has a password generator that can choose passwords for you. It
+ allows you to determine how long the password should be, and what types of
+ characters (lower case, upper case, numbers and symbols) should be used.
+ You can even have it avoid ambiguous characters such as a capital O or the
+ number zero.
+- Auto-minimise and/or auto-locking passwords database after configurable time
+ to the tray icon.
+
+WWW: http://als.regnet.cz/fpm2/
diff --git a/security/fpm2/pkg-plist b/security/fpm2/pkg-plist
new file mode 100644
index 000000000000..e20776a8999b
--- /dev/null
+++ b/security/fpm2/pkg-plist
@@ -0,0 +1,15 @@
+bin/fpm2
+man/man1/fpm2.1.gz
+share/applications/fpm2.desktop
+%%NLS%%share/locale/bg/LC_MESSAGES/fpm2.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/fpm2.mo
+%%NLS%%share/locale/de/LC_MESSAGES/fpm2.mo
+%%NLS%%share/locale/es/LC_MESSAGES/fpm2.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/fpm2.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/fpm2.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/fpm2.mo
+%%NLS%%share/locale/it/LC_MESSAGES/fpm2.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/fpm2.mo
+share/pixmaps/fpm2/logo.png
+@dirrm share/pixmaps/fpm2
+@dirrmtry share/applications