aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-08 17:09:36 +0800
committeredwin <edwin@FreeBSD.org>2003-09-08 17:09:36 +0800
commit1e73a77e25a8e89fc091a03b5567feb2a3cb9ef0 (patch)
tree8b34abd3a2ae6c0c6785180c5f9cf68c86ac7198 /security
parent4b074d8e07a48fc837130da51f06d9a754b1e252 (diff)
downloadfreebsd-ports-gnome-1e73a77e25a8e89fc091a03b5567feb2a3cb9ef0.tar.gz
freebsd-ports-gnome-1e73a77e25a8e89fc091a03b5567feb2a3cb9ef0.tar.zst
freebsd-ports-gnome-1e73a77e25a8e89fc091a03b5567feb2a3cb9ef0.zip
[new port] security/dropbear: a lightweight SSH2 server
Dropbear is an SSH 2 server, designed to be usable in small memory environments. It supports: * Main features of SSH 2 protocol * Implements X11 forwarding, and authentication-agent forwarding for OpenSSH clients * Compatible with OpenSSH ~/.ssh/authorized_keys public key authentication WWW: http://matt.ucc.asn.au/dropbear/dropbear.html PR: ports/55795 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/dropbear/Makefile39
-rw-r--r--security/dropbear/distinfo1
-rw-r--r--security/dropbear/pkg-descr10
-rw-r--r--security/dropbear/pkg-plist5
5 files changed, 56 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d140a1a420ee..2afd7f7cc109 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -56,6 +56,7 @@
SUBDIR += digest
SUBDIR += dirmngr
SUBDIR += donkey
+ SUBDIR += dropbear
SUBDIR += drweb
SUBDIR += drweb-postfix
SUBDIR += drweb-qmail
diff --git a/security/dropbear/Makefile b/security/dropbear/Makefile
new file mode 100644
index 000000000000..8a7546119f24
--- /dev/null
+++ b/security/dropbear/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: dropbear
+# Date created: 20 August 2003
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dropbear
+PORTVERSION= 0.36
+CATEGORIES= security ipv6
+MASTER_SITES= http://matt.ucc.asn.au/dropbear/
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= An SSH 2 server, designed to be usable in small memory environments
+
+GNU_CONFIGURE= YES
+USE_GMAKE= YES
+USE_REINPLACE= YES
+
+.if defined(IS_STATIC)
+CONFIGURE_ENV= LDFLAGS=-static
+.endif
+
+BIN= dropbear dropbearkey dropbearconvert
+
+post-configure:
+ @${REINPLACE_CMD} -e "s,/etc/,${PREFIX}/etc/,g" ${WRKSRC}/options.h
+ @${REINPLACE_CMD} -e "s,/usr/bin/X11/,${X11BASE}/,g" ${WRKSRC}/options.h
+
+do-install:
+.for bin in ${BIN}
+ @${INSTALL_PROGRAM} ${WRKSRC}/${bin} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOC)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/dropbear/distinfo b/security/dropbear/distinfo
new file mode 100644
index 000000000000..94c061015cd4
--- /dev/null
+++ b/security/dropbear/distinfo
@@ -0,0 +1 @@
+MD5 (dropbear-0.36.tar.gz) = 37b38670235c4cdd37e3833919bcf53f
diff --git a/security/dropbear/pkg-descr b/security/dropbear/pkg-descr
new file mode 100644
index 000000000000..b46954afeac4
--- /dev/null
+++ b/security/dropbear/pkg-descr
@@ -0,0 +1,10 @@
+Dropbear is an SSH 2 server, designed to be usable in small memory environments.
+It supports:
+
+ * Main features of SSH 2 protocol
+ * Implements X11 forwarding, and authentication-agent forwarding
+ for OpenSSH clients
+ * Compatible with OpenSSH ~/.ssh/authorized_keys public key
+ authentication
+
+WWW: http://matt.ucc.asn.au/dropbear/dropbear.html
diff --git a/security/dropbear/pkg-plist b/security/dropbear/pkg-plist
new file mode 100644
index 000000000000..fa82866934c6
--- /dev/null
+++ b/security/dropbear/pkg-plist
@@ -0,0 +1,5 @@
+bin/dropbear
+bin/dropbearkey
+bin/dropbearconvert
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%