aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-01-05 09:54:24 +0800
committerwen <wen@FreeBSD.org>2011-01-05 09:54:24 +0800
commit2103376c8c7ce19223911d540fda31b347498dd9 (patch)
tree8839de1070ce440742bae0d0209c6fa40138aa36 /security
parent2249b8fec4b826434c085ed304fb3e3723208a13 (diff)
downloadfreebsd-ports-gnome-2103376c8c7ce19223911d540fda31b347498dd9.tar.gz
freebsd-ports-gnome-2103376c8c7ce19223911d540fda31b347498dd9.tar.zst
freebsd-ports-gnome-2103376c8c7ce19223911d540fda31b347498dd9.zip
Honggfuzz is a general-purpose fuzzing tool. Given a starting corpus of test
files, Hongfuzz supplies and modifies input to a test program and utilize the ptrace() API/POSIX signal interface to detect and log crashes. WWW: http://code.google.com/p/honggfuzz/
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/honggfuzz/Makefile36
-rw-r--r--security/honggfuzz/distinfo2
-rw-r--r--security/honggfuzz/pkg-descr5
-rw-r--r--security/honggfuzz/pkg-plist13
5 files changed, 57 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 435b778f3819..cd34981eda09 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -191,6 +191,7 @@
SUBDIR += heimdal
SUBDIR += hlfl
SUBDIR += hmap
+ SUBDIR += honggfuzz
SUBDIR += horde-jeta
SUBDIR += hotssh
SUBDIR += hs-SHA
diff --git a/security/honggfuzz/Makefile b/security/honggfuzz/Makefile
new file mode 100644
index 000000000000..80a25d74719e
--- /dev/null
+++ b/security/honggfuzz/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: honggfuzz
+# Date created: 2010-12-13
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= honggfuzz
+PORTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= A general-purpose fuzzer with simple, command-line interface
+
+LICENSE= ASL
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GMAKE= yes
+
+# inplace replacement to remove relative binary path in examples scripts
+post-patch:
+ @${REINPLACE_CMD} -i "" -E "s,\.\./,," ${WRKSRC}/examples/*.sh
+
+do-build:
+ @(cd ${WRKSRC}; ${GMAKE})
+
+do-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/honggfuzz/distinfo b/security/honggfuzz/distinfo
new file mode 100644
index 000000000000..31343c1a23fd
--- /dev/null
+++ b/security/honggfuzz/distinfo
@@ -0,0 +1,2 @@
+SHA256 (honggfuzz-0.1.tgz) = 5eabcb34e63989ed4f5642d912c8641cae186311d69337401092b6d50f806e3a
+SIZE (honggfuzz-0.1.tgz) = 18228
diff --git a/security/honggfuzz/pkg-descr b/security/honggfuzz/pkg-descr
new file mode 100644
index 000000000000..ff87890514a0
--- /dev/null
+++ b/security/honggfuzz/pkg-descr
@@ -0,0 +1,5 @@
+Honggfuzz is a general-purpose fuzzing tool. Given a starting corpus of test
+files, Hongfuzz supplies and modifies input to a test program and utilize the
+ptrace() API/POSIX signal interface to detect and log crashes.
+
+WWW: http://code.google.com/p/honggfuzz/
diff --git a/security/honggfuzz/pkg-plist b/security/honggfuzz/pkg-plist
new file mode 100644
index 000000000000..65f954d84fc0
--- /dev/null
+++ b/security/honggfuzz/pkg-plist
@@ -0,0 +1,13 @@
+@comment $FreeBSD$
+bin/honggfuzz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/externalfuzzers/lowBytesIncrease.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/externalfuzzers/o20.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inputfiles/badcode1.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run-honggfuzz-on-badcode1-with-externalfuzzer.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run-honggfuzz-on-badcode1.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/targets/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/targets/badcode1.c
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/targets
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/inputfiles
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/externalfuzzers
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%