aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-09-18 05:47:23 +0800
committerpawel <pawel@FreeBSD.org>2011-09-18 05:47:23 +0800
commit21a879b53ee69d67984e5082166afb269d012b6b (patch)
tree501bb26efe81eb1a27e878cdd363a9233c30032b /security
parentd3f77900c048f6ed874cc710b9fe272d33181373 (diff)
downloadfreebsd-ports-gnome-21a879b53ee69d67984e5082166afb269d012b6b.tar.gz
freebsd-ports-gnome-21a879b53ee69d67984e5082166afb269d012b6b.tar.zst
freebsd-ports-gnome-21a879b53ee69d67984e5082166afb269d012b6b.zip
An ncurses based password database client that is compatible
with KeePass 1.x format databases. WWW: http://ckpass.sourceforge.net/ PR: ports/160676 Submitted by: Gvozdikov Veniamin <g.veniamin@googlemail.com> Approved by: miwi, wen (mentors implicit)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/ckpass/Makefile26
-rw-r--r--security/ckpass/distinfo2
-rw-r--r--security/ckpass/files/patch-bindings.c12
-rw-r--r--security/ckpass/pkg-descr4
5 files changed, 45 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 6f1a88df6aba..555f9ef24841 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -65,6 +65,7 @@
SUBDIR += chntpw
SUBDIR += chroot_safe
SUBDIR += chrootuid
+ SUBDIR += ckpass
SUBDIR += cksfv
SUBDIR += cl-md5
SUBDIR += cl-md5-clisp
diff --git a/security/ckpass/Makefile b/security/ckpass/Makefile
new file mode 100644
index 000000000000..fd3989973fbe
--- /dev/null
+++ b/security/ckpass/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ckpass
+# Date created: 2011-09-12
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ckpass
+PORTVERSION= 0.1
+CATEGORIES= security
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= An ncurses based password database client
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= kpass.0:${PORTSDIR}/security/libkpass
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= "-I${LOCALBASE}/include"
+
+PLIST_FILES= bin/ckpass
+
+.include <bsd.port.mk>
diff --git a/security/ckpass/distinfo b/security/ckpass/distinfo
new file mode 100644
index 000000000000..9a1782bba032
--- /dev/null
+++ b/security/ckpass/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ckpass-0.1.tar.gz) = 2bf19b9214127d5772fc70777e2db147ed58c809fa003fe3cbd23c361336d12e
+SIZE (ckpass-0.1.tar.gz) = 89129
diff --git a/security/ckpass/files/patch-bindings.c b/security/ckpass/files/patch-bindings.c
new file mode 100644
index 000000000000..60754f3a1cb6
--- /dev/null
+++ b/security/ckpass/files/patch-bindings.c
@@ -0,0 +1,12 @@
+--- bindings.c.orig 2011-09-12 12:31:15.000000000 +0300
++++ bindings.c 2011-09-12 12:45:59.000000000 +0300
+@@ -57,7 +57,8 @@
+ (b+1)->key = 0; /* Make last one be the terminating binding. */
+
+ /* Keep bindings sorted by command. */
+- for(b--; b >= *set && strcmp(command, b->command) < 0; b--) {
++ const char *bcommand=&b->command;
++ for(b--; b >= *set && strcmp(command, bcommand) < 0; b--) {
+ (b+1)->key = b->key;
+ (b+1)->command = b->command;
+ }
diff --git a/security/ckpass/pkg-descr b/security/ckpass/pkg-descr
new file mode 100644
index 000000000000..b0ee43e80f01
--- /dev/null
+++ b/security/ckpass/pkg-descr
@@ -0,0 +1,4 @@
+An ncurses based password database client that is compatible
+with KeePass 1.x format databases.
+
+WWW: http://ckpass.sourceforge.net/