aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-02-20 01:32:14 +0800
committerKurt Jaeger <pi@FreeBSD.org>2018-02-20 01:32:14 +0800
commit221062a86a255d4ed13b8cde43276a47c50cd507 (patch)
treee3bbc84de7def14278459ea8ffb5b72e08522963 /security
parentd1c086370131b2a1e3cdc460a48156f9dafc341b (diff)
downloadfreebsd-ports-gnome-221062a86a255d4ed13b8cde43276a47c50cd507.tar.gz
freebsd-ports-gnome-221062a86a255d4ed13b8cde43276a47c50cd507.tar.zst
freebsd-ports-gnome-221062a86a255d4ed13b8cde43276a47c50cd507.zip
security/yersinia: update 0.7.1 -> 0.8.2
PR: 222096 Approved by: ayu@commun.jp (maintainer timeout) Relnotes: https://github.com/tomac/yersinia/blob/master/ChangeLog
Diffstat (limited to 'security')
-rw-r--r--security/yersinia/Makefile29
-rw-r--r--security/yersinia/distinfo5
-rw-r--r--security/yersinia/files/patch-configure21
-rw-r--r--security/yersinia/files/patch-src_interfaces.c15
4 files changed, 15 insertions, 55 deletions
diff --git a/security/yersinia/Makefile b/security/yersinia/Makefile
index f4756f5888b6..3db23e4e24a0 100644
--- a/security/yersinia/Makefile
+++ b/security/yersinia/Makefile
@@ -2,30 +2,25 @@
# $FreeBSD$
PORTNAME= yersinia
-PORTVERSION= 0.7.1
-PORTREVISION= 2
+PORTVERSION= 0.8.2
CATEGORIES= security
-MASTER_SITES= http://www.yersinia.net/download/
+MASTER_SITES= GH
+# MASTER_SITES= http://www.yersinia.net/download/
MAINTAINER= ayu@commun.jp
COMMENT= Layer 2 vulnerability scanner (switches, spanning tree, 802.1q ...)
-LIB_DEPENDS= libnet.so:net/libnet
+LICENSE= GPLv2
-.if !defined(WITHOUT_GTK)
-.if exists(${LOCALBASE}/include/gtk-2.0/gtk/gtk.h)
-WITH_GTK= true
-.endif
-.endif
-.if defined(WITH_GTK)
-USES= pkgconfig
-USE_GNOME+= gtk20
+LIB_DEPENDS= libnet.so:net/libnet \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
+USES= autoreconf ncurses pkgconfig
+USE_GNOME+= cairo gdkpixbuf2 gtk20
PKGNAMESUFFIX= -gtk
-CONFLICTS= yersinia-[0-9]*
-.else
-CONFIGURE_ARGS+= --disable-gtk
-CONFLICTS= yersinia-gtk-[0-9]*
-.endif
+USE_GITHUB= yes
+GH_TUPLE= tomac:yersinia:8c0d7c5
GNU_CONFIGURE= yes
PLIST_FILES= sbin/yersinia \
diff --git a/security/yersinia/distinfo b/security/yersinia/distinfo
index c62fc80d2ab3..f768e9bfa5b2 100644
--- a/security/yersinia/distinfo
+++ b/security/yersinia/distinfo
@@ -1,2 +1,3 @@
-SHA256 (yersinia-0.7.1.tar.gz) = 9c473c49bba9b5271ca1cc6fb5d64314bff675772f597837341f58dc93351a17
-SIZE (yersinia-0.7.1.tar.gz) = 318396
+TIMESTAMP = 1519051893
+SHA256 (tomac-yersinia-0.8.2-8c0d7c5_GH0.tar.gz) = ad7bee0a972780ecf9e9dde794a851d5ab53d7e7de33860c840f56c51178122a
+SIZE (tomac-yersinia-0.8.2-8c0d7c5_GH0.tar.gz) = 267446
diff --git a/security/yersinia/files/patch-configure b/security/yersinia/files/patch-configure
deleted file mode 100644
index 0dd24cb602e7..000000000000
--- a/security/yersinia/files/patch-configure
+++ /dev/null
@@ -1,21 +0,0 @@
---- configure.orig 2007-01-27 04:22:30.000000000 +0900
-+++ configure 2009-08-19 22:35:11.000000000 +0900
-@@ -3470,7 +3470,8 @@
-
-
- if test -n "$GCC"; then
-- CFLAGS="-O3 -Wall -g"
-+# CFLAGS="-O3 -Wall -g"
-+:
- else
- { echo "$as_me:$LINENO: WARNING: Ouch!! Only gcc is supported..." >&5
- echo "$as_me: WARNING: Ouch!! Only gcc is supported..." >&2;}
-@@ -4462,7 +4463,7 @@
- echo $pcap_dir
- echo $dir
- echo; echo please wipe out all unused pcap installations
-- exit
-+# exit
- else
- pcap_dir="$dir"
- fi
diff --git a/security/yersinia/files/patch-src_interfaces.c b/security/yersinia/files/patch-src_interfaces.c
deleted file mode 100644
index 0880e7478a16..000000000000
--- a/security/yersinia/files/patch-src_interfaces.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/interfaces.c~ Sun Jun 18 17:23:33 2006
-+++ src/interfaces.c Sat Oct 14 07:28:41 2006
-@@ -271,10 +271,12 @@
-
- if (tty_tmp->debug)
- write_log(0,"\n interfaces_init finish...\n");
-
-+ {
- dlist_t *p;
- for (p=interfaces->list;p; p = dlist_next(interfaces->list, p)) {
- iface_data = (struct interface_data *) dlist_data(p);
-+ }
- }
-
- return 0;