aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-27 16:07:23 +0800
committerclsung <clsung@FreeBSD.org>2006-07-27 16:07:23 +0800
commit24d377754795e94c24ac954604dc6d605b109bd4 (patch)
treeae85d08704e0d9c418f549903d54c4e72e722cd4 /security
parent0f9d5a21776b9dd42fcf77970b9da2bb2f666ac8 (diff)
downloadfreebsd-ports-gnome-24d377754795e94c24ac954604dc6d605b109bd4.tar.gz
freebsd-ports-gnome-24d377754795e94c24ac954604dc6d605b109bd4.tar.zst
freebsd-ports-gnome-24d377754795e94c24ac954604dc6d605b109bd4.zip
Add courieruserinfo 1.1.2, user account information retrieval utility.
PR: ports/100900 Submitted by: Andrew St. Jean <andrew at arda.homeunix.net>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/courieruserinfo/Makefile40
-rw-r--r--security/courieruserinfo/distinfo3
-rw-r--r--security/courieruserinfo/pkg-descr5
-rw-r--r--security/courieruserinfo/pkg-message44
-rw-r--r--security/courieruserinfo/pkg-plist8
6 files changed, 101 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index af15ece37750..1e3c618f02b6 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -68,6 +68,7 @@
SUBDIR += courierpassd
SUBDIR += courierpasswd
SUBDIR += cops
+ SUBDIR += courieruserinfo
SUBDIR += cp2fwb
SUBDIR += crack
SUBDIR += cracklib
diff --git a/security/courieruserinfo/Makefile b/security/courieruserinfo/Makefile
new file mode 100644
index 000000000000..c1488c8f5a63
--- /dev/null
+++ b/security/courieruserinfo/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: courieruserinfo
+# Date created: 27th July 2006
+# Whom: Andrew St. Jean <andrew@arda.homeunix.net>
+#
+# $FreeBSD$
+
+PORTNAME= courieruserinfo
+PORTVERSION= 1.1.2
+CATEGORIES= security mail
+MASTER_SITES= http://www.arda.homeunix.net/store/
+
+MAINTAINER= andrew@arda.homeunix.net
+COMMENT= User account information retrieval utility
+
+BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
+RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS='${CPPFLAGS}' LDFLAGS='${LDFLAGS}'
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN8= courieruserinfo.8
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/security/courieruserinfo/distinfo b/security/courieruserinfo/distinfo
new file mode 100644
index 000000000000..b369c60c9523
--- /dev/null
+++ b/security/courieruserinfo/distinfo
@@ -0,0 +1,3 @@
+MD5 (courieruserinfo-1.1.2.tar.gz) = 38efe36ba1cd6a85985b21cde23a7a03
+SHA256 (courieruserinfo-1.1.2.tar.gz) = 8a3667fc90241ee40af7eb92552ca7d38f38a926beb3124c9e1ea8b7d00d0037
+SIZE (courieruserinfo-1.1.2.tar.gz) = 283493
diff --git a/security/courieruserinfo/pkg-descr b/security/courieruserinfo/pkg-descr
new file mode 100644
index 000000000000..4069a5acec81
--- /dev/null
+++ b/security/courieruserinfo/pkg-descr
@@ -0,0 +1,5 @@
+courieruserinfo is a utility for retrieving user account information.
+Account information is accessed through the courier-authlib authentication
+library.
+
+WWW: http://www.arda.homeunix.net/store/
diff --git a/security/courieruserinfo/pkg-message b/security/courieruserinfo/pkg-message
new file mode 100644
index 000000000000..0540fc049697
--- /dev/null
+++ b/security/courieruserinfo/pkg-message
@@ -0,0 +1,44 @@
+
+#########################################################################
+NOTES FOR RUNNING COURIERUSERINFO
+
+In order to use courieruserinfo, it must be able to access the
+authdaemon domain socket, named 'socket'. When courieruserinfo runs as
+root, this presents no problem. However, if you need to run courieruserinfo
+as a non-root user, you have three options, all of which require some
+manual work.
+
+Option 1: Add the user courieruserinfo will run as to the group that
+owns the authdaemon socket directory in /etc/group. More than one user
+can be added to the group vector in this way. This arrangement works
+well if courieruserinfo will be run by only a small number of users.
+If the authdaemon socket directory is owned by courier:courier and you
+run courieruserinfo as user vmail, your /etc/group file will have a line
+something like this:
+
+ courier:x:465:vmail
+
+Option 2: Some programs, such as tcpserver, allow you to separately set
+the uid and gid of programs they call but don't honour the group vector
+found in /etc/group. If you invoke courieruserinfo from such a program,
+set the gid to the group ownership of the authdaemon socket directory.
+
+Option 3: Change the permissions on courieruserinfo to set gid to the
+group ownership of the socket directory. Again, if the socket directory
+is owned by courier:courier, change the ownership and permissions
+of courieruserinfo like so:
+
+ chgrp courier courieruserinfo
+ chmod g+s courieruserinfo
+
+Be aware that this will allow any user on the system to access user
+account information through courieruserinfo.
+
+To mitigate possible security risks posed by running courieruserinfo
+setgid, courieruserinfo cannot retrieve passwords.
+
+The location of the authdaemon domain socket is listed in the
+authdaemonrc configuration file as the parameter authdaemonvar.
+
+#########################################################################
+
diff --git a/security/courieruserinfo/pkg-plist b/security/courieruserinfo/pkg-plist
new file mode 100644
index 000000000000..68e1b7733334
--- /dev/null
+++ b/security/courieruserinfo/pkg-plist
@@ -0,0 +1,8 @@
+sbin/courieruserinfo
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%