aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2014-06-15 15:12:26 +0800
committerCy Schubert <cy@FreeBSD.org>2014-06-15 15:12:26 +0800
commit25eef83f62066271e88446db07c4ce170a78df0a (patch)
tree5c98a9e2703bb517241799e3729e782759b1cdeb /security
parentb48180eb8b69991ea0ca3e6bf3b949e28cc15acf (diff)
downloadfreebsd-ports-gnome-25eef83f62066271e88446db07c4ce170a78df0a.tar.gz
freebsd-ports-gnome-25eef83f62066271e88446db07c4ce170a78df0a.tar.zst
freebsd-ports-gnome-25eef83f62066271e88446db07c4ce170a78df0a.zip
Fix build under clang and gcc 4.8.
Submitted by: dim
Diffstat (limited to 'security')
-rw-r--r--security/tripwire/Makefile1
-rw-r--r--security/tripwire/files/patch-src-core-archive.cpp13
-rw-r--r--security/tripwire/files/patch-src-core-archive.h11
-rw-r--r--security/tripwire/files/patch-src-core-displayencoder.cpp16
-rw-r--r--security/tripwire/files/patch-src-core-fsservices.h19
-rw-r--r--security/tripwire/files/patch-src-core-tw_signal.cpp11
-rw-r--r--security/tripwire/files/patch-src-core-twlocale.h11
-rw-r--r--security/tripwire/files/patch-src-core-unixfsservices.cpp11
-rw-r--r--security/tripwire/files/patch-src-core-unixfsservices.h11
-rw-r--r--security/tripwire/files/patch-src-cryptlib-algebra.h11
-rw-r--r--security/tripwire/files/patch-src-cryptlib-cryptlib.cpp13
-rw-r--r--security/tripwire/files/patch-src-fco-fcospec.cpp10
-rw-r--r--security/tripwire/files/patch-src-fco-parsergenreutil.h10
-rw-r--r--security/tripwire/files/patch-src-tripwire-mailmessage.cpp11
14 files changed, 158 insertions, 1 deletions
diff --git a/security/tripwire/Makefile b/security/tripwire/Makefile
index 307e55b4b2c0..e579f8db9a51 100644
--- a/security/tripwire/Makefile
+++ b/security/tripwire/Makefile
@@ -18,7 +18,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
MAKE_JOBS_UNSAFE= yes
USES= gmake tar:bzip2
GNU_CONFIGURE= yes
-USE_GCC= 4.6
MAKE_ARGS= SYSPRE=${ARCH}-unknown-freebsd \
DESTDIR=${STAGEDIR}
IS_INTERACTIVE= yes
diff --git a/security/tripwire/files/patch-src-core-archive.cpp b/security/tripwire/files/patch-src-core-archive.cpp
new file mode 100644
index 000000000000..15c850c4ef79
--- /dev/null
+++ b/security/tripwire/files/patch-src-core-archive.cpp
@@ -0,0 +1,13 @@
+--- src/core/archive.cpp.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/core/archive.cpp 2014-06-15 01:45:01.000000000 +0200
+@@ -886,8 +886,8 @@ void cLockedTemporaryFileArchive::OpenRe
+ catch( eFSServices& e)
+ {
+ TSTRING errStr = TSS_GetString( cCore, core::STR_BAD_TEMPDIRECTORY );
+- eArchiveOpen e(strTempFile, errStr);
+- throw e;
++ eArchiveOpen e2(strTempFile, errStr);
++ throw e2;
+ }
+ }
+ ///////////////////////////////////////////////////////////////////////////////
diff --git a/security/tripwire/files/patch-src-core-archive.h b/security/tripwire/files/patch-src-core-archive.h
new file mode 100644
index 000000000000..5eec35fd3156
--- /dev/null
+++ b/security/tripwire/files/patch-src-core-archive.h
@@ -0,0 +1,11 @@
+--- src/core/archive.h.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/core/archive.h 2014-06-15 01:51:40.000000000 +0200
+@@ -85,6 +85,8 @@ TSS_EXCEPTION( eArchiveStringTooLong, eA
+ class cArchive
+ {
+ public:
++ virtual ~cArchive() {}
++
+ // convenience methods
+ //
+ // Specific Read functions throw(eArchive) if EOF is reached because
diff --git a/security/tripwire/files/patch-src-core-displayencoder.cpp b/security/tripwire/files/patch-src-core-displayencoder.cpp
new file mode 100644
index 000000000000..b15c97ba99df
--- /dev/null
+++ b/security/tripwire/files/patch-src-core-displayencoder.cpp
@@ -0,0 +1,16 @@
+--- src/core/displayencoder.cpp.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/core/displayencoder.cpp 2014-06-15 01:46:55.000000000 +0200
+@@ -825,11 +825,10 @@ bool cEncoder::OnlyOneCatagoryPerChar()
+ {
+ bool fFailedATest = false;
+
+- ach[0] = ch;
++ TSTRING ach(1, ch);
+ for( sack_type::const_iterator atE = m_encodings.begin(); atE != m_encodings.end(); atE++ )
+ {
+- TSTRING::const_iterator first(&ach[0]), last(&ach[1]);
+- if( (*atE)->NeedsEncoding( first, last ) )
++ if( (*atE)->NeedsEncoding( ach.begin(), ach.end() ) )
+ {
+ if( fFailedATest )
+ return false; // each char can only fail one test
diff --git a/security/tripwire/files/patch-src-core-fsservices.h b/security/tripwire/files/patch-src-core-fsservices.h
new file mode 100644
index 000000000000..f3cea82095c4
--- /dev/null
+++ b/security/tripwire/files/patch-src-core-fsservices.h
@@ -0,0 +1,19 @@
+--- src/core/fsservices.h.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/core/fsservices.h 2014-06-15 01:54:49.000000000 +0200
+@@ -177,6 +177,7 @@ TSS_FILE_EXCEPTION( eFSServicesGeneric,
+ class iFSServices
+ {
+ public:
++ virtual ~iFSServices() {}
+
+ ///////////////////////////////////////////////////////////////
+ // ENUMS
+@@ -219,7 +220,7 @@ class iFSServices
+ // returns true if the file system is case sensitive
+ virtual TCHAR GetPathSeperator() const = 0;
+ // returns "/" for unix and "\\" for win32
+- virtual TCHAR* GetStandardBackupExtension() const = 0;
++ virtual const TCHAR* GetStandardBackupExtension() const = 0;
+ // returns normal string to append to backup files for this os.
+
+ ////////////////////////////////////////
diff --git a/security/tripwire/files/patch-src-core-tw_signal.cpp b/security/tripwire/files/patch-src-core-tw_signal.cpp
new file mode 100644
index 000000000000..d5ef2dde2cf9
--- /dev/null
+++ b/security/tripwire/files/patch-src-core-tw_signal.cpp
@@ -0,0 +1,11 @@
+--- src/core/tw_signal.cpp.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/core/tw_signal.cpp 2014-06-15 01:48:28.000000000 +0200
+@@ -79,7 +79,7 @@ void util_SignalHandler( int sig )
+ #if IS_UNIX
+ void tw_psignal(int sig, const TCHAR *str)
+ {
+- TCHAR *siglist[NSIG] = {
++ const TCHAR *siglist[NSIG] = {
+ _T("Unknown Signal"),
+ _T("Hangup"),
+ _T("Interrupt"),
diff --git a/security/tripwire/files/patch-src-core-twlocale.h b/security/tripwire/files/patch-src-core-twlocale.h
new file mode 100644
index 000000000000..361fe105005f
--- /dev/null
+++ b/security/tripwire/files/patch-src-core-twlocale.h
@@ -0,0 +1,11 @@
+--- src/core/twlocale.h.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/core/twlocale.h 2014-06-15 01:48:46.000000000 +0200
+@@ -110,7 +110,7 @@ namespace tss
+ #if USE_STD_CPP_LOCALE_WORKAROUND
+ return std::use_facet( l, pf );
+ #else
+- return std::use_facet< FacetT >( l ); pf; // This is C++ standard
++ return std::use_facet< FacetT >( l ); (void)pf; // This is C++ standard
+ #endif
+ }
+ }
diff --git a/security/tripwire/files/patch-src-core-unixfsservices.cpp b/security/tripwire/files/patch-src-core-unixfsservices.cpp
new file mode 100644
index 000000000000..3e44044735f2
--- /dev/null
+++ b/security/tripwire/files/patch-src-core-unixfsservices.cpp
@@ -0,0 +1,11 @@
+--- src/core/unixfsservices.cpp.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/core/unixfsservices.cpp 2014-06-15 01:44:45.000000000 +0200
+@@ -792,7 +792,7 @@ bool cUnixFSServices::FullPath( TSTRING&
+ // Returns normal string to append to backup files for this os.
+ // (e.g. "~" for unix and ".bak" for winos)
+ ///////////////////////////////////////////////////////////////////////////////
+-TCHAR* cUnixFSServices::GetStandardBackupExtension() const
++const TCHAR* cUnixFSServices::GetStandardBackupExtension() const
+ {
+ return _T(".bak");
+ }
diff --git a/security/tripwire/files/patch-src-core-unixfsservices.h b/security/tripwire/files/patch-src-core-unixfsservices.h
new file mode 100644
index 000000000000..ab2fec5bdb18
--- /dev/null
+++ b/security/tripwire/files/patch-src-core-unixfsservices.h
@@ -0,0 +1,11 @@
+--- src/core/unixfsservices.h.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/core/unixfsservices.h 2014-06-15 01:44:45.000000000 +0200
+@@ -99,7 +99,7 @@ class cUnixFSServices : public iFSServic
+ ////////////////////////////////////////
+ virtual bool IsCaseSensitive() const;
+ // returns true if the file system is case sensitive
+- virtual TCHAR* GetStandardBackupExtension() const;
++ virtual const TCHAR* GetStandardBackupExtension() const;
+ // returns normal string to append to backup files for this os.
+ // (e.g. "~" for unix and ".bak" for winos)
+ virtual TCHAR GetPathSeperator() const;
diff --git a/security/tripwire/files/patch-src-cryptlib-algebra.h b/security/tripwire/files/patch-src-cryptlib-algebra.h
new file mode 100644
index 000000000000..af4a03e9d92e
--- /dev/null
+++ b/security/tripwire/files/patch-src-cryptlib-algebra.h
@@ -0,0 +1,11 @@
+--- src/cryptlib/algebra.h.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/cryptlib/algebra.h 2014-06-15 01:42:42.000000000 +0200
+@@ -273,7 +273,7 @@ template <class T> T AbstractEuclideanDo
+ Element g[3]={b, a};
+ unsigned int i0=0, i1=1, i2=2;
+
+- while (!Equal(g[i1], this->Zero()))
++ while (!this->Equal(g[i1], this->Zero()))
+ {
+ g[i2] = Mod(g[i0], g[i1]);
+ unsigned int t = i0; i0 = i1; i1 = i2; i2 = t;
diff --git a/security/tripwire/files/patch-src-cryptlib-cryptlib.cpp b/security/tripwire/files/patch-src-cryptlib-cryptlib.cpp
new file mode 100644
index 000000000000..035cb6bdd9da
--- /dev/null
+++ b/security/tripwire/files/patch-src-cryptlib-cryptlib.cpp
@@ -0,0 +1,13 @@
+--- src/cryptlib/cryptlib.cpp.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/cryptlib/cryptlib.cpp 2014-06-15 01:42:35.000000000 +0200
+@@ -43,8 +43,8 @@ void StreamCipher::ProcessString(byte *o
+
+ void StreamCipher::ProcessString(byte *inoutString, unsigned int length)
+ {
+- while(length--)
+- *inoutString++ = ProcessByte(*inoutString);
++ for(;length--; inoutString++)
++ *inoutString = ProcessByte(*inoutString);
+ }
+
+ bool MessageAuthenticationCode::Verify(const byte *macIn)
diff --git a/security/tripwire/files/patch-src-fco-fcospec.cpp b/security/tripwire/files/patch-src-fco-fcospec.cpp
new file mode 100644
index 000000000000..1b992f9e9872
--- /dev/null
+++ b/security/tripwire/files/patch-src-fco-fcospec.cpp
@@ -0,0 +1,10 @@
+--- src/fco/fcospec.cpp.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/fco/fcospec.cpp 2014-06-15 01:50:46.000000000 +0200
+@@ -51,6 +51,7 @@
+ class cDefaultSpecMask : public iFCOSpecMask
+ {
+ public:
++ cDefaultSpecMask() {}
+ virtual const TSTRING& GetName() const;
+ virtual bool Accept(const iFCO* pFCO) const;
+ private:
diff --git a/security/tripwire/files/patch-src-fco-parsergenreutil.h b/security/tripwire/files/patch-src-fco-parsergenreutil.h
new file mode 100644
index 000000000000..76f5c5f6c8e9
--- /dev/null
+++ b/security/tripwire/files/patch-src-fco-parsergenreutil.h
@@ -0,0 +1,10 @@
+--- src/fco/parsergenreutil.h.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/fco/parsergenreutil.h 2014-06-15 01:55:46.000000000 +0200
+@@ -53,6 +53,7 @@ class cFCOName;
+ class iParserGenreUtil
+ {
+ public:
++ virtual ~iParserGenreUtil() {}
+ virtual bool MapStringToProperty( const TSTRING& str, int& propIndex ) const = 0;
+ // maps the given string to an index into a property vector for the genre
+ virtual void AddSubTypeProps( cFCOPropVector& v ) const = 0;
diff --git a/security/tripwire/files/patch-src-tripwire-mailmessage.cpp b/security/tripwire/files/patch-src-tripwire-mailmessage.cpp
new file mode 100644
index 000000000000..fd642442696e
--- /dev/null
+++ b/security/tripwire/files/patch-src-tripwire-mailmessage.cpp
@@ -0,0 +1,11 @@
+--- src/tripwire/mailmessage.cpp.orig 2011-11-21 17:06:56.000000000 +0100
++++ src/tripwire/mailmessage.cpp 2014-06-15 01:56:20.000000000 +0200
+@@ -258,7 +258,7 @@ bool cMailMessageUtil::ReadDate( TSTRING
+ }
+
+
+-static char* util_Get_IANA_CharSet()
++static const char* util_Get_IANA_CharSet()
+ {
+ const char* pCP = setlocale( LC_CTYPE, NULL );
+