aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2015-02-06 17:59:17 +0800
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2015-02-06 17:59:17 +0800
commit26ead078cae969594fb76c8495b63128efc4b494 (patch)
tree31eb37d036918ce62829b6d2f00b46d3245a1a88 /security
parent21ceda0cc8e83a703466720500ffd140fbd5e867 (diff)
downloadfreebsd-ports-gnome-26ead078cae969594fb76c8495b63128efc4b494.tar.gz
freebsd-ports-gnome-26ead078cae969594fb76c8495b63128efc4b494.tar.zst
freebsd-ports-gnome-26ead078cae969594fb76c8495b63128efc4b494.zip
- Fix assembler opcodes on i386
- Fix build on FreeBSD < 10 - Do not bump revision since this only affects broken systems
Diffstat (limited to 'security')
-rw-r--r--security/hpenc/Makefile8
-rw-r--r--security/hpenc/files/patch-poly1305-i386-asm22
2 files changed, 29 insertions, 1 deletions
diff --git a/security/hpenc/Makefile b/security/hpenc/Makefile
index 8febca8b1cad..5f626c481a3b 100644
--- a/security/hpenc/Makefile
+++ b/security/hpenc/Makefile
@@ -20,7 +20,13 @@ CXXFLAGS+= -std=c++11 \
-I${WRKSRC}/poly1305-opt/app/include
LDFLAGS+= -pthread -lcrypto
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000036
+WITH_OPENSSL_PORT= yes
+.endif
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/hpenc
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/hpenc/files/patch-poly1305-i386-asm b/security/hpenc/files/patch-poly1305-i386-asm
new file mode 100644
index 000000000000..0747c06ed501
--- /dev/null
+++ b/security/hpenc/files/patch-poly1305-i386-asm
@@ -0,0 +1,22 @@
+--- poly1305-opt/app/extensions/poly1305/poly1305_avx-32.inc
++++ poly1305-opt/app/extensions/poly1305/poly1305_avx-32.inc
+@@ -7,7 +7,7 @@ FN_END poly1305_block_size_avx
+
+
+ GLOBAL_HIDDEN_FN poly1305_auth_avx
++cmpl $64, 12(%esp)
+-cmp $64, 12(%esp)
+ jbe poly1305_auth_x86_local
+ pushl %ebp
+ movl %esp, %ebp
+--- poly1305-opt/app/extensions/poly1305/poly1305_avx2-32.inc
++++ poly1305-opt/app/extensions/poly1305/poly1305_avx2-32.inc
+@@ -8,7 +8,7 @@ FN_END poly1305_block_size_avx2
+
+
+ GLOBAL_HIDDEN_FN poly1305_auth_avx2
++cmpl $64, 12(%esp)
+-cmp $64, 12(%esp)
+ jbe poly1305_auth_x86_local
+ pushl %ebp
+ movl %esp, %ebp