aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2012-05-16 17:46:51 +0800
committerflo <flo@FreeBSD.org>2012-05-16 17:46:51 +0800
commit279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19 (patch)
tree2de93387d7ad1df58a7807b573d91395f20dccb9 /security
parent604a42f7a6032c5db4396ed6acc540dc4fc691c4 (diff)
downloadfreebsd-ports-gnome-279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19.tar.gz
freebsd-ports-gnome-279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19.tar.zst
freebsd-ports-gnome-279ccadd7d5cb268f7aaa2ea5100cd9b2abfdd19.zip
readd php 5.3.13 and all its modules as php53*
Diffstat (limited to 'security')
-rw-r--r--security/Makefile4
-rw-r--r--security/php53-filter/Makefile14
-rw-r--r--security/php53-filter/files/patch-config.m410
-rw-r--r--security/php53-hash/Makefile14
-rw-r--r--security/php53-mcrypt/Makefile14
-rw-r--r--security/php53-openssl/Makefile14
6 files changed, 70 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index cb4da141760b..6eea7e3500a7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -668,6 +668,10 @@
SUBDIR += php52-mcrypt
SUBDIR += php52-mhash
SUBDIR += php52-openssl
+ SUBDIR += php53-filter
+ SUBDIR += php53-hash
+ SUBDIR += php53-mcrypt
+ SUBDIR += php53-openssl
SUBDIR += phpdeadlock
SUBDIR += phpsecinfo
SUBDIR += pidentd
diff --git a/security/php53-filter/Makefile b/security/php53-filter/Makefile
new file mode 100644
index 000000000000..68dd012c8460
--- /dev/null
+++ b/security/php53-filter/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-filter
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -filter
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/php53-filter/files/patch-config.m4 b/security/php53-filter/files/patch-config.m4
new file mode 100644
index 000000000000..ab64c6c9d5ad
--- /dev/null
+++ b/security/php53-filter/files/patch-config.m4
@@ -0,0 +1,10 @@
+--- config.m4.orig 2009-03-06 08:25:45.000000000 +0100
++++ config.m4 2009-03-06 08:28:10.000000000 +0100
+@@ -32,6 +32,7 @@
+ #endif
+ ],[
+ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
+ ],[
+ PHP_PCRE_REGEX=no
+ ])
diff --git a/security/php53-hash/Makefile b/security/php53-hash/Makefile
new file mode 100644
index 000000000000..fc4b7fc62cc9
--- /dev/null
+++ b/security/php53-hash/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-hash
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -hash
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/php53-mcrypt/Makefile b/security/php53-mcrypt/Makefile
new file mode 100644
index 000000000000..24e9f45be88d
--- /dev/null
+++ b/security/php53-mcrypt/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-mcrypt
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -mcrypt
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/php53-openssl/Makefile b/security/php53-openssl/Makefile
new file mode 100644
index 000000000000..64373c5fdcc8
--- /dev/null
+++ b/security/php53-openssl/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php53-openssl
+# Date created: 12 Apr 2012
+# Whom: Florian Smeets <flo@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php53
+
+PKGNAMESUFFIX= -openssl
+
+.include "${MASTERDIR}/Makefile"