aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-20 22:49:19 +0800
committererwin <erwin@FreeBSD.org>2005-12-20 22:49:19 +0800
commit27a1124b79b52c853c1f2916e92a9690917d0ea5 (patch)
treef2225f4bf68566abc626c956806d7d6252979a8f /security
parent005529608d01df0b6c85bb1234dff7484c597a6e (diff)
downloadfreebsd-ports-gnome-27a1124b79b52c853c1f2916e92a9690917d0ea5.tar.gz
freebsd-ports-gnome-27a1124b79b52c853c1f2916e92a9690917d0ea5.tar.zst
freebsd-ports-gnome-27a1124b79b52c853c1f2916e92a9690917d0ea5.zip
The Data Encryption Standard (DES), also known as Data
Encryption Algorithm (DEA) is a semi-strong encryption and decryption algorithm. The module is 100 % compatible to Crypt::DES but is implemented entirely in Perl. That means that you do not need a C compiler to build and install this extension. WWW: http://search.cpan.org/dist/Crypt-DES_PP PR: ports/90682 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-DES_PP/Makefile24
-rw-r--r--security/p5-Crypt-DES_PP/distinfo3
-rw-r--r--security/p5-Crypt-DES_PP/pkg-descr23
-rw-r--r--security/p5-Crypt-DES_PP/pkg-plist5
5 files changed, 56 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e6e86d74a66a..1b5e8bda42e0 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -297,6 +297,7 @@
SUBDIR += p5-Crypt-Ctr
SUBDIR += p5-Crypt-DES
SUBDIR += p5-Crypt-DES_EDE3
+ SUBDIR += p5-Crypt-DES_PP
SUBDIR += p5-Crypt-DH
SUBDIR += p5-Crypt-DSA
SUBDIR += p5-Crypt-ECB
diff --git a/security/p5-Crypt-DES_PP/Makefile b/security/p5-Crypt-DES_PP/Makefile
new file mode 100644
index 000000000000..eb801a09cbf7
--- /dev/null
+++ b/security/p5-Crypt-DES_PP/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-DES_PP
+# Date created: 20 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-DES_PP
+PORTVERSION= 1.00
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for DES encryption in pure Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::DES_PP.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-DES_PP/distinfo b/security/p5-Crypt-DES_PP/distinfo
new file mode 100644
index 000000000000..1ed81e636036
--- /dev/null
+++ b/security/p5-Crypt-DES_PP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-DES_PP-1.00.tar.gz) = 2fdfee7afd3ffabdc85297b15e60d270
+SHA256 (Crypt-DES_PP-1.00.tar.gz) = 21ce10b688db039a16c4473ac539f29746430382490cbd30c3b66c075f583d38
+SIZE (Crypt-DES_PP-1.00.tar.gz) = 34796
diff --git a/security/p5-Crypt-DES_PP/pkg-descr b/security/p5-Crypt-DES_PP/pkg-descr
new file mode 100644
index 000000000000..69ebb2e9e135
--- /dev/null
+++ b/security/p5-Crypt-DES_PP/pkg-descr
@@ -0,0 +1,23 @@
+The Data Encryption Standard (DES), also known as Data
+Encryption Algorithm (DEA) is a semi-strong encryption and
+decryption algorithm.
+The module is 100 % compatible to Crypt::DES but is implemented
+entirely in Perl. That means that you do not need a C compiler
+to build and install this extension.
+The module implements the Crypt::CBC interface. You are
+encouraged to read the documentation for Crypt::CBC if you
+intend to use this module for Cipher Block Chaining.
+The minimum (and maximum) key size is 8 bytes. Shorter keys will
+cause an exception, longer keys will get silently truncated.
+Data is encrypted and decrypted in blocks of 8 bytes.
+The module implements the Ultra-Fast-Crypt (UFC) algorithm as
+found for example in the GNU libc. On the Perl side a lot has
+been done in order to make the module as fast as possible
+(function inlining, use integer, ...).
+Note: For performance issues the source code for the module is
+first preprocessed by m4. That means that you need an m4 macro
+processor in order to hack on the sources. This is of no concern
+for you if you only want to use the module, the preprocessed
+output is always included in the distribution.
+
+WWW: http://search.cpan.org/dist/Crypt-DES_PP
diff --git a/security/p5-Crypt-DES_PP/pkg-plist b/security/p5-Crypt-DES_PP/pkg-plist
new file mode 100644
index 000000000000..b490ea7d7e32
--- /dev/null
+++ b/security/p5-Crypt-DES_PP/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/DES_PP.pm
+%%SITE_PERL%%/Crypt/.cvsignore
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt-DES_PP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt-DES_PP/
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true