aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2007-07-27 22:41:07 +0800
committerchinsan <chinsan@FreeBSD.org>2007-07-27 22:41:07 +0800
commit2802be6ca65340fa32c138e78b87a08a54457232 (patch)
tree5fb26a5763ecb320836c444abb6a37c0138395c4 /security
parent32cdb5dbe56740b390da9113de8e618acfef728e (diff)
downloadfreebsd-ports-gnome-2802be6ca65340fa32c138e78b87a08a54457232.tar.gz
freebsd-ports-gnome-2802be6ca65340fa32c138e78b87a08a54457232.tar.zst
freebsd-ports-gnome-2802be6ca65340fa32c138e78b87a08a54457232.zip
Add chntpw 070409, utility to set the password and edit registry on
Microsoft NT system. PR: ports/114897 Submitted by: buganini at gmail.com Approved by: rafan (mentor, implicit)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/chntpw/Makefile37
-rw-r--r--security/chntpw/distinfo3
-rw-r--r--security/chntpw/pkg-descr9
4 files changed, 50 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4559cd2046a4..457b2b3479e3 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -63,6 +63,7 @@
SUBDIR += checkpassword
SUBDIR += checkpassword-pam
SUBDIR += chkrootkit
+ SUBDIR += chntpw
SUBDIR += chroot_safe
SUBDIR += chrootuid
SUBDIR += cksfv
diff --git a/security/chntpw/Makefile b/security/chntpw/Makefile
new file mode 100644
index 000000000000..f4e9e4f4c580
--- /dev/null
+++ b/security/chntpw/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: chntpw
+# Date created: 25 July 2007
+# Whom: buganini@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= chntpw
+PORTVERSION= 070409
+CATEGORIES= security sysutils
+MASTER_SITES= http://home.eunet.no/pnordahl/ntpasswd/
+DISTNAME= ${PORTNAME}-source-${PORTVERSION}
+
+MAINTAINER= buganini@gmail.com
+COMMENT= Utility to set the password and edit registry on Microsoft NT system
+
+USE_ZIP= yes
+USE_GMAKE= yes
+USE_OPENSSL= yes
+
+PLIST_FILES= bin/chntpw
+PORTDOCS= README.txt WinReg.txt regedit.txt
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e '10 s,/usr,$$\(OPENSSLBASE\),' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/chntpw ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/chntpw/distinfo b/security/chntpw/distinfo
new file mode 100644
index 000000000000..ee3cd027be2c
--- /dev/null
+++ b/security/chntpw/distinfo
@@ -0,0 +1,3 @@
+MD5 (chntpw-source-070409.zip) = 8953c585b907d54e74066300467f0730
+SHA256 (chntpw-source-070409.zip) = f12a068134d7184400314f3c2c71a8de75bdc6c51d1e580179a83a0510adec12
+SIZE (chntpw-source-070409.zip) = 385040
diff --git a/security/chntpw/pkg-descr b/security/chntpw/pkg-descr
new file mode 100644
index 000000000000..b62ef700471b
--- /dev/null
+++ b/security/chntpw/pkg-descr
@@ -0,0 +1,9 @@
+* This is a utility to (re)set the password of any user that has a valid
+ (local) account on your NT system.
+* You do not need to know the old password to set a new one.
+* It works offline, that is, you have to shutdown your computer and boot off
+ a floppydisk or CD.
+* Will detect and offer to unlock locked or disabled out user accounts!
+* It is also an almost fully functional registry editor!
+
+WWW: http://home.eunet.no/pnordahl/ntpasswd/