aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-08-05 17:11:10 +0800
committerKai Knoblich <kai@FreeBSD.org>2019-08-05 17:11:10 +0800
commit290250d0d7a7c14bf476d3c1cfa6cb3e5a0e9dd8 (patch)
treed1dc94671967fd078ffcffde4f113e9058797639 /security
parent875c0689734938054faeba75cbc6de5b5e7c4cb6 (diff)
downloadfreebsd-ports-gnome-290250d0d7a7c14bf476d3c1cfa6cb3e5a0e9dd8.tar.gz
freebsd-ports-gnome-290250d0d7a7c14bf476d3c1cfa6cb3e5a0e9dd8.tar.zst
freebsd-ports-gnome-290250d0d7a7c14bf476d3c1cfa6cb3e5a0e9dd8.zip
security/py-openssl: Update to 19.0.0
While I'm here: * Improve the "do-test" target to easen future QA and add the required dependencies for it. * Sort variables a bit according to the PHB to pet portclippy/portlint. Changelog: Backward-incompatible changes: * X509Store.add_cert no longer raises an error if one add a duplicate cert * pyOpenSSL now works with OpenSSL 1.1.1 * pyOpenSSL now handles NUL bytes in X509Name.get_components() PR: 237006 Submitted by: timp87@gmail.com (based on) Approved by: sbz (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/py-openssl/Makefile24
-rw-r--r--security/py-openssl/distinfo4
2 files changed, 22 insertions, 6 deletions
diff --git a/security/py-openssl/Makefile b/security/py-openssl/Makefile
index 2265cb837255..676084e854fe 100644
--- a/security/py-openssl/Makefile
+++ b/security/py-openssl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openssl
-PORTVERSION= 18.0.0
+PORTVERSION= 19.0.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,8 +16,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.2.1:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.5.2:devel/py-six@${PY_FLAVOR}
-
-OPTIONS_DEFINE= EXAMPLES
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.0.1:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}flaky>0:devel/py-flaky@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pretend>0:devel/py-pretend@${PY_FLAVOR} \
+ ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
USES= cpe python
USE_PYTHON= autoplist concurrent distutils pythonprefix
@@ -29,11 +31,25 @@ CPE_PRODUCT= py${PORTNAME}
PORTEXAMPLES= *
+OPTIONS_DEFINE= EXAMPLES
+
post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+# These tests will be skipped due the following reasons:
+#
+# * test_connect_refused: Avoid stalling in build environments that don't have
+# a internet connection
+# * test_set_verify_callback_exception: Fails on *BSD systems, see also
+# https://github.com/pyca/pyopenssl/issues/656 for further details
+#
+# The system clock must be in sync otherwise the test "test_verify_with_time"
+# will fail.
do-test:
- @(cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test)
+ @cd ${WRKSRC} && \
+ ${SET_ENV} LC_ALL=en_US.UTF-8 ${PYTHON_CMD} -m pytest -rs -v -k ' \
+ not test_connect_refused and \
+ not test_set_verify_callback_exception'
.include <bsd.port.mk>
diff --git a/security/py-openssl/distinfo b/security/py-openssl/distinfo
index 8fdc00c65521..dd471a7396ca 100644
--- a/security/py-openssl/distinfo
+++ b/security/py-openssl/distinfo
@@ -1,3 +1,3 @@
TIMESTAMP = 1540136888
-SHA256 (pyOpenSSL-18.0.0.tar.gz) = 6488f1423b00f73b7ad5167885312bb0ce410d3312eb212393795b53c8caa580
-SIZE (pyOpenSSL-18.0.0.tar.gz) = 167296
+SHA256 (pyOpenSSL-19.0.0.tar.gz) = aeca66338f6de19d1aa46ed634c3b9ae519a64b458f8468aec688e7e3c20f200
+SIZE (pyOpenSSL-19.0.0.tar.gz) = 168551