aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoreugen <eugen@FreeBSD.org>2017-05-19 17:46:16 +0800
committereugen <eugen@FreeBSD.org>2017-05-19 17:46:16 +0800
commit2b212c35ee87e6794d97b3b1748a759cbbe39d12 (patch)
tree997b83045f6fbe6c62b98ec8d6c08c706ec92753 /security
parent3e298ace88d0d1d9b4396173eb558b8763fe1e5d (diff)
downloadfreebsd-ports-gnome-2b212c35ee87e6794d97b3b1748a759cbbe39d12.tar.gz
freebsd-ports-gnome-2b212c35ee87e6794d97b3b1748a759cbbe39d12.tar.zst
freebsd-ports-gnome-2b212c35ee87e6794d97b3b1748a759cbbe39d12.zip
Make nmap work with INET4-only kernels:
- add new FreeBSD-specific patch; - remove invalid comment from Makefile (it did build but produced run-time error); - bump PORTREVISION. PR: 217558 Approved by: ohauer (maintainer timeout, 10 weeks), vsevolod (mentor)
Diffstat (limited to 'security')
-rw-r--r--security/nmap/Makefile2
-rw-r--r--security/nmap/files/patch-intf.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index 374c9bd8d503..17d813f284e4 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nmap
DISTVERSION= 7.40
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
@@ -24,7 +25,6 @@ LIB_DEPENDS= libpcre.so:devel/pcre
USES= tar:bzip2 gmake cpe
GNU_CONFIGURE= yes
-# Note: nmap does no longer build agains custom kernel without IPv6!
OPTIONS_SUB= yes
OPTIONS_DEFINE= DOCS SSL
OPTIONS_DEFAULT=SSL
diff --git a/security/nmap/files/patch-intf.c b/security/nmap/files/patch-intf.c
new file mode 100644
index 000000000000..b00c4a17e91e
--- /dev/null
+++ b/security/nmap/files/patch-intf.c
@@ -0,0 +1,11 @@
+--- libdnet-stripped/src/intf.c.orig 2017-03-05 16:19:13.768984000 +0700
++++ libdnet-stripped/src/intf.c 2017-03-05 16:16:48.337379000 +0700
+@@ -163,7 +163,7 @@ intf_open(void)
+ #if defined(SIOCGLIFCONF) || defined(SIOCGIFNETMASK_IN6) || defined(SIOCGIFNETMASK6)
+ if ((intf->fd6 = socket(AF_INET6, SOCK_DGRAM, 0)) < 0) {
+ # ifdef EPROTONOSUPPORT
+- if (errno != EPROTONOSUPPORT)
++ if (errno != EPROTONOSUPPORT && errno != EAFNOSUPPORT)
+ # endif
+ return (intf_close(intf));
+ }