aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2013-10-06 06:04:31 +0800
committercs <cs@FreeBSD.org>2013-10-06 06:04:31 +0800
commit2c3624fe22273477ee34b88c3edbae9d54deb809 (patch)
tree551eb94198b5cab7cc2513dffe774daf34e84ec6 /security
parent7b525385d6065629807e0c7749898adfa1462639 (diff)
downloadfreebsd-ports-gnome-2c3624fe22273477ee34b88c3edbae9d54deb809.tar.gz
freebsd-ports-gnome-2c3624fe22273477ee34b88c3edbae9d54deb809.tar.zst
freebsd-ports-gnome-2c3624fe22273477ee34b88c3edbae9d54deb809.zip
Update to 1.2.2
Diffstat (limited to 'security')
-rw-r--r--security/py-gnupg/Makefile16
-rw-r--r--security/py-gnupg/distinfo4
-rw-r--r--security/py-gnupg/pkg-descr14
-rw-r--r--security/py-gnupg/pkg-plist3
4 files changed, 22 insertions, 15 deletions
diff --git a/security/py-gnupg/Makefile b/security/py-gnupg/Makefile
index b8463600ad1d..89c31d2c9382 100644
--- a/security/py-gnupg/Makefile
+++ b/security/py-gnupg/Makefile
@@ -2,18 +2,22 @@
# $FreeBSD$
PORTNAME= gnupg
-PORTVERSION= 0.3.2
+PORTVERSION= 1.2.2
CATEGORIES= security python
-MASTER_SITES= SF/py-${PORTNAME}/GnuPGInterface/${PORTVERSION}
+MASTER_SITES= http://www.c-s.li/ports/ \
+ CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= GnuPGInterface-${PORTVERSION}
MAINTAINER= cs@FreeBSD.org
-COMMENT= Python module for GnuPG interface
+COMMENT= Python wrapper for GnuPG
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psutil>=0.5.1:${PORTSDIR}/sysutils/py-psutil
USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_PKGNAME= GnuPGInterface
+USE_PYDISTUTILS=easy_install
+PYDISTUTILS_AUTOPLIST=yes
NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/security/py-gnupg/distinfo b/security/py-gnupg/distinfo
index c80deb598c97..8d892200a474 100644
--- a/security/py-gnupg/distinfo
+++ b/security/py-gnupg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (GnuPGInterface-0.3.2.tar.gz) = 0ea672251e2e3f71b62fef0c01539519d500f6b338f803af6b57e67a73cca8e6
-SIZE (GnuPGInterface-0.3.2.tar.gz) = 19875
+SHA256 (gnupg-1.2.2.tar.gz) = 0062528de9daf02876a0b77749517d4a0a8988eb4fd77d0cf653c364cc3b1142
+SIZE (gnupg-1.2.2.tar.gz) = 64587
diff --git a/security/py-gnupg/pkg-descr b/security/py-gnupg/pkg-descr
index 25fd9211147a..1d767b77b5d3 100644
--- a/security/py-gnupg/pkg-descr
+++ b/security/py-gnupg/pkg-descr
@@ -1,5 +1,11 @@
-GnuPGInterface is a Python module to interface with GnuPG . It concentrates
-on interacting with GnuPG via filehandles, providing access to control GnuPG
-via versatile and extensible means.
+This module allows easy access to GnuPG's key management, encryption and
+signature functionality from Python programs, by interacting with GnuPG through
+file descriptors. Input arguments are strictly checked and sanitised, and
+therefore this module should be safe to use in networked applications requiring
+direct user input. It is intended for use with Python 2.6 or greater.
-WWW: http://py-gnupg.sourceforge.net/
+This is a fork of python-gnupg-0.3.2, patched to fix a potential vulnerability
+which could result in remote code execution, do to unsanitised inputs being
+passed to subprocess.Popen([...], shell=True).
+
+WWW: https://github.com/isislovecruft/python-gnupg
diff --git a/security/py-gnupg/pkg-plist b/security/py-gnupg/pkg-plist
deleted file mode 100644
index d1263c662d25..000000000000
--- a/security/py-gnupg/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%PYTHON_SITELIBDIR%%/GnuPGInterface.py
-%%PYTHON_SITELIBDIR%%/GnuPGInterface.pyc
-%%PYTHON_SITELIBDIR%%/GnuPGInterface.pyo