aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2015-12-15 13:02:21 +0800
committercy <cy@FreeBSD.org>2015-12-15 13:02:21 +0800
commit2e21690a4438b31c3fa0ba0bbffdbedc3b2d30fe (patch)
tree3f3efa97d551a4e9014f852b533b47155bfc65e4 /security
parent0a9ceb616cfcec192605b8e54bc54d103686dba0 (diff)
downloadfreebsd-ports-gnome-2e21690a4438b31c3fa0ba0bbffdbedc3b2d30fe.tar.gz
freebsd-ports-gnome-2e21690a4438b31c3fa0ba0bbffdbedc3b2d30fe.tar.zst
freebsd-ports-gnome-2e21690a4438b31c3fa0ba0bbffdbedc3b2d30fe.zip
This is the second part of two commits, the first being r403749.
Adopt the same port structure as used by the cfengine family of ports: security/krb5 is renamed to security/krb5-114. A brand new security/krb5 now becomes a master port for the family of security/krb5-* ports. The default installs krb5-1.14. There is no functional change to the port build nor does the name of the latest krb5 port and package change. Users can continue to install security/krb5 to track the latest major version of security/krb5. Users wishing to install a specific version branch of krb5 can continue to install any of the security/krb5-* ports or by setting KRB5_VERSION in make.conf make.conf or including the branch on the make command line during build: make KRB5_VERSIN=NNN make -V VERSIONS lists available versions. security/krb5-appl has been updated to support this change (also fixing a typo in the krb5-appl/Makefile). Inspired by: sysutils/cfengine
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/krb5-112/Makefile2
-rw-r--r--security/krb5-113/Makefile2
-rw-r--r--security/krb5-114/Makefile4
-rw-r--r--security/krb5-appl/Makefile9
-rw-r--r--security/krb5/Makefile8
6 files changed, 24 insertions, 2 deletions
diff --git a/security/Makefile b/security/Makefile
index 513efea381ed..45ca1c1d438a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -269,6 +269,7 @@
SUBDIR += krb5
SUBDIR += krb5-112
SUBDIR += krb5-113
+ SUBDIR += krb5-114
SUBDIR += krb5-appl
SUBDIR += kripp
SUBDIR += kstart
diff --git a/security/krb5-112/Makefile b/security/krb5-112/Makefile
index 5a6637154d86..8058c0eb5b72 100644
--- a/security/krb5-112/Makefile
+++ b/security/krb5-112/Makefile
@@ -6,7 +6,9 @@ PORTVERSION= 1.12.4
PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
+.if !defined(MASTERDIR)
PKGNAMESUFFIX= -112
+.endif
DISTNAME= ${PORTNAME}-${PORTVERSION}-signed
EXTRACT_SUFX= .tar
diff --git a/security/krb5-113/Makefile b/security/krb5-113/Makefile
index 776c44baf247..39666890962c 100644
--- a/security/krb5-113/Makefile
+++ b/security/krb5-113/Makefile
@@ -5,7 +5,9 @@ PORTNAME= krb5
PORTVERSION= 1.13.3
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
+.if !defined(MASTERDIR)
PKGNAMESUFFIX= -113
+.endif
PATCH_SITES= http://web.mit.edu/kerberos/advisories/
PATCH_DIST_STRIP= -p2
diff --git a/security/krb5-114/Makefile b/security/krb5-114/Makefile
index 07f72d1b7bcf..590afbe67deb 100644
--- a/security/krb5-114/Makefile
+++ b/security/krb5-114/Makefile
@@ -5,6 +5,10 @@ PORTNAME= krb5
PORTVERSION= 1.14
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
+.if !defined(MASTERDIR)
+PKGNAMESUFFIX= -114
+.endif
+
PATCH_SITES= http://web.mit.edu/kerberos/advisories/
PATCH_DIST_STRIP= -p2
diff --git a/security/krb5-appl/Makefile b/security/krb5-appl/Makefile
index 606d341c875a..374c7693477f 100644
--- a/security/krb5-appl/Makefile
+++ b/security/krb5-appl/Makefile
@@ -33,7 +33,8 @@ PATCH_DIST_STRIP= -p1
OPTIONS_DEFINE= KRB5_RENAME_FTP KRB5_RENAME_TELNET KRB5_RENAME_RLOGIN KRB5_RENAME_RSH KRB5_RENAME_RCP
OPTIONS_DEFAULT= KRB5_PORT
OPTIONS_SINGLE= KRB5_VERSION
-OPTIONS_SINGLE_KRB5_VERSION= KRB5_PORT KRB5_112_PORT KRB5_113_PORT
+OPTIONS_SINGLE_KRB5_VERSION= KRB5_PORT KRB5_112_PORT KRB5_113_PORT \
+ KRB5_114_PORT
KRB5_RENAME_FTP_DESC= Rename ftp to kftp
KRB5_RENAME_TELNET_DESC= Rename telnet to ktelnet
KRB5_RENAME_RLOGIN_DESC= Rename rlogin to krlogin
@@ -41,7 +42,8 @@ KRB5_RENAME_RSH_DESC= Rename rsh to krsh
KRB5_RENAME_RCP_DESC= Rename rcp to krcp
KRB5_PORT_DESC= Depend on security/krb5
KRB5_112_PORT_DESC= Depend on security/krb5-112
-KRB5_112_PORT_DESC= Depend on security/krb5-113
+KRB5_113_PORT_DESC= Depend on security/krb5-113
+KRB5_114_PORT_DESC= Depend on security/krb5-114
.include <bsd.port.pre.mk>
@@ -54,6 +56,9 @@ RUN_DEPENDS= kinit:${PORTSDIR}/security/krb5-112
.elif ${PORT_OPTIONS:MKRB5_113_PORT}
LIB_DEPENDS= libkrb5support.so:${PORTSDIR}/security/krb5-113
RUN_DEPENDS= kinit:${PORTSDIR}/security/krb5-113
+.elif ${PORT_OPTIONS:MKRB5_114_PORT}
+LIB_DEPENDS= libkrb5support.so:${PORTSDIR}/security/krb5-114
+RUN_DEPENDS= kinit:${PORTSDIR}/security/krb5-113
.else
BROKEN= krb5 dependency not selected
.endif
diff --git a/security/krb5/Makefile b/security/krb5/Makefile
new file mode 100644
index 000000000000..061d4f996cd8
--- /dev/null
+++ b/security/krb5/Makefile
@@ -0,0 +1,8 @@
+# $FreeBSD$
+
+VERSIONS= 112 113 114
+KRB5_VERSION?= 114
+
+MASTERDIR= ${.CURDIR}/../krb5-${KRB5_VERSION}
+
+.include "${MASTERDIR}/Makefile"