aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-05-04 00:05:39 +0800
committerpav <pav@FreeBSD.org>2004-05-04 00:05:39 +0800
commit2e773f0014f4e856c9447ba72156ae3c49c041f1 (patch)
tree05a23d1e5726950af2e35ba8b26f89353056d671 /security
parent37d1691aef5645b36cd6d954d1303e320a21aa1a (diff)
downloadfreebsd-ports-gnome-2e773f0014f4e856c9447ba72156ae3c49c041f1.tar.gz
freebsd-ports-gnome-2e773f0014f4e856c9447ba72156ae3c49c041f1.tar.zst
freebsd-ports-gnome-2e773f0014f4e856c9447ba72156ae3c49c041f1.zip
- Update to 0.94
PR: ports/66099 Submitted by: Wesley Shields <wxs@csh.rit.edu> Approved by: maintainer
Diffstat (limited to 'security')
-rw-r--r--security/libtomcrypt/Makefile6
-rw-r--r--security/libtomcrypt/distinfo4
-rw-r--r--security/libtomcrypt/files/patch-dsa.c88
-rw-r--r--security/libtomcrypt/pkg-plist3
4 files changed, 7 insertions, 94 deletions
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index 8b01a2583ae4..1ea316822ab7 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libtomcrypt
-PORTVERSION= 0.92
+PORTVERSION= 0.94
CATEGORIES= security
MASTER_SITES= http://libtomcrypt.org/files/
DISTNAME= crypt-${PORTVERSION}
@@ -18,6 +18,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= makefile
MAKE_ENV= PREFIX=${PREFIX} DOCSDIR=${DOCSDIR} EXAMPLESDIR=${EXAMPLESDIR}
USE_BZIP2= yes
+USE_REINPLACE= yes
ALL_TARGET= library
.if defined(WITH_DOCS)
@@ -32,4 +33,7 @@ test: build
(cd ${WRKSRC} && ${MAKE} test && ${WRKSRC}/test)
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's| ||' ${WRKSRC}/whirl.c
+
.include <bsd.port.mk>
diff --git a/security/libtomcrypt/distinfo b/security/libtomcrypt/distinfo
index cbf228b476ea..14c384e400cb 100644
--- a/security/libtomcrypt/distinfo
+++ b/security/libtomcrypt/distinfo
@@ -1,2 +1,2 @@
-MD5 (crypt-0.92.tar.bz2) = 12fd407c6678e072446323aaf41c0719
-SIZE (crypt-0.92.tar.bz2) = 783233
+MD5 (crypt-0.94.tar.bz2) = f53f3977e74d63e4733e388bffc69087
+SIZE (crypt-0.94.tar.bz2) = 820131
diff --git a/security/libtomcrypt/files/patch-dsa.c b/security/libtomcrypt/files/patch-dsa.c
deleted file mode 100644
index 3ff2d8d0a48e..000000000000
--- a/security/libtomcrypt/files/patch-dsa.c
+++ /dev/null
@@ -1,88 +0,0 @@
---- dsa.c.orig Tue Jan 13 14:52:15 2004
-+++ dsa.c Tue Jan 13 14:53:54 2004
-@@ -297,15 +297,15 @@
- return err;
- }
-
--#define OUTPUT_BIGNUM(num, buf2, y, z) \
--{ \
-- z = (unsigned long)mp_unsigned_bin_size(num); \
-- if ((y + 4 + z) > *outlen) { return CRYPT_BUFFER_OVERFLOW; } \
-- STORE32L(z, out+y); \
-- y += 4; \
-- if (mp_to_unsigned_bin(num, out+y) != MP_OKAY) { return CRYPT_MEM; } \
-- y += z; \
--}
-+#define OUTPUT_BIGNUM(num, buf2, y, z) \
-+{ \
-+ z = (unsigned long)mp_unsigned_bin_size(num); \
-+ if ((y + 4 + z) > *outlen) { return CRYPT_BUFFER_OVERFLOW; } \
-+ STORE32L(z, out+y); \
-+ y += 4; \
-+ if (mp_to_unsigned_bin(num, out+y) != MP_OKAY) { return CRYPT_MEM; } \
-+ y += z; \
-+}
-
- int dsa_export(unsigned char *out, unsigned long *outlen, int type, dsa_key *key)
- {
-@@ -352,33 +352,33 @@
- return CRYPT_OK;
- }
-
--#define INPUT_BIGNUM(num, in, x, y) \
--{ \
-- /* load value */ \
-- if (y+4 > inlen) { \
-- err = CRYPT_INVALID_PACKET; \
-- goto error; \
-- } \
-- LOAD32L(x, in+y); \
-- y += 4; \
-- \
-- /* sanity check... */ \
-- if (y+x > inlen) { \
-- err = CRYPT_INVALID_PACKET; \
-- goto error; \
-- } \
-- \
-- /* load it */ \
-- if (mp_read_unsigned_bin(num, (unsigned char *)in+y, (int)x) != MP_OKAY) {\
-- err = CRYPT_MEM; \
-- goto error; \
-- } \
-- y += x; \
-- if (mp_shrink(num) != MP_OKAY) { \
-- err = CRYPT_MEM; \
-- goto error; \
-- } \
--}
-+#define INPUT_BIGNUM(num, in, x, y) \
-+{ \
-+ /* load value */ \
-+ if (y+4 > inlen) { \
-+ err = CRYPT_INVALID_PACKET; \
-+ goto error; \
-+ } \
-+ LOAD32L(x, in+y); \
-+ y += 4; \
-+ \
-+ /* sanity check... */ \
-+ if (y+x > inlen) { \
-+ err = CRYPT_INVALID_PACKET; \
-+ goto error; \
-+ } \
-+ \
-+ /* load it */ \
-+ if (mp_read_unsigned_bin(num, (unsigned char *)in+y, (int)x) != MP_OKAY) {\
-+ err = CRYPT_MEM; \
-+ goto error; \
-+ } \
-+ y += x; \
-+ if (mp_shrink(num) != MP_OKAY) { \
-+ err = CRYPT_MEM; \
-+ goto error; \
-+ } \
-+}
-
- int dsa_import(const unsigned char *in, unsigned long inlen, dsa_key *key)
- {
diff --git a/security/libtomcrypt/pkg-plist b/security/libtomcrypt/pkg-plist
index aa7e652e277c..92cd3dce4dd3 100644
--- a/security/libtomcrypt/pkg-plist
+++ b/security/libtomcrypt/pkg-plist
@@ -18,12 +18,9 @@ include/mycrypt_custom.h
%%EXAMPLESDIR%%/ch2-01.c
%%EXAMPLESDIR%%/encrypt.c
%%EXAMPLESDIR%%/small.c
-%%EXAMPLESDIR%%/timer.asm
-%%EXAMPLESDIR%%/timer.h
%%EXAMPLESDIR%%/x86_prof.c
%%EXAMPLESDIR%%/hashsum.c
%%EXAMPLESDIR%%/test.c
-%%EXAMPLESDIR%%/timer.c
%%EXAMPLESDIR%%/tv_gen.c
%%PORTDOCS%%%%DOCSDIR%%/crypt.pdf
%%PORTDOCS%%%%DOCSDIR%%/cipher_tv.txt