aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-10-02 01:48:40 +0800
committererwin <erwin@FreeBSD.org>2006-10-02 01:48:40 +0800
commit333b2b4e963bc0dbba5dd9a7047e42a392757933 (patch)
treed3636f5f596b9b37db9b744fb4a28ca391956056 /security
parent1ad5bf220ab37d55abd0c59e2c282d7c74a5d64d (diff)
downloadfreebsd-ports-gnome-333b2b4e963bc0dbba5dd9a7047e42a392757933.tar.gz
freebsd-ports-gnome-333b2b4e963bc0dbba5dd9a7047e42a392757933.tar.zst
freebsd-ports-gnome-333b2b4e963bc0dbba5dd9a7047e42a392757933.zip
- Update to 2.4.3
- Remove NEW_MILTER from OPTIONS since it was a circular dependency - Change description for SQLITE in OPTIONS since it is almost only useful for logging - Change the order of p0f parameters in the rc.d script, because -l must be the last command line option [1] - Add new option so that arguments can be passed to p0f-analyzer.pl as well not just for p0f Submitted by: Henrik Schack <henrik@schack.dk> [1], gabor (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/amavisd-new/Makefile10
-rw-r--r--security/amavisd-new/distinfo6
-rw-r--r--security/amavisd-new/files/amavis-p0fanalyzer.sh.in7
-rw-r--r--security/amavisd-new/files/patch-amavisd40
-rw-r--r--security/amavisd-new/files/pkg-message.in3
5 files changed, 11 insertions, 55 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 894d7dd72cae..59dd074058b6 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -7,8 +7,7 @@
# Based on amavisd ports makefile.
PORTNAME= amavisd-new
-PORTVERSION= 2.4.2
-PORTREVISION= 4
+PORTVERSION= 2.4.3
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.ijs.si/software/amavisd/ \
@@ -47,13 +46,12 @@ AMAVISQUARANTINE?= /var/virusmails
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.p.+//}
OPTIONS= BDB "Use BerkeleyDB for nanny/cache/snmp" on \
- SQLITE "Use SQLite for lookups/logging/quarantine" off \
+ SQLITE "Use SQLite for lookups" off \
MYSQL "Use MySQL for lookups/logging/quarantine" off \
PGSQL "Use PgSQL for lookups/logging/quarantine" off \
LDAP "Use LDAP for lookups" off \
SASL "Use SASL authentication" off \
MILTER "Sendmail milter support" on \
- NEW_MILTER "New sendmail milter support (external module)" off \
SPAMASSASSIN "Use mail/p5-Mail-SpamAssassin" on \
P0F "Passive operating system fingerprinting" off \
FILE "Use newer file(1) utility from ports" off \
@@ -121,10 +119,6 @@ RUN_DEPENDS+= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
RUN_DEPENDS+= ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL
.endif
-.if defined(WITH_NEW_MILTER)
-RUN_DEPENDS+= ${LOCALBASE}/sbin/amavisd-milter:${PORTSDIR}/security/amavisd-milter
-.endif
-
.if defined(WITH_SPAMASSASSIN)
RUN_DEPENDS+= ${SITE_PERL}/Mail/SpamAssassin.pm:${PORTSDIR}/mail/p5-Mail-SpamAssassin
.endif
diff --git a/security/amavisd-new/distinfo b/security/amavisd-new/distinfo
index f527b232c1d7..828ccb490596 100644
--- a/security/amavisd-new/distinfo
+++ b/security/amavisd-new/distinfo
@@ -1,3 +1,3 @@
-MD5 (amavisd-new-2.4.2.tar.gz) = d750176de7481498ebd1011e08a488da
-SHA256 (amavisd-new-2.4.2.tar.gz) = 80023cc0397560d082dd4152c96b7efc49d3cc2695b4d578ed01b08c3af2bb9a
-SIZE (amavisd-new-2.4.2.tar.gz) = 854326
+MD5 (amavisd-new-2.4.3.tar.gz) = ee46a93edc1507a291ac0d1ff43a1d54
+SHA256 (amavisd-new-2.4.3.tar.gz) = 353f04a3f097bb3246707599187e50fe852ce6d6f7337c923cd5b55a0c0466cd
+SIZE (amavisd-new-2.4.3.tar.gz) = 876584
diff --git a/security/amavisd-new/files/amavis-p0fanalyzer.sh.in b/security/amavisd-new/files/amavis-p0fanalyzer.sh.in
index c5dc8bdeebec..97a9f16ae6de 100644
--- a/security/amavisd-new/files/amavis-p0fanalyzer.sh.in
+++ b/security/amavisd-new/files/amavis-p0fanalyzer.sh.in
@@ -10,6 +10,7 @@ amavis_p0fanalyzer_enable="${amavis_p0fanalyzer_enable-NO}"
amavis_p0fanalyzer_p0f_filter="${amavis_p0fanalyzer_p0f_filter-"tcp dst port 25"}"
amavis_p0fanalyzer_pidfile1="${amavis_p0fanalyzer_pidfile1-/var/run/p0fanalyzer1.pid}"
amavis_p0fanalyzer_pidfile2="${amavis_p0fanalyzer_pidfile2-/var/run/p0fanalyzer2.pid}"
+amavis_p0fanalyzer_flags="${amavis_p0fanalyzer_flags-2345}"
. /etc/rc.subr
@@ -22,10 +23,10 @@ stop_cmd=p0fanalyzer_stop
p0fanalyzer_start() {
echo "Starting p0f-analyzer." && \
/usr/sbin/daemon -p ${amavis_p0fanalyzer_pidfile1} \
- %%PREFIX%%/bin/p0f -l "${amavis_p0fanalyzer_p0f_filter}" \
- "${amavis_p0fanalyzer_flags}" 2>&1 | \
+ %%PREFIX%%/bin/p0f "${amavis_p0f_daemon_flags}" \
+ -l "${amavis_p0fanalyzer_p0f_filter}" 2>&1 | \
/usr/sbin/daemon -p ${amavis_p0fanalyzer_pidfile2} \
- %%PREFIX%%/sbin/p0f-analyzer.pl 2345
+ %%PREFIX%%/sbin/p0f-analyzer.pl ${amavis_p0fanalyzer_flags}
}
p0fanalyzer_stop() {
diff --git a/security/amavisd-new/files/patch-amavisd b/security/amavisd-new/files/patch-amavisd
index 22cf6d322974..e69de29bb2d1 100644
--- a/security/amavisd-new/files/patch-amavisd
+++ b/security/amavisd-new/files/patch-amavisd
@@ -1,40 +0,0 @@
---- amavisd.old Fri Aug 18 13:01:43 2006
-+++ amavisd Fri Aug 18 13:01:51 2006
-@@ -12049,15 +12049,20 @@
- my($bounced) = $msginfo->dsn_sent;
- for my $r (@{$msginfo->per_recip_data}) {
- my($resp) = $r->recip_smtp_response;
-- if ($bounced && $smtp_resp=~/^2/ && $resp!~/^2/) {
-- # as the message was already bounced by us,
-- # MTA must not bounce it again; failure status
-- # needs to be converted into success!
-- $resp = sprintf("250 2.5.0 Ok %s, DSN %s (%s)",
-- $r->recip_addr, $bounced==1 ? 'sent' : 'muted', $resp);
-+ my($recip_quoted) = qquote_rfc2821_local($r->recip_addr);
-+ if ($resp=~/^2/) {
-+ # success, no need to change status
-+ } elsif ($bounced) {
-+ # a non-delivery notifications was already sent by us, so
-+ # MTA must not bounce it again; turn status into a success
-+ $resp = sprintf("250 2.5.0 Ok %s, DSN was sent (%s)",
-+ $recip_quoted, $resp);
-+ } elsif ($resp=~/^5/ && $r->recip_destiny != D_REJECT) {
-+ $resp = sprintf("250 2.5.0 Ok %s, DSN suppressed (%s)",
-+ $recip_quoted, $resp);
- }
-- do_log(4, 'sending LMTP response for <%s>: "%s"',
-- $r->recip_addr, $resp);
-+ do_log(4, 'sending LMTP response for %s: "%s"',
-+ $recip_quoted, $resp);
- $self->smtp_resp(0, $resp);
- }
- }
-@@ -15055,6 +15060,8 @@
- local_tests_only => $sa_local_tests_only,
- home_dir_for_helpers => $helpers_home,
- stop_at_threshold => 0,
-+ LOCAL_STATE_DIR => '/var/lib',
-+ PREFIX => '/usr/local',
- # DEF_RULES_DIR => '/usr/local/share/spamassassin',
- # LOCAL_RULES_DIR => '/etc/mail/spamassassin',
- #see man Mail::SpamAssassin for other options
diff --git a/security/amavisd-new/files/pkg-message.in b/security/amavisd-new/files/pkg-message.in
index efcf16568533..dae402695c37 100644
--- a/security/amavisd-new/files/pkg-message.in
+++ b/security/amavisd-new/files/pkg-message.in
@@ -25,7 +25,8 @@
amavis_p0fanalyzer_enable="YES"
amavis_p0fanalyzer_p0f_filter="tcp dst port 25"
- You can pass another command line options to p0fanalyzer by setting
+ You can pass another command line options to p0f daemon by setting
+ amavis_p0f_daemon_flags and to p0f-analyzer.pl by setting
amavis_p0fanalyzer_flags.
Configuration templates are available in %%PREFIX%%/etc