aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-03-09 03:18:43 +0800
committeradamw <adamw@FreeBSD.org>2015-03-09 03:18:43 +0800
commit352bccf6f6abb7c20ba149bc8f38a5ed44defaf3 (patch)
treee2d7ec6609476587225c5fccbc2ead9736e2d236 /security
parentb0c385db953d6ed72f9b61b65fe3920154dbe184 (diff)
downloadfreebsd-ports-gnome-352bccf6f6abb7c20ba149bc8f38a5ed44defaf3.tar.gz
freebsd-ports-gnome-352bccf6f6abb7c20ba149bc8f38a5ed44defaf3.tar.zst
freebsd-ports-gnome-352bccf6f6abb7c20ba149bc8f38a5ed44defaf3.zip
Allow the OpenSSL library to be overridden by using WITH_OPENSSL_PORT
instead of a LIB_DEPENDS. I think this is the right way to use WITH_OPENSSL_PORT, but it's tough to know given the lack of documentation on it. PR: 198111 Submitted by: Bernard Spil
Diffstat (limited to 'security')
-rw-r--r--security/p5-Crypt-SMIME/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/security/p5-Crypt-SMIME/Makefile b/security/p5-Crypt-SMIME/Makefile
index 3115a71a5af4..bc2d5425725d 100644
--- a/security/p5-Crypt-SMIME/Makefile
+++ b/security/p5-Crypt-SMIME/Makefile
@@ -2,7 +2,7 @@
PORTNAME= Crypt-SMIME
PORTVERSION= 0.15
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,13 +13,18 @@ COMMENT= S/MIME message signing, verification, encryption and decryption
LICENSE= ART10
RUN_DEPENDS= p5-ExtUtils-CChecker>=0:${PORTSDIR}/devel/p5-ExtUtils-CChecker \
- p5-ExtUtils-PkgConfig>=0:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
- ${LOCALBASE}/lib/libcrypto.so:${PORTSDIR}/security/openssl
+ p5-ExtUtils-PkgConfig>=0:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig
BUILD_DEPENDS= ${RUN_DEPENDS}
-TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
+TEST_DEPENDS= p5-Taint-Util>=0:${PORTSDIR}/devel/p5-Taint-Util \
+ p5-Test-Dependencies>=0:${PORTSDIR}/devel/p5-Test-Dependencies \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ p5-Test-Taint>=0:${PORTSDIR}/devel/p5-Test-Taint
USES= perl5
USE_OPENSSL= yes
+WITH_OPENSSL_PORT?= yes
USE_PERL5= configure
post-stage: