aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-09-12 00:11:53 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-09-12 00:11:53 +0800
commit36520d61bc07996653e9f187666336aba1b654ad (patch)
tree5ac8da0700b61cf0e506fd6dc3bd6922248d8774 /security
parent4f4582f1aa295a28bce28b64640c8f8028c804eb (diff)
downloadfreebsd-ports-gnome-36520d61bc07996653e9f187666336aba1b654ad.tar.gz
freebsd-ports-gnome-36520d61bc07996653e9f187666336aba1b654ad.tar.zst
freebsd-ports-gnome-36520d61bc07996653e9f187666336aba1b654ad.zip
- Add LICENSE
- Switch to USES=localbase - Switch to new test framework - Don't install license as documentation Approved by: portmgr blanket
Diffstat (limited to 'security')
-rw-r--r--security/obfsclient/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/security/obfsclient/Makefile b/security/obfsclient/Makefile
index c8c13ba7da3c..f1ad9bd1680c 100644
--- a/security/obfsclient/Makefile
+++ b/security/obfsclient/Makefile
@@ -10,6 +10,10 @@ CATEGORIES= security
MAINTAINER= fk@fabiankeil.de
COMMENT= Tor-managed pluggable transport client
+LICENSE= BSD2CLAUSE MIT ISCL BSD3CLAUSE
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= liballium-1.0.so:devel/liballium \
libevent.so:devel/libevent2
@@ -17,19 +21,9 @@ USE_GITHUB= yes
GH_ACCOUNT= Yawning
GNU_CONFIGURE= yes
-USES= autoreconf compiler:c++11-lib pkgconfig tar:bzip2
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
+USES= autoreconf compiler:c++11-lib localbase pkgconfig
+TEST_TARGET= check
PLIST_FILES= bin/${PORTNAME}
-PORTDOCS= COPYING
-
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/COPYING ${STAGEDIR}${DOCSDIR}
-
-regression-test: build
- (cd ${WRKSRC} && make check)
.include <bsd.port.mk>