aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-11 22:08:22 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-11 22:08:22 +0800
commit368dee217a4b0443d430cdd0f7c07fae8f8aa139 (patch)
tree0a0f903b6e6f24d7a20e10de21fba8bc95fa22a6 /security
parentfbdbee4420d5baee0bc398a5831156b9b4e3417d (diff)
downloadfreebsd-ports-gnome-368dee217a4b0443d430cdd0f7c07fae8f8aa139.tar.gz
freebsd-ports-gnome-368dee217a4b0443d430cdd0f7c07fae8f8aa139.tar.zst
freebsd-ports-gnome-368dee217a4b0443d430cdd0f7c07fae8f8aa139.zip
- Add p5-Crypt-Password-Util 0.09
Crypt::Password::Util is a crypt password utilities. Its crypt($str) works like Perl's crypt(), but automatically choose the appropriate crypt type and random salt. Will first choose SSHA512 with 64-bit random salt. If not supported by system, fall back to MD5-CRYPT with 32-bit random salt. If that is not supported, fall back to CRYPT. Its crypt_type($str) returns crypt type, or undef if $str does not look like a crypted password. Currently known types: CRYPT (traditional DES crypt), MD5-CRYPT (including Apache variant), SSHA256 (salted SHA256), SSHA512 (salted SHA512), and PLAIN-MD5. See also Authen::Passphrase which recognizes more encodings (but currently not SSHA256 and SSHA512). WWW: http://search.cpan.org/dist/Crypt-Password-Util/ PR: ports/182326 Submitted by: Henk van Oers <hvo.pm@xs4all.nl>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Password-Util/Makefile23
-rw-r--r--security/p5-Crypt-Password-Util/distinfo2
-rw-r--r--security/p5-Crypt-Password-Util/pkg-descr16
-rw-r--r--security/p5-Crypt-Password-Util/pkg-plist4
5 files changed, 46 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 148f252f096f..34de6066e7ee 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -476,6 +476,7 @@
SUBDIR += p5-Crypt-PGPSimple
SUBDIR += p5-Crypt-PassGen
SUBDIR += p5-Crypt-PasswdMD5
+ SUBDIR += p5-Crypt-Password-Util
SUBDIR += p5-Crypt-Primes
SUBDIR += p5-Crypt-RC4
SUBDIR += p5-Crypt-RC5
diff --git a/security/p5-Crypt-Password-Util/Makefile b/security/p5-Crypt-Password-Util/Makefile
new file mode 100644
index 000000000000..aea261fa3112
--- /dev/null
+++ b/security/p5-Crypt-Password-Util/Makefile
@@ -0,0 +1,23 @@
+# Created by: Henk van Oers <hvo.pm@xs4all.nl>
+# $FreeBSD$
+
+PORTNAME= Crypt-Password-Util
+PORTVERSION= 0.09
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Crypt password utilities
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-UUID-Random-Patch-UseMRS>=0:${PORTSDIR}/devel/p5-UUID-Random-Patch-UseMRS
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Sort-Versions>=0:${PORTSDIR}/devel/p5-Sort-Versions
+
+USE_PERL5= modbuild
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Password-Util/distinfo b/security/p5-Crypt-Password-Util/distinfo
new file mode 100644
index 000000000000..972c84305977
--- /dev/null
+++ b/security/p5-Crypt-Password-Util/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-Password-Util-0.09.tar.gz) = 9e7c3ffb877748a201955bf95cf25cfbb134fb1b0bd906e905861e73dddf420f
+SIZE (Crypt-Password-Util-0.09.tar.gz) = 11588
diff --git a/security/p5-Crypt-Password-Util/pkg-descr b/security/p5-Crypt-Password-Util/pkg-descr
new file mode 100644
index 000000000000..3386454851cc
--- /dev/null
+++ b/security/p5-Crypt-Password-Util/pkg-descr
@@ -0,0 +1,16 @@
+Crypt::Password::Util is a crypt password utilities.
+
+Its crypt($str) works like Perl's crypt(), but automatically choose the
+appropriate crypt type and random salt. Will first choose SSHA512 with 64-bit
+random salt. If not supported by system, fall back to MD5-CRYPT with 32-bit
+random salt. If that is not supported, fall back to CRYPT.
+
+Its crypt_type($str) returns crypt type, or undef if $str does not look like a
+crypted password. Currently known types: CRYPT (traditional DES crypt),
+MD5-CRYPT (including Apache variant), SSHA256 (salted SHA256), SSHA512 (salted
+SHA512), and PLAIN-MD5.
+
+See also Authen::Passphrase which recognizes more encodings (but currently not
+SSHA256 and SSHA512).
+
+WWW: http://search.cpan.org/dist/Crypt-Password-Util/
diff --git a/security/p5-Crypt-Password-Util/pkg-plist b/security/p5-Crypt-Password-Util/pkg-plist
new file mode 100644
index 000000000000..80c43cdb4402
--- /dev/null
+++ b/security/p5-Crypt-Password-Util/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Crypt/Password/Util.pm
+%%PERL5_MAN3%%/Crypt::Password::Util.3.gz
+@dirrmtry %%SITE_PERL%%/Crypt/Password
+@dirrmtry %%SITE_PERL%%/Crypt