aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-09-21 00:47:29 +0800
committerantoine <antoine@FreeBSD.org>2016-09-21 00:47:29 +0800
commit36e04e8bdbfa4c80d10b7e69e643bdd43839c504 (patch)
tree4e5cc23e21e7c78024660a3434bafdaef3532f53 /security
parent3beea409a1763f5dda6db54d42c0292191bbd6f8 (diff)
downloadfreebsd-ports-gnome-36e04e8bdbfa4c80d10b7e69e643bdd43839c504.tar.gz
freebsd-ports-gnome-36e04e8bdbfa4c80d10b7e69e643bdd43839c504.tar.zst
freebsd-ports-gnome-36e04e8bdbfa4c80d10b7e69e643bdd43839c504.zip
New port: security/py-dfdatetime
dfDateTime, or Digital Forensics date and time, provides date and time objects to preserve accuracy and precision. WWW: https://github.com/log2timeline/dfdatetime
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-dfdatetime/Makefile24
-rw-r--r--security/py-dfdatetime/distinfo3
-rw-r--r--security/py-dfdatetime/pkg-descr4
4 files changed, 32 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index af48efd58675..1e20f8fca17c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -840,6 +840,7 @@
SUBDIR += py-cryptkit
SUBDIR += py-cryptography
SUBDIR += py-cybox
+ SUBDIR += py-dfdatetime
SUBDIR += py-dfvfs
SUBDIR += py-ecdsa
SUBDIR += py-ed25519ll
diff --git a/security/py-dfdatetime/Makefile b/security/py-dfdatetime/Makefile
new file mode 100644
index 000000000000..a68fb85937af
--- /dev/null
+++ b/security/py-dfdatetime/Makefile
@@ -0,0 +1,24 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= dfdatetime
+PORTVERSION= 20160323
+CATEGORIES= security devel python
+MASTER_SITES= https://github.com/log2timeline/dfdatetime/releases/download/${PORTVERSION}/ \
+ CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Digital Forensics Date and Time
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} run_tests.py)
+
+.include <bsd.port.mk>
diff --git a/security/py-dfdatetime/distinfo b/security/py-dfdatetime/distinfo
new file mode 100644
index 000000000000..427f874ae845
--- /dev/null
+++ b/security/py-dfdatetime/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474382627
+SHA256 (dfdatetime-20160323.tar.gz) = 1fa7e4bcd3c5f3ba3745eb61f847c8a09090d4986eb6c71eae37f38458e909e1
+SIZE (dfdatetime-20160323.tar.gz) = 12488
diff --git a/security/py-dfdatetime/pkg-descr b/security/py-dfdatetime/pkg-descr
new file mode 100644
index 000000000000..6787af5c77df
--- /dev/null
+++ b/security/py-dfdatetime/pkg-descr
@@ -0,0 +1,4 @@
+dfDateTime, or Digital Forensics date and time, provides date and time
+objects to preserve accuracy and precision.
+
+WWW: https://github.com/log2timeline/dfdatetime