aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-04-20 02:35:54 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-04-20 02:35:54 +0800
commit37e53f025a1f7aad18755b608218e4e262701974 (patch)
tree4e72fbc0bc58a7aed168ecfc3edc6d0a6bf06a15 /security
parent4022876b1b881b0bf3df5101ee6ee3554a828ba8 (diff)
downloadfreebsd-ports-gnome-37e53f025a1f7aad18755b608218e4e262701974.tar.gz
freebsd-ports-gnome-37e53f025a1f7aad18755b608218e4e262701974.tar.zst
freebsd-ports-gnome-37e53f025a1f7aad18755b608218e4e262701974.zip
- Cleanup Makefile
- Cosmetic change
Diffstat (limited to 'security')
-rw-r--r--security/p5-Authen-Simple/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/security/p5-Authen-Simple/Makefile b/security/p5-Authen-Simple/Makefile
index 45a536cf442d..32cfc4000a79 100644
--- a/security/p5-Authen-Simple/Makefile
+++ b/security/p5-Authen-Simple/Makefile
@@ -15,11 +15,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple authentication framework
-RUN_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
- ${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Crypt-PasswdMD5>=0:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate
-BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
MAN3= Authen::Simple.3 \
Authen::Simple::Adapter.3 \
@@ -27,12 +29,11 @@ MAN3= Authen::Simple.3 \
Authen::Simple::Log.3 \
Authen::Simple::Password.3
-PERL_MODBUILD= yes
-
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+BUILD_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
+RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
.endif
.include <bsd.port.post.mk>