aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormmoll <mmoll@FreeBSD.org>2015-05-27 02:11:32 +0800
committermmoll <mmoll@FreeBSD.org>2015-05-27 02:11:32 +0800
commit3a099a6bad8b404f4d7e190f3008a1202c3260e0 (patch)
tree95a6194a6833f4eab46452e25dffc44804987f5f /security
parent45fd4f633e51f0cd1c4324b2dd25a6bbf4e4329f (diff)
downloadfreebsd-ports-gnome-3a099a6bad8b404f4d7e190f3008a1202c3260e0.tar.gz
freebsd-ports-gnome-3a099a6bad8b404f4d7e190f3008a1202c3260e0.tar.zst
freebsd-ports-gnome-3a099a6bad8b404f4d7e190f3008a1202c3260e0.zip
new port: security/rubygem-rack-oauth2
OAuth 2.0 Server & Client Library. WWW: https://github.com/nov/rack-oauth2 PR: 199922 Differential Revision: https://reviews.freebsd.org/D2638 Submitted by: Torsten Zuehlsdorff <ports@toco-domains.de> Approved by: mat (mentor)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-rack-oauth2/Makefile24
-rw-r--r--security/rubygem-rack-oauth2/distinfo2
-rw-r--r--security/rubygem-rack-oauth2/pkg-descr4
4 files changed, 31 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d9f6bd9f4907..dd0d96b23b5f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -928,6 +928,7 @@
SUBDIR += rubygem-omniauth-shibboleth
SUBDIR += rubygem-origami
SUBDIR += rubygem-pyu-ruby-sasl
+ SUBDIR += rubygem-rack-oauth2
SUBDIR += rubygem-razorback-scriptNugget
SUBDIR += rubygem-recog
SUBDIR += rubygem-roauth
diff --git a/security/rubygem-rack-oauth2/Makefile b/security/rubygem-rack-oauth2/Makefile
new file mode 100644
index 000000000000..f337732acb42
--- /dev/null
+++ b/security/rubygem-rack-oauth2/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= rack-oauth2
+PORTVERSION= 1.1.1
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= OAuth 2.0 Server & Client Library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-activesupport>=2.3:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-attr_required>=0.0.5:${PORTSDIR}/devel/rubygem-attr_required \
+ rubygem-httpclient>=2.4:${PORTSDIR}/www/rubygem-httpclient \
+ rubygem-multi_json>=1.3.6:${PORTSDIR}/devel/rubygem-multi_json \
+ rubygem-rack>=1.1:${PORTSDIR}/www/rubygem-rack
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-rack-oauth2/distinfo b/security/rubygem-rack-oauth2/distinfo
new file mode 100644
index 000000000000..5be728e3a8fc
--- /dev/null
+++ b/security/rubygem-rack-oauth2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rack-oauth2-1.1.1.gem) = 4bd6bfdb9b8044792dbff5313a343fe86ed5523d4f685c5431e55e71fefabec9
+SIZE (rubygem/rack-oauth2-1.1.1.gem) = 30208
diff --git a/security/rubygem-rack-oauth2/pkg-descr b/security/rubygem-rack-oauth2/pkg-descr
new file mode 100644
index 000000000000..1d071af619e4
--- /dev/null
+++ b/security/rubygem-rack-oauth2/pkg-descr
@@ -0,0 +1,4 @@
+OAuth 2.0 Server & Client Library.
+Both Bearer and MAC token type are supported.
+
+WWW: https://github.com/nov/rack-oauth2