aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-03-13 10:19:18 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-03-13 10:19:18 +0800
commit3fd14d5a2cd99b0bdfa38337818b8be4dacc2d80 (patch)
tree1dfdf22b444f311298c2c95960cbfe5e980500b5 /security
parent01b294cac49b86272a0cd20a762ebd361e472246 (diff)
downloadfreebsd-ports-gnome-3fd14d5a2cd99b0bdfa38337818b8be4dacc2d80.tar.gz
freebsd-ports-gnome-3fd14d5a2cd99b0bdfa38337818b8be4dacc2d80.tar.zst
freebsd-ports-gnome-3fd14d5a2cd99b0bdfa38337818b8be4dacc2d80.zip
- Fix license. COPYING explicitly states that APACHE20 does not apply, the license is actually commercial:
Commercial software. Please write info@synergetics.be for licensing terms. LICENSE-2.0.txt does not apply. It is only provided for information, e.g. on some related software packages. - Switch to options helpers - Regenerate patches with `make makepatch`
Diffstat (limited to 'security')
-rw-r--r--security/zxid/Makefile6
-rw-r--r--security/zxid/files/patch-pkcs12.c8
-rw-r--r--security/zxid/files/patch-platform.h6
-rw-r--r--security/zxid/files/patch-zx.h6
4 files changed, 15 insertions, 11 deletions
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
index dcec9af56bdf..4cc086312c7e 100644
--- a/security/zxid/Makefile
+++ b/security/zxid/Makefile
@@ -9,7 +9,10 @@ MASTER_SITES= http://zxid.org/
MAINTAINER= ports@FreeBSD.org
COMMENT= Open Source IdM for the Masses - SAML SSO
-LICENSE= APACHE20
+LICENSE= E2ETA
+LICENSE_NAME= End2End Trust Architecture (e2eta) Software Copying
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= # none
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
@@ -57,6 +60,7 @@ do-install:
${LN} -sf libzxid.so.0.0 ${STAGEDIR}${PREFIX}/lib/libzxid.so
${LN} -sf libzxid.so.0.0 ${STAGEDIR}${PREFIX}/lib/libzxid.so.0
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.pd ${STAGEDIR}${DOCSDIR}
diff --git a/security/zxid/files/patch-pkcs12.c b/security/zxid/files/patch-pkcs12.c
index 42bb5fc225a2..54e1fc67afaa 100644
--- a/security/zxid/files/patch-pkcs12.c
+++ b/security/zxid/files/patch-pkcs12.c
@@ -1,8 +1,8 @@
---- pkcs12.c.orig
+--- pkcs12.c.orig 2016-02-29 00:16:50 UTC
+++ pkcs12.c
-@@ -95,6 +95,10 @@
- #define SMIME_INTERNALS /* we want also our internal helper functions */
- #include "smimeutil.h"
+@@ -99,6 +99,10 @@
+ #define _STACK STACK
+ #endif
+#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x10000000L
+#define _STACK STACK
diff --git a/security/zxid/files/patch-platform.h b/security/zxid/files/patch-platform.h
index 72101f68a509..22029a0fbcb8 100644
--- a/security/zxid/files/patch-platform.h
+++ b/security/zxid/files/patch-platform.h
@@ -1,6 +1,6 @@
---- platform.h.orig 2013-11-27 10:56:48.000000000 +0900
-+++ platform.h 2014-07-28 07:51:37.000000000 +0900
-@@ -130,6 +130,7 @@
+--- platform.h.orig 2016-02-29 00:16:50 UTC
++++ platform.h
+@@ -132,6 +132,7 @@ unsigned int alarm(unsigned int secs);
* NOT MINGW nor WIN32CL (i.e. its Unix) */
#include <dirent.h>
diff --git a/security/zxid/files/patch-zx.h b/security/zxid/files/patch-zx.h
index 86b946d0d49d..b1f286ba865c 100644
--- a/security/zxid/files/patch-zx.h
+++ b/security/zxid/files/patch-zx.h
@@ -1,6 +1,6 @@
---- zx.h.orig 2011-07-25 03:56:45.000000000 +0800
-+++ zx.h 2011-12-29 17:00:27.394555276 +0800
-@@ -25,6 +25,7 @@
+--- zx.h.orig 2016-02-29 00:16:50 UTC
++++ zx.h
+@@ -29,6 +29,7 @@
#include <memory.h>
#include <string.h>
#include <stdarg.h>