aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2013-03-27 07:25:19 +0800
committerXin LI <delphij@FreeBSD.org>2013-03-27 07:25:19 +0800
commit41a97d8f469eee6db16e06ba4d2c5ff985ee6414 (patch)
tree31f33ba98cedfc78b4854e436ac75283ff61a97a /security
parent41d7484e2458a4c142b1598e20880ab7fc7a5596 (diff)
downloadfreebsd-ports-gnome-41a97d8f469eee6db16e06ba4d2c5ff985ee6414.tar.gz
freebsd-ports-gnome-41a97d8f469eee6db16e06ba4d2c5ff985ee6414.tar.zst
freebsd-ports-gnome-41a97d8f469eee6db16e06ba4d2c5ff985ee6414.zip
In validate target, use unexpand and sed to make sure that we are using
consistent space style. Reviewed by: stas, simon
Diffstat (limited to 'security')
-rw-r--r--security/vuxml/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/security/vuxml/Makefile b/security/vuxml/Makefile
index ca13a1182141..76508e38ed97 100644
--- a/security/vuxml/Makefile
+++ b/security/vuxml/Makefile
@@ -80,6 +80,17 @@ validate: tidy
else \
return 1; \
fi
+ @${ECHO_MSG} Checking for space/tab...
+ @unexpand "${VUXML_FILE}" | ${SED} 's,[[:space:]]*$$,,g' > "${VUXML_FILE}.unexpanded"
+ @if ${DIFF} -u "${VUXML_FILE}" "${VUXML_FILE}.unexpanded"; \
+ then \
+ ${ECHO_MSG} ... seems okay; \
+ ${RM} "${VUXML_FILE}.unexpanded"; \
+ else \
+ ${ECHO_MSG} ... see above; \
+ ${ECHO_CMD} Consider using ${VUXML_FILE}.unexpanded for final commit; \
+ return 1; \
+ fi
tidy: vuln.xml
@if [ ! -e ${LOCALBASE}/share/xml/dtd/vuxml/catalog.xml ]; \