aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-04-23 23:53:34 +0800
committerdinoex <dinoex@FreeBSD.org>2010-04-23 23:53:34 +0800
commit438d58d9723ef45449b0b20e93a8d07fb1d22f1c (patch)
treed5f48d3c38c78870c54e7a8323fa5415a0b1cb94 /security
parentf167e2b999889d7d90235d66054a7249a00d50f8 (diff)
downloadfreebsd-ports-gnome-438d58d9723ef45449b0b20e93a8d07fb1d22f1c.tar.gz
freebsd-ports-gnome-438d58d9723ef45449b0b20e93a8d07fb1d22f1c.tar.zst
freebsd-ports-gnome-438d58d9723ef45449b0b20e93a8d07fb1d22f1c.zip
- PHP 5.2 slave port
PR: 145772 Submitted by: Alex Keda
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/php52-filter/Makefile14
-rw-r--r--security/php52-filter/files/patch-config.m425
-rw-r--r--security/php52-hash/Makefile14
4 files changed, 54 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index eea17b753e84..74c5161ff19e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -630,6 +630,7 @@
SUBDIR += php5-mcrypt
SUBDIR += php5-openssl
SUBDIR += php52-filter
+ SUBDIR += php52-hash
SUBDIR += phpdeadlock
SUBDIR += phpmyid
SUBDIR += phpsecinfo
diff --git a/security/php52-filter/Makefile b/security/php52-filter/Makefile
new file mode 100644
index 000000000000..42a02c2e1012
--- /dev/null
+++ b/security/php52-filter/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-filter
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -filter
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/php52-filter/files/patch-config.m4 b/security/php52-filter/files/patch-config.m4
new file mode 100644
index 000000000000..91aebe515ded
--- /dev/null
+++ b/security/php52-filter/files/patch-config.m4
@@ -0,0 +1,25 @@
+--- config.m4.orig 2009-03-06 08:25:45.000000000 +0100
++++ config.m4 2009-03-06 08:28:10.000000000 +0100
+@@ -19,7 +19,7 @@
+ CPPFLAGS=$INCLUDES
+ AC_EGREP_CPP(yes,[
+ #include <main/php_config.h>
+-#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++#if defined(HAVE_BUNDLED_PCRE)
+ yes
+ #endif
+ ],[
+@@ -27,11 +27,12 @@
+ ],[
+ AC_EGREP_CPP(yes,[
+ #include <main/php_config.h>
+-#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++#if defined(HAVE_PCRE)
+ yes
+ #endif
+ ],[
+ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
+ ],[
+ PHP_PCRE_REGEX=no
+ ])
diff --git a/security/php52-hash/Makefile b/security/php52-hash/Makefile
new file mode 100644
index 000000000000..11f6a504d6b3
--- /dev/null
+++ b/security/php52-hash/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-hash
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -hash
+
+.include "${MASTERDIR}/Makefile"