aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-10-15 21:47:11 +0800
committeredwin <edwin@FreeBSD.org>2003-10-15 21:47:11 +0800
commit45d5f592828e267dce7ad5c122e7ed86530faa39 (patch)
treefe3c78578ae4a033b261cd4ac4e46147ef80e2f2 /security
parent57a506f1849f8aa8619e00629224f579da0164cb (diff)
downloadfreebsd-ports-gnome-45d5f592828e267dce7ad5c122e7ed86530faa39.tar.gz
freebsd-ports-gnome-45d5f592828e267dce7ad5c122e7ed86530faa39.tar.zst
freebsd-ports-gnome-45d5f592828e267dce7ad5c122e7ed86530faa39.zip
unbreak port by adding a \n\ to a patchfile
Diffstat (limited to 'security')
-rw-r--r--security/py-twofish/Makefile9
-rw-r--r--security/py-twofish/files/patch-twofishmodule.c11
2 files changed, 13 insertions, 7 deletions
diff --git a/security/py-twofish/Makefile b/security/py-twofish/Makefile
index 5806eb04d350..c200761b8d9a 100644
--- a/security/py-twofish/Makefile
+++ b/security/py-twofish/Makefile
@@ -8,6 +8,7 @@
PORTNAME= twofish
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= twofish-py
@@ -20,12 +21,6 @@ COMMENT= Twofish cryptographic module for Python
USE_PYTHON= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
do-install:
${INSTALL_DATA} ${WRKSRC}/_twofish.so ${PYTHON_SITELIBDIR}
${INSTALL_SCRIPT} ${WRKSRC}/*.py ${PYTHON_SITELIBDIR}
@@ -34,4 +29,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/py-twofish/files/patch-twofishmodule.c b/security/py-twofish/files/patch-twofishmodule.c
new file mode 100644
index 000000000000..dfe8209d0e56
--- /dev/null
+++ b/security/py-twofish/files/patch-twofishmodule.c
@@ -0,0 +1,11 @@
+--- twofishmodule.c.orig Wed Oct 15 06:46:16 2003
++++ twofishmodule.c Wed Oct 15 06:46:30 2003
+@@ -489,7 +489,7 @@
+ Functions:\n\
+ new() -- return a new twofish object.\n\
+ \n\
+-Special Objects:
++Special Objects: \n\
+ \n\
+ TwoFishType -- type object for TwoFish objects. \n";
+