aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2011-06-23 16:31:52 +0800
committermartymac <martymac@FreeBSD.org>2011-06-23 16:31:52 +0800
commit47d98388b25c7b70ed11e556510d324ebf3130bb (patch)
tree07d3477e65fcf1fa882182a6490663c981b1212a /security
parent3d4facf407c55f6273b92f29d7470e9d28570291 (diff)
downloadfreebsd-ports-gnome-47d98388b25c7b70ed11e556510d324ebf3130bb.tar.gz
freebsd-ports-gnome-47d98388b25c7b70ed11e556510d324ebf3130bb.tar.zst
freebsd-ports-gnome-47d98388b25c7b70ed11e556510d324ebf3130bb.zip
- Fix build with clang
- Remove MD5 checksum
Diffstat (limited to 'security')
-rw-r--r--security/vlock/Makefile3
-rw-r--r--security/vlock/distinfo1
-rw-r--r--security/vlock/files/patch-configure25
3 files changed, 18 insertions, 11 deletions
diff --git a/security/vlock/Makefile b/security/vlock/Makefile
index 49d42ffd63d6..1d9dfe303d24 100644
--- a/security/vlock/Makefile
+++ b/security/vlock/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vlock
PORTVERSION= 2.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://cthulhu.c3d2.de/~toidinamai/vlock/archive/
@@ -27,6 +27,7 @@ CONFIGURE_ARGS= --enable-plugins --enable-pam \
VLOCK_MODE="0750" \
EXTRA_CFLAGS="-I${LOCALBASE}/include" \
EXTRA_LDFLAGS="-L${LOCALBASE}/lib"
+USE_CSTD= gnu99
OPTIONS= ROOTPWD "Enable unlock using root password" on \
VLOCKSCRIPTS "Install sample hook scripts" off \
diff --git a/security/vlock/distinfo b/security/vlock/distinfo
index d5b354628c3d..97febc4d8b2e 100644
--- a/security/vlock/distinfo
+++ b/security/vlock/distinfo
@@ -1,3 +1,2 @@
-MD5 (vlock-2.2.2.tar.gz) = 51c389ee4ef814bf59063bc367437eb8
SHA256 (vlock-2.2.2.tar.gz) = ea875250cad150872583b6ed2436470bc5e9c3a580d85554e31a2d5ae1d92fad
SIZE (vlock-2.2.2.tar.gz) = 54732
diff --git a/security/vlock/files/patch-configure b/security/vlock/files/patch-configure
index 8cf43e19abdb..4ecb477dfd4c 100644
--- a/security/vlock/files/patch-configure
+++ b/security/vlock/files/patch-configure
@@ -1,12 +1,19 @@
---- configure.orig 2008-05-24 08:37:25.515872840 +0200
-+++ configure 2008-05-24 08:38:44.943843155 +0200
-@@ -220,7 +220,8 @@
+--- configure.orig 2008-05-18 11:10:54.000000000 +0200
++++ configure 2011-06-23 08:20:00.811018722 +0200
+@@ -219,12 +219,12 @@
+ SCRIPTDIR="\$(LIBDIR)/vlock/scripts"
MODULEDIR="\$(LIBDIR)/vlock/modules"
- CC=gcc
-- DEFAULT_CFLAGS="-O2 -Wall -W -pedantic -std=gnu99"
-+ #DEFAULT_CFLAGS="-O2 -Wall -W -pedantic -std=gnu99"
-+ DEFAULT_CFLAGS="-pedantic -std=gnu99"
+- CC=gcc
++ #CC=gcc
+ DEFAULT_CFLAGS="-O2 -Wall -W -pedantic -std=gnu99"
DEBUG_CFLAGS="-O0 -g -Wall -W -pedantic -std=gnu99"
- CFLAGS="${DEFAULT_CFLAGS}"
- LD=ld
+- CFLAGS="${DEFAULT_CFLAGS}"
+- LD=ld
+- LDFLAGS=""
++ #CFLAGS="${DEFAULT_CFLAGS}"
++ #LD=ld
++ #LDFLAGS=""
+ AUTH_METHOD="pam"
+ ENABLE_ROOT_PASSWORD="yes"
+ ENABLE_PLUGINS="yes"