aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-10-18 11:13:53 +0800
committerkoobs <koobs@FreeBSD.org>2015-10-18 11:13:53 +0800
commit488664a2bb2058b52d55f80bc6817fdefa0f4544 (patch)
tree6947a14f6eb0cb6c0411e5a71c3dea382e8f45b0 /security
parentcb0263fd08a96c47eb45954a446c5ceeb157ea5f (diff)
downloadfreebsd-ports-gnome-488664a2bb2058b52d55f80bc6817fdefa0f4544.tar.gz
freebsd-ports-gnome-488664a2bb2058b52d55f80bc6817fdefa0f4544.tar.zst
freebsd-ports-gnome-488664a2bb2058b52d55f80bc6817fdefa0f4544.zip
security/py-cryptography: Update to 1.0.2
- Update to 1.0.2 - Strip shared libraries - Add patch to support building with LibreSSL - Remove ALPN patch (upstreamed) Changes: https://github.com/pyca/cryptography/blob/1.0.2/CHANGELOG.rst PR: 203819 Submitted by: Ralf van der Enden <tremere cainites net>
Diffstat (limited to 'security')
-rw-r--r--security/py-cryptography/Makefile5
-rw-r--r--security/py-cryptography/distinfo4
-rw-r--r--security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py12
-rw-r--r--security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_ssl.py17
4 files changed, 18 insertions, 20 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 704d3b4047e1..0e2d2bf17cf1 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cryptography
-PORTVERSION= 0.8.2
+PORTVERSION= 1.0.2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -33,6 +33,9 @@ LDFLAGS+= -L${OPENSSLLIB}
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>0:${PORTSDIR}/devel/py-enum34
.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/cryptography/hazmat/bindings/*.so
+
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/security/py-cryptography/distinfo b/security/py-cryptography/distinfo
index a65f20312e5f..fe6401d114e7 100644
--- a/security/py-cryptography/distinfo
+++ b/security/py-cryptography/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cryptography-0.8.2.tar.gz) = 1c9a022ab3decaf152093e2ef2d5ee4258c72c7d429446c86bd68ff8c0929db6
-SIZE (cryptography-0.8.2.tar.gz) = 268288
+SHA256 (cryptography-1.0.2.tar.gz) = d64cd491e91ddf642c643bea16532c2a2da2da054cca6df756edadd55a8bacca
+SIZE (cryptography-1.0.2.tar.gz) = 332870
diff --git a/security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py b/security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py
new file mode 100644
index 000000000000..48ddafc0b7b5
--- /dev/null
+++ b/security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py
@@ -0,0 +1,12 @@
+--- src/_cffi_src/openssl/ec.py.orig 2015-09-27 13:51:07 UTC
++++ src/_cffi_src/openssl/ec.py
+@@ -396,7 +396,8 @@ EC_GROUP *(*EC_GROUP_new_curve_GF2m)(
+ static const long Cryptography_HAS_EC2M = 1;
+ #endif
+
+-#if defined(OPENSSL_NO_EC) || OPENSSL_VERSION_NUMBER < 0x1000200f || \
++#if defined(OPENSSL_NO_EC) || \
++ OPENSSL_VERSION_NUMBER < 0x1000200f && !defined(LIBRESSL_VERSION_NUMBER) || \
+ defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20020002L
+ static const long Cryptography_HAS_EC_1_0_2 = 0;
+ const char *(*EC_curve_nid2nist)(int) = NULL;
diff --git a/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_ssl.py b/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_ssl.py
deleted file mode 100644
index feb2da8902ad..000000000000
--- a/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_ssl.py
+++ /dev/null
@@ -1,17 +0,0 @@
-From 622409947f6e64fcabbf2b4da2ed086abc06ed85 Mon Sep 17 00:00:00 2001
-From: Bernard Spil <Sp1l@users.noreply.github.com>
-Date: Wed, 15 Apr 2015 11:09:32 +0200
-Subject: [PATCH] LibreSSL added ALPN support in 2.1.3
-Link: https://github.com/pyca/cryptography/pull/1849
-
---- src/cryptography/hazmat/bindings/openssl/ssl.py.orig 2015-04-24 12:57:06 UTC
-+++ src/cryptography/hazmat/bindings/openssl/ssl.py
-@@ -526,7 +526,7 @@ static const long Cryptography_HAS_NEXTP
- #endif
-
- /* ALPN was added in OpenSSL 1.0.2. */
--#if OPENSSL_VERSION_NUMBER < 0x10002001L
-+#if OPENSSL_VERSION_NUMBER < 0x10002001L && !defined(LIBRESSL_VERSION_NUMBER)
- int (*SSL_CTX_set_alpn_protos)(SSL_CTX *,
- const unsigned char *,
- unsigned) = NULL;