aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-23 02:05:04 +0800
committerbapt <bapt@FreeBSD.org>2013-09-23 02:05:04 +0800
commit4ab0594f63e38be08f045ae986deea85d9f8e781 (patch)
tree5ccc149311d24585961d9a2cf90f90b5de162a2d /security
parent144134eb9b1691db727f497d0fe3e24da49605ee (diff)
downloadfreebsd-ports-gnome-4ab0594f63e38be08f045ae986deea85d9f8e781.tar.gz
freebsd-ports-gnome-4ab0594f63e38be08f045ae986deea85d9f8e781.tar.zst
freebsd-ports-gnome-4ab0594f63e38be08f045ae986deea85d9f8e781.zip
Fix NO_STAGE attribution
Diffstat (limited to 'security')
-rw-r--r--security/aescrypt/Makefile2
-rw-r--r--security/cracklib/Makefile2
-rw-r--r--security/libtasn1/Makefile2
-rw-r--r--security/pam_p11/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/security/aescrypt/Makefile b/security/aescrypt/Makefile
index a5ae712aadf5..44c3ba4cfd10 100644
--- a/security/aescrypt/Makefile
+++ b/security/aescrypt/Makefile
@@ -16,12 +16,12 @@ COMMENT= Command-line AES encryption/decryption suite
GNU_CONFIGURE= yes
MAKE_ENV+= BINGRP=wheel
+NO_STAGE= yes
MAN1= aescrypt.1 aesget.1
MANCOMPRESSED= yes
.if !defined(NOPORTDOCS)
-NO_STAGE= yes
post-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
diff --git a/security/cracklib/Makefile b/security/cracklib/Makefile
index 75b5aa516df7..5e577b175434 100644
--- a/security/cracklib/Makefile
+++ b/security/cracklib/Makefile
@@ -20,6 +20,7 @@ DICTFILE= ${DICTPATH}/pw_dict
GNU_CONFIGURE= yes
CONFIGURE_ARGS=--with-default-dict=${DICTPATH}
USE_LDCONFIG= yes
+NO_STAGE= yes
.if defined(PYTHON_SLAVEPORT)
USE_PYTHON= yes
@@ -57,7 +58,6 @@ PLIST_FILES= include/crack.h \
.endif
.if defined(PYTHON_SLAVEPORT)
-NO_STAGE= yes
pre-build:
cd ${WRKSRC}/lib && ${MAKE} libcrack.la
diff --git a/security/libtasn1/Makefile b/security/libtasn1/Makefile
index 76b43fa813ec..35c896d55dfd 100644
--- a/security/libtasn1/Makefile
+++ b/security/libtasn1/Makefile
@@ -14,6 +14,7 @@ USE_LDCONFIG= yes
USES= pkgconfig pathfix
GNU_CONFIGURE= yes
USE_GMAKE= yes
+NO_STAGE= yes
DOCS= AUTHORS NEWS README THANKS doc/TODO \
doc/libtasn1.html doc/libtasn1.pdf doc/libtasn1.ps
@@ -57,7 +58,6 @@ MAN3= asn1_array2tree.3 \
libtasn1_strerror.3
.if !defined(NOPORTDOCS)
-NO_STAGE= yes
post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
diff --git a/security/pam_p11/Makefile b/security/pam_p11/Makefile
index 13bc0ba43156..f8ab5db27a7e 100644
--- a/security/pam_p11/Makefile
+++ b/security/pam_p11/Makefile
@@ -16,6 +16,7 @@ USE_AUTOTOOLS= libtool
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USES= pkgconfig
+NO_STAGE= yes
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
@@ -23,7 +24,6 @@ CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
PORTDOCS= *
.ifndef(NOPORTDOCS)
-NO_STAGE= yes
post-install:
@${MKDIR} ${DOCSDIR}/wiki
@(cd ${WRKSRC} && ${CP} NEWS ${DOCSDIR})