aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2012-07-23 22:19:34 +0800
committerzi <zi@FreeBSD.org>2012-07-23 22:19:34 +0800
commit4d428c32fa5eeee8e96a0cad7435e20922dc28b6 (patch)
tree50ddddc5c99c1e1224e50dadbdc035dfd4977fb2 /security
parent57e94c905be51a27fb649239b6a63d7e718c501f (diff)
downloadfreebsd-ports-gnome-4d428c32fa5eeee8e96a0cad7435e20922dc28b6.tar.gz
freebsd-ports-gnome-4d428c32fa5eeee8e96a0cad7435e20922dc28b6.tar.zst
freebsd-ports-gnome-4d428c32fa5eeee8e96a0cad7435e20922dc28b6.zip
- Update to 2.9.3
- Convert to OptionsNG
Diffstat (limited to 'security')
-rw-r--r--security/snort/Makefile163
-rw-r--r--security/snort/distinfo4
-rw-r--r--security/snort/pkg-plist60
3 files changed, 102 insertions, 125 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 15a6c33a589c..461c3486983c 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= snort
-PORTVERSION= 2.9.2.3
+PORTVERSION= 2.9.3
CATEGORIES= security
MASTER_SITES= SF/snort/snort \
http://mirrors.rit.edu/zi/
@@ -19,30 +19,29 @@ COMMENT= Lightweight network intrusion detection system
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= pcre.1:${PORTSDIR}/devel/pcre
-BUILD_DEPENDS= daq>=0.6.2:${PORTSDIR}/net/daq \
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+BUILD_DEPENDS= daq>=1.1.1:${PORTSDIR}/net/daq \
${LOCALBASE}/lib/libnet11/libnet.a:${PORTSDIR}/net/libnet
-RUN_DEPENDS= daq>=0.6.2:${PORTSDIR}/net/daq \
+RUN_DEPENDS= daq>=1.1.1:${PORTSDIR}/net/daq \
${LOCALBASE}/lib/libnet11/libnet.a:${PORTSDIR}/net/libnet
-OPTIONS= IPV6 "Enable IPv6 support" on \
- MPLS "Enable MPLS support" on \
- GRE "Enable GRE support" on \
- TARGETBASED "Enable Targetbased support" off \
- DECODERPRE "Enable Decoded-Preprocessor-Rules" on \
- ZLIB "Enable GZIP support" on \
- NORMALIZER "Enable Normalizer" on \
- REACT "Enable React" on \
- PERFPROFILE "Enable Performance Profiling" on \
- FLEXRESP3 "Flexible response to events (version 3)" on \
- MYSQL "Enable MySQL support" off \
- ODBC "Enable ODBC support" off \
- POSTGRESQL "Enable PostgreSQL support" off \
- PRELUDE "Enable Prelude NIDS integration" off \
- LRGPCAP "Enable pcaps larger than 2GB" off \
- SNORTSAM "Unofficial Snortsam Patch" off \
- SOURCEFIRE "Enable Sourcefire specific build options" on \
- DBGSNORT "Enable debugging symbols+core dumps" off
+OPTIONS_DEFINE= IPV6 MPLS GRE TARGETBASED ZLIB NORMALIZER REACT \
+ PERFPROFILE FLEXRESP3 LRGPCAP SNORTSAM SOURCEFIRE \
+ DBGSNORT
+OPTIONS_DEFAULT=IPV6 MPLS GRE ZLIB NORMALIZER REACT PERFPROFILE \
+ FLEXRESP3 SOURCEFIRE TARGETBASED
+
+GRE_DESC= Enable GRE support
+TARGETBASED_DESC= Enable targetbased support
+ZLIB_DESC= Enable GZIP support
+NORMALIZER_DESC= Enable normalizer
+REACT_DESC= Enable react
+PERFPROFILE_DESC= Enable performance profiling
+FLEXRESP3_DESC= Enable flexible response on events (v3)
+LRGPCAP_DESC= Enable pcaps larger than 2GB
+SNORTSAM_DESC= Enable unofficial Snortsam patch
+SOURCEFIRE_DESC= Enable Sourcefire-specific build options
+DBGSNORT_DESC= Enable debugging symbols+core dumps
.include <bsd.port.options.mk>
@@ -84,98 +83,59 @@ CONFIGURE_ARGS= --enable-dynamicplugin --enable-build-dynamic-examples \
PLIST_SUB+= DYNAMIC=""
-.if defined(WITH_FLEXRESP3)
-CONFIGURE_ARGS+= --enable-flexresp3 \
- --enable-active-response
+.if empty(PORT_OPTIONS:MFLEXRESP3)
+CONFIGURE_ARGS+=--disable-flexresp3 --disable-active-response
.endif
-.if defined(WITH_MYSQL)
-USE_MYSQL= yes
-CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --with-mysql=no
-.endif
-
-.if defined(WITH_ODBC)
-LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
-CONFIGURE_ARGS+= --with-odbc=${LOCALBASE}
-LDFLAGS+= ${PTHREAD_LIBS}
-.else
-CONFIGURE_ARGS+= --with-odbc=no
+.if ${PORT_OPTIONS:MLRGPCAP}
+CONFIGURE_ARGS+=--enable-large-pcap
.endif
-.if defined(WITH_POSTGRESQL)
-USE_PGSQL= yes
-CONFIGURE_ARGS+= --with-postgresql=${LOCALBASE}
-.if exists(/usr/lib/libssl.a) && exists(/usr/lib/libcrypto.a)
-LDFLAGS+= -lssl -lcrypto
-.endif
+.if ${PORT_OPTIONS:MDBGSNORT}
+CONFIGURE_ARGS+=--enable-corefiles --enable-debug
+MAKE_ENV+= DONTSTRIP="yes"
.else
-CONFIGURE_ARGS+= --with-postgresql=no
+CONFIGURE_ARGS+=--disable-corefiles
.endif
-.if defined(WITH_PRELUDE)
-LIB_DEPENDS+= prelude.20:${PORTSDIR}/security/libprelude
-CONFIGURE_ARGS+= --enable-prelude
-PLIST_SUB+= PRELUDE=""
-.else
-CONFIGURE_ARGS+= --disable-prelude
-PLIST_SUB+= PRELUDE="@comment "
-.endif
-
-.if defined(WITH_LRGPCAP)
-CONFIGURE_ARGS+= --enable-large-pcap
-.endif
-
-.if defined(WITH_DBGSNORT)
-CONFIGURE_ARGS+= --enable-corefiles --enable-debug
-MAKE_ENV+= DONTSTRIP="yes"
-.else
-CONFIGURE_ARGS+= --disable-corefiles
+.if ${PORT_OPTIONS:MSOURCEFIRE}
+CONFIGURE_ARGS+=--enable-sourcefire
.endif
-.if defined(WITH_SOURCEFIRE)
-CONFIGURE_ARGS+= --enable-sourcefire
+.if empty(PORT_OPTIONS:MPERFPROFILE)
+CONFIGURE_ARGS+=--disable-perfprofiling --disable-ppm
.endif
-.if defined(WITH_PERFPROFILE)
-CONFIGURE_ARGS+= --enable-perfprofiling --enable-ppm
+.if empty(PORT_OPTIONS:MIPV6)
+CONFIGURE_ARGS+=--disable-ipv6
.endif
-.if defined(WITHOUT_IPV6)
-CONFIGURE_ARGS+= --disable-ipv6
+.if empty(PORT_OPTIONS:MGRE)
+CONFIGURE_ARGS+=--disable-gre
.endif
-.if defined(WITH_GRE)
-CONFIGURE_ARGS+= --enable-gre
+.if empty(PORT_OPTIONS:MMPLS)
+CONFIGURE_ARGS+=--disable-mpls
.endif
-.if defined(WITH_MPLS)
-CONFIGURE_ARGS+= --enable-mpls
+.if empty(PORT_OPTIONS:MTARGETBASED)
+CONFIGURE_ARGS+=--disable-targetbased
.endif
-.if defined(WITH_TARGETBASED)
-CONFIGURE_ARGS+= --enable-targetbased
+.if empty(PORT_OPTIONS:MZLIB)
+CONFIGURE_ARGS+=--disable-zlib
.endif
-.if defined(WITH_DECODERPRE)
-CONFIGURE_ARGS+= --enable-decoder-preprocessor-rules
+.if ${PORT_OPTIONS:MNORMALIZER}
+CONFIGURE_ARGS+=--enable-normalizer
.endif
-.if defined(WITH_ZLIB)
-CONFIGURE_ARGS+= --enable-zlib
+.if ${PORT_OPTIONS:MREACT}
+CONFIGURE_ARGS+=--enable-react
.endif
-.if defined(WITH_NORMALIZER)
-CONFIGURE_ARGS+= --enable-normalizer
-.endif
-
-.if defined(WITH_REACT)
-CONFIGURE_ARGS+= --enable-react
-.endif
-
-.if defined(WITH_SNORTSAM)
-#BROKEN= current snortsam patch results in build failures
+.if ${PORT_OPTIONS:MSNORTSAM}
+BROKEN= current snortsam patch fails to apply
USE_AUTOTOOLS+= automake
USE_GNOME= pkgconfig
PATCH_SITES+= http://www.snortsam.net/files/snort-plugin/:snortsam
@@ -189,16 +149,14 @@ post-patch:
@${REINPLACE_CMD} -e 's|^dynamicdetection|#dynamicdetection|' ${WRKSRC}/etc/snort.conf
@${REINPLACE_CMD} -e '/var HOME_NET/s/any/[YOU_NEED_TO_SET_HOME_NET_IN_snort.conf]/' ${WRKSRC}/etc/snort.conf
@${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.in \
- ${WRKSRC}/src/dynamic-preprocessors/libs/Makefile.in
+ ${WRKSRC}/src/dynamic-preprocessors/libs/Makefile.in ${WRKSRC}/src/dynamic-output/libs/Makefile.in
@${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|g' ${WRKSRC}/configure
-.if defined(WITHOUT_IPV6)
+.if empty(PORT_OPTIONS:MIPV6)
@${REINPLACE_CMD} -e 's|^ipvar |var |' ${WRKSRC}/etc/snort.conf
@${REINPLACE_CMD} -e '/normalize_ip6/s/^preprocessor/#preprocessor/' ${WRKSRC}/etc/snort.conf
@${REINPLACE_CMD} -e '/normalize_icmp6/s/^preprocessor/#preprocessor/' ${WRKSRC}/etc/snort.conf
.endif
-.if defined(WITH_DECODERPRE)
@${REINPLACE_CMD} -e '/^# include .PREPROC_RULE/s/# include/include/' ${WRKSRC}/etc/snort.conf
-.endif
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} '/SUBDIRS = /s/doc//' ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -e '/README.u2boat/d' \
@@ -206,32 +164,21 @@ post-patch:
.endif
pre-configure:
-.if defined(WITH_SNORTSAM)
+.if ${PORT_OPTIONS:MSNORTSAM}
@${FIND} ${WRKSRC} -name 'Makefile.am' | ${XARGS} ${REINPLACE_CMD} -e 's|lib/snort_|lib/snort/|g'
@${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.am \
- ${WRKSRC}/src/dynamic-preprocessors/libs/Makefile.am
+ ${WRKSRC}/src/dynamic-preprocessors/libs/Makefile.am \
+ ${WRKSRC}/src/dynamic-output/libs/Makefile.am
@${ECHO_MSG} "===> Rebuilding required files for snortsam patches..."
@cd ${WRKSRC} && ${SH} ${WRKSRC}/autojunk.sh
@${ECHO_MSG} "===> Done. Configuring..."
.endif
-pre-install:
-.if defined(WITH_POSTGRESQL)
- @${REINPLACE_CMD} -e '/REQUIRE:/ s|$$| postgresql|' ${WRKDIR}/snort.sh
-.endif
-.if defined(WITH_MYSQL)
- @${REINPLACE_CMD} -e '/REQUIRE:/ s|$$| mysql|' ${WRKDIR}/snort.sh
-.endif
-
post-install:
@${LIBTOOL} --finish ${LOCALBASE}/lib/snort/dynamicpreprocessor
[ -d ${CONFIG_DIR} ] || ${MKDIR} ${CONFIG_DIR}
[ -d ${RULES_DIR} ] || ${MKDIR} ${RULES_DIR}
[ -d ${LOGS_DIR} ] || ${MKDIR} ${LOGS_DIR}
-.if !defined(NOPORTEXAMPLES)
- [ -d ${EXAMPLESDIR} ] || ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/schemas/create* ${EXAMPLESDIR}
-.endif
.for f in ${CONFIG_FILES}
${INSTALL_DATA} ${WRKSRC}/etc/${f} ${CONFIG_DIR}/${f}-sample
@if [ ! -f ${CONFIG_DIR}/${f} ]; then \
@@ -242,7 +189,6 @@ post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
-.if defined(WITH_DECODERPRE)
@${MKDIR} ${PREPROC_RULE_DIR}
.for f in ${PREPROC_RULES}
${INSTALL_DATA} ${WRKSRC}/preproc_rules/${f} ${PREPROC_RULE_DIR}/${f}-sample
@@ -250,7 +196,6 @@ post-install:
${CP} -p ${PREPROC_RULE_DIR}/${f}-sample ${PREPROC_RULE_DIR}/${f} ; \
fi
.endfor
-.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/security/snort/distinfo b/security/snort/distinfo
index c97667b0a925..42887c09afcf 100644
--- a/security/snort/distinfo
+++ b/security/snort/distinfo
@@ -1,4 +1,4 @@
-SHA256 (snort-2.9.2.3.tar.gz) = ccdb5cdaffdb82ee6277a9d861a7fe762b131037fbe2bf17837332ccdb220c02
-SIZE (snort-2.9.2.3.tar.gz) = 6532878
+SHA256 (snort-2.9.3.tar.gz) = 11522b17183c4b1092816224e4c3cf63d4fda94ee2bad08a96c384273accac15
+SIZE (snort-2.9.3.tar.gz) = 4935566
SHA256 (snortsam-2.9.2.2.diff.gz) = 61c6104778a1cd2d0795be0a7b3d67460955e5ffab392852a930b167c1fe27f2
SIZE (snortsam-2.9.2.2.diff.gz) = 28987
diff --git a/security/snort/pkg-plist b/security/snort/pkg-plist
index 36fda6e95956..471de61031a4 100644
--- a/security/snort/pkg-plist
+++ b/security/snort/pkg-plist
@@ -58,6 +58,7 @@ etc/snort/preproc_rules/sensitive-data.rules-sample
%%DYNAMIC%%src/snort_dynamicsrc/sf_ip.h
%%DYNAMIC%%src/snort_dynamicsrc/sf_decompression.h
%%DYNAMIC%%src/snort_dynamicsrc/sf_protocols.h
+%%DYNAMIC%%src/snort_dynamicsrc/sf_seqnums.h
%%DYNAMIC%%src/snort_dynamicsrc/sf_snort_packet.h
%%DYNAMIC%%src/snort_dynamicsrc/sf_snort_plugin_api.h
%%DYNAMIC%%src/snort_dynamicsrc/sf_types.h
@@ -76,12 +77,31 @@ etc/snort/preproc_rules/sensitive-data.rules-sample
%%DYNAMIC%%src/snort_dynamicsrc/Unified2_common.h
%%DYNAMIC%%@dirrmtry src/snort_dynamicsrc
%%DYNAMIC%%@dirrmtry src
+include/snort/dynamic_output/output_lib.h
+include/snort/dynamic_output/output_api.h
+include/snort/dynamic_output/output_common.h
+include/snort/dynamic_output/obfuscation.h
+include/snort/dynamic_output/ipv6_port.h
+include/snort/dynamic_output/sf_ip.h
+include/snort/dynamic_output/snort_debug.h
+include/snort/dynamic_output/sfPolicy.h
+include/snort/dynamic_output/sf_dynamic_common.h
+include/snort/dynamic_output/stream_api.h
+include/snort/dynamic_output/preprocids.h
+include/snort/dynamic_output/bitop.h
+include/snort/dynamic_output/sf_snort_packet.h
+include/snort/dynamic_output/sf_protocols.h
+include/snort/dynamic_output/sfrt.h
+include/snort/dynamic_output/sfrt_dir.h
+include/snort/dynamic_output/sfrt_trie.h
+@dirrmtry include/snort/dynamic_output
%%DYNAMIC%%include/snort/dynamic_preproc/attribute_table_api.h
%%DYNAMIC%%include/snort/dynamic_preproc/ssl.h
%%DYNAMIC%%include/snort/dynamic_preproc/sfcommon.h
%%DYNAMIC%%include/snort/dynamic_preproc/sf_preproc_info.h
%%DYNAMIC%%include/snort/dynamic_preproc/sf_snort_packet.h
%%DYNAMIC%%include/snort/dynamic_preproc/sf_protocols.h
+%%DYNAMIC%%include/snort/dynamic_preproc/sf_seqnums.h
%%DYNAMIC%%include/snort/dynamic_preproc/sf_snort_plugin_api.h
%%DYNAMIC%%include/snort/dynamic_preproc/sf_decompression.h
%%DYNAMIC%%include/snort/dynamic_preproc/sfPolicyUserData.h
@@ -115,9 +135,13 @@ etc/snort/preproc_rules/sensitive-data.rules-sample
%%DYNAMIC%%include/snort/dynamic_preproc/preprocids.h
%%DYNAMIC%%@dirrmtry include/snort/dynamic_preproc
@dirrmtry include/snort
+lib/snort/dynamic_output/libsf_dynamic_output.a
+lib/snort/dynamic_output/libsf_dynamic_output.la
+@dirrmtry lib/snort/dynamic_output
+%%DYNAMIC%%lib/snort/dynamicengine/libsf_engine.a
+%%DYNAMIC%%lib/snort/dynamicengine/libsf_engine.la
%%DYNAMIC%%lib/snort/dynamicengine/libsf_engine.so
%%DYNAMIC%%lib/snort/dynamicengine/libsf_engine.so.0
-%%DYNAMIC%%lib/snort/dynamicengine/libsf_engine.la
%%DYNAMIC%%@dirrmtry lib/snort/dynamicengine
%%DYNAMIC%%lib/snort/dynamicrules/lib_sfdynamic_example_rule.a
%%DYNAMIC%%lib/snort/dynamicrules/lib_sfdynamic_example_rule.la
@@ -127,45 +151,59 @@ etc/snort/preproc_rules/sensitive-data.rules-sample
%%DYNAMIC%%lib/snort/dynamic_preproc/libsf_dynamic_preproc.la
%%DYNAMIC%%lib/snort/dynamic_preproc/libsf_dynamic_preproc.a
%%DYNAMIC%%@dirrmtry lib/snort/dynamic_preproc
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dce2_preproc.a
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dce2_preproc.la
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dce2_preproc.so
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dce2_preproc.so.0
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dnp3_preproc.a
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dnp3_preproc.la
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dnp3_preproc.so.0
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dnp3_preproc.so
-%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dnp3_preproc.la
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dns_preproc.a
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dns_preproc.la
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dns_preproc.so
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_dns_preproc.so.0
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ftptelnet_preproc.a
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ftptelnet_preproc.la
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ftptelnet_preproc.so
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ftptelnet_preproc.so.0
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_gtp_preproc.a
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_gtp_preproc.so.0
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_gtp_preproc.so
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_gtp_preproc.la
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_imap_preproc.a
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_imap_preproc.so.0
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_imap_preproc.so
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_imap_preproc.la
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_modbus_preproc.a
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_modbus_preproc.la
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_modbus_preproc.so.0
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_modbus_preproc.so
-%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_modbus_preproc.la
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_pop_preproc.a
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_pop_preproc.so.0
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_pop_preproc.so
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_pop_preproc.la
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_reputation_preproc.a
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_reputation_preproc.la
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_reputation_preproc.so.0
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_reputation_preproc.so
-%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_reputation_preproc.la
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_sdf_preproc.a
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_sdf_preproc.la
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_sdf_preproc.so
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_sdf_preproc.so.0
-%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_sip_preproc.so.0
-%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_sip_preproc.so
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_sip_preproc.a
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_sip_preproc.la
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_sip_preproc.so
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_sip_preproc.so.0
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_smtp_preproc.a
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_smtp_preproc.la
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_smtp_preproc.so
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_smtp_preproc.so.0
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ssh_preproc.a
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ssh_preproc.la
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ssh_preproc.so
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ssh_preproc.so.0
+%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ssl_preproc.a
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ssl_preproc.la
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ssl_preproc.so
%%DYNAMIC%%lib/snort/dynamicpreprocessor/libsf_ssl_preproc.so.0
@@ -175,11 +213,6 @@ etc/snort/preproc_rules/sensitive-data.rules-sample
%%DYNAMIC%%lib/snort/dynamicpreprocessor/lib_sfdynamic_preprocessor_example.la
%%DYNAMIC%%@dirrmtry lib/snort/dynamicpreprocessor
%%DYNAMIC%%@dirrmtry lib/snort
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/create_db2
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/create_mssql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/create_mysql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/create_oracle.sql
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/create_postgresql
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/BUGS
@@ -188,7 +221,6 @@ etc/snort/preproc_rules/sensitive-data.rules-sample
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/PROBLEMS
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.ARUBA
%%PORTDOCS%%%%DOCSDIR%%/README.GTP
%%PORTDOCS%%%%DOCSDIR%%/README.PLUGINS
%%PORTDOCS%%%%DOCSDIR%%/README.PerfProfiling
@@ -200,7 +232,6 @@ etc/snort/preproc_rules/sensitive-data.rules-sample
%%PORTDOCS%%%%DOCSDIR%%/README.asn1
%%PORTDOCS%%%%DOCSDIR%%/README.counts
%%PORTDOCS%%%%DOCSDIR%%/README.csv
-%%PORTDOCS%%%%DOCSDIR%%/README.database
%%PORTDOCS%%%%DOCSDIR%%/README.daq
%%PORTDOCS%%%%DOCSDIR%%/README.dcerpc2
%%PORTDOCS%%%%DOCSDIR%%/README.decode
@@ -233,6 +264,7 @@ etc/snort/preproc_rules/sensitive-data.rules-sample
%%PORTDOCS%%%%DOCSDIR%%/README.stream5
%%PORTDOCS%%%%DOCSDIR%%/README.tag
%%PORTDOCS%%%%DOCSDIR%%/README.thresholding
+%%PORTDOCS%%%%DOCSDIR%%/README.unified2
%%PORTDOCS%%%%DOCSDIR%%/README.u2boat
%%PORTDOCS%%%%DOCSDIR%%/README.variables
%%PORTDOCS%%%%DOCSDIR%%/README.rzb_saac
@@ -243,7 +275,7 @@ etc/snort/preproc_rules/sensitive-data.rules-sample
%%PORTDOCS%%%%DOCSDIR%%/faq.pdf
%%PORTDOCS%%%%DOCSDIR%%/generators
%%PORTDOCS%%%%DOCSDIR%%/snort_manual.pdf
-%%PORTDOCS%%%%DOCSDIR%%/snort_schema_v106.pdf
%%PORTDOCS%%@dirrm %%DOCSDIR%%
libdata/pkgconfig/snort.pc
+libdata/pkgconfig/snort_output.pc
libdata/pkgconfig/snort_preproc.pc