aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-10-09 20:10:02 +0800
committerjbeich <jbeich@FreeBSD.org>2016-10-09 20:10:02 +0800
commit4f019a52672f513b8a0fed0ca76a586964ea5878 (patch)
treefedaedc28676986b730a2a891c51409a466b2d72 /security
parenta5dec5ea0b27cbaa85090a9cdca12a69a934a32f (diff)
downloadfreebsd-ports-gnome-4f019a52672f513b8a0fed0ca76a586964ea5878.tar.gz
freebsd-ports-gnome-4f019a52672f513b8a0fed0ca76a586964ea5878.tar.zst
freebsd-ports-gnome-4f019a52672f513b8a0fed0ca76a586964ea5878.zip
devel/nspr, security/nss: drop version from SONAME
No other downstream appends synthetic library version, and doing so causes underlinking due to fragile build system (see below). Not to mention being unable to swap out bundled libs from upstream builds. $ cc -lplds4 -L/usr/local/lib /usr/lib/crt1.o: In function `_start1': crt1_c.c:(.text+0xa6): undefined reference to `main' /usr/local/lib/libplds4.so: undefined reference to `pthread_set_name_np' /usr/local/lib/libplds4.so: undefined reference to `pthread_create' /usr/local/lib/libplds4.so: undefined reference to `pthread_condattr_init' /usr/local/lib/libplds4.so: undefined reference to `pthread_setschedparam' /usr/local/lib/libplds4.so: undefined reference to `pthread_getschedparam' PR: 213144 Exp-run by: antoine
Diffstat (limited to 'security')
-rw-r--r--security/libfprint/Makefile1
-rw-r--r--security/nss/Makefile5
-rw-r--r--security/nss/files/patch-coreconf_FreeBSD.mk21
-rw-r--r--security/nss/files/patch-coreconf_rules.mk12
-rw-r--r--security/nss/pkg-plist9
-rw-r--r--security/nss_compat_ossl/Makefile1
-rw-r--r--security/pidgin-encryption/Makefile2
-rw-r--r--security/sssd/Makefile2
-rw-r--r--security/suricata/Makefile2
-rw-r--r--security/xmlsec1/Makefile1
10 files changed, 14 insertions, 42 deletions
diff --git a/security/libfprint/Makefile b/security/libfprint/Makefile
index 04c41de7e714..96da28b9a2ba 100644
--- a/security/libfprint/Makefile
+++ b/security/libfprint/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libfprint
PORTVERSION= 0.6.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://people.freedesktop.org/~hadess/
diff --git a/security/nss/Makefile b/security/nss/Makefile
index 8a9a5bd2e56d..00be3b996666 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -3,6 +3,7 @@
PORTNAME= nss
PORTVERSION= 3.27.1
+PORTREVISION= 1
#DISTVERSIONSUFFIX= -with-ckbi-1.98
CATEGORIES= security
MASTER_SITES= MOZILLA/security/${PORTNAME}/releases/${DISTNAME:tu:C/[-.]/_/g}_RTM/src
@@ -89,7 +90,7 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/include/nss/nss ${STAGEDIR}${PREFIX}/lib/nss
${FIND} ${DIST}/public/nss -type l \
-exec ${INSTALL_DATA} {} ${STAGEDIR}${PREFIX}/include/nss/nss \;
- ${INSTALL_LIB} ${BINS}/lib/*.so.1 \
+ ${INSTALL_LIB} ${BINS}/lib/*.so \
${STAGEDIR}${PREFIX}/lib/nss
${INSTALL_DATA} ${BINS}/lib/libcrmf.a \
${STAGEDIR}${PREFIX}/lib/nss
@@ -97,8 +98,6 @@ do-install:
${INSTALL_PROGRAM} ${BINS}/bin/${bin} \
${STAGEDIR}${PREFIX}/bin
.endfor
- cd ${BINS}/lib && \
- ${TAR} -cf - *.so | ${TAR} --unlink -C ${STAGEDIR}${PREFIX}/lib/nss -xf -
${INSTALL_SCRIPT} ${WRKDIR}/nss-config ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKDIR}/nss.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig
diff --git a/security/nss/files/patch-coreconf_FreeBSD.mk b/security/nss/files/patch-coreconf_FreeBSD.mk
index f77bd7e725ba..2cbc8d92fefd 100644
--- a/security/nss/files/patch-coreconf_FreeBSD.mk
+++ b/security/nss/files/patch-coreconf_FreeBSD.mk
@@ -30,25 +30,16 @@
OS_CFLAGS = $(DSO_CFLAGS) -ansi -Wall -Wno-switch -DFREEBSD -DHAVE_STRERROR -DHAVE_BSD_FLOCK
-@@ -70,15 +85,15 @@
-
- ARCH = freebsd
-
--MOZ_OBJFORMAT := $(shell test -x /usr/bin/objformat && /usr/bin/objformat || echo elf)
-+ifndef MOZILLA_CLIENT
-+DLL_SUFFIX = so.1
-+endif
+@@ -46,7 +56,11 @@ else
+ DLL_SUFFIX = so.1.0
+ endif
--ifeq ($(MOZ_OBJFORMAT),elf)
--DLL_SUFFIX = so
+-MKSHLIB = $(CC) $(DSO_LDOPTS)
+ifneq (,$(filter alpha ia64,$(OS_TEST)))
+MKSHLIB = $(CC) -Wl,-Bsymbolic -lc $(DSO_LDOPTS)
- else
--DLL_SUFFIX = so.1.0
++else
+MKSHLIB = $(CC) -Wl,-Bsymbolic $(DSO_LDOPTS)
- endif
--
--MKSHLIB = $(CC) $(DSO_LDOPTS)
++endif
ifdef MAPFILE
MKSHLIB += -Wl,--version-script,$(MAPFILE)
endif
diff --git a/security/nss/files/patch-coreconf_rules.mk b/security/nss/files/patch-coreconf_rules.mk
deleted file mode 100644
index 22fb9a317288..000000000000
--- a/security/nss/files/patch-coreconf_rules.mk
+++ /dev/null
@@ -1,12 +0,0 @@
---- coreconf/rules.mk.orig Sat Jan 6 00:48:54 2007
-+++ coreconf/rules.mk Fri Mar 23 10:15:46 2007
-@@ -114,6 +114,9 @@
- endif
- ifdef SHARED_LIBRARY
- $(INSTALL) -m 775 $(SHARED_LIBRARY) $(SOURCE_LIB_DIR)
-+ifndef MOZILLA_CLIENT
-+ ln -sf $(notdir $(SHARED_LIBRARY)) $(SOURCE_LIB_DIR)/$(notdir $(SHARED_LIBRARY:.so.1=.so))
-+endif
- ifdef MOZ_DEBUG_SYMBOLS
- ifeq (,$(filter-out _WIN%,$(NS_USE_GCC)_$(OS_TARGET)))
- $(INSTALL) -m 644 $(SHARED_LIBRARY:$(DLL_SUFFIX)=pdb) $(SOURCE_LIB_DIR)
diff --git a/security/nss/pkg-plist b/security/nss/pkg-plist
index dacf1c3c2593..6ebb7829ab18 100644
--- a/security/nss/pkg-plist
+++ b/security/nss/pkg-plist
@@ -123,21 +123,12 @@ include/nss/nss/utilparst.h
include/nss/nss/utilrename.h
lib/nss/libcrmf.a
lib/nss/libfreebl3.so
-lib/nss/libfreebl3.so.1
lib/nss/libfreeblpriv3.so
-lib/nss/libfreeblpriv3.so.1
lib/nss/libnss3.so
-lib/nss/libnss3.so.1
lib/nss/libnssckbi.so
-lib/nss/libnssckbi.so.1
lib/nss/libnssdbm3.so
-lib/nss/libnssdbm3.so.1
lib/nss/libnssutil3.so
-lib/nss/libnssutil3.so.1
lib/nss/libsmime3.so
-lib/nss/libsmime3.so.1
lib/nss/libsoftokn3.so
-lib/nss/libsoftokn3.so.1
lib/nss/libssl3.so
-lib/nss/libssl3.so.1
libdata/pkgconfig/nss.pc
diff --git a/security/nss_compat_ossl/Makefile b/security/nss_compat_ossl/Makefile
index 883edad3cb47..31a9e56f66a5 100644
--- a/security/nss_compat_ossl/Makefile
+++ b/security/nss_compat_ossl/Makefile
@@ -2,6 +2,7 @@
PORTNAME= nss_compat_ossl
PORTVERSION= 0.9.6
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://rcritten.fedorapeople.org/
diff --git a/security/pidgin-encryption/Makefile b/security/pidgin-encryption/Makefile
index e449ee316388..75e485e166d2 100644
--- a/security/pidgin-encryption/Makefile
+++ b/security/pidgin-encryption/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pidgin
PORTVERSION= 3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}-encrypt/Releases/${PORTVERSION}
PKGNAMESUFFIX= -encryption
diff --git a/security/sssd/Makefile b/security/sssd/Makefile
index 3e991be86986..d9bc069b4d3a 100644
--- a/security/sssd/Makefile
+++ b/security/sssd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sssd
PORTVERSION= 1.11.7
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= https://fedorahosted.org/released/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
diff --git a/security/suricata/Makefile b/security/suricata/Makefile
index 66d643669ef2..002c15b49fd1 100644
--- a/security/suricata/Makefile
+++ b/security/suricata/Makefile
@@ -3,7 +3,7 @@
PORTNAME= suricata
PORTVERSION= 3.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.openinfosecfoundation.org/download/
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index 4065461e89ec..fea29a99f009 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -3,6 +3,7 @@
PORTNAME= xmlsec1
PORTVERSION= 1.2.22
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
ftp://ftp.aleksey.com/pub/xmlsec/releases/ \