aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2000-10-30 20:57:16 +0800
committersteve <steve@FreeBSD.org>2000-10-30 20:57:16 +0800
commit51eb911abaef92c9082ea5afe9e529efb4be3690 (patch)
tree9379ea40da39df6a82ef3d3158294746e1104900 /security
parentd2159372a2dca296853c18fac9714dba74622cdd (diff)
downloadfreebsd-ports-gnome-51eb911abaef92c9082ea5afe9e529efb4be3690.tar.gz
freebsd-ports-gnome-51eb911abaef92c9082ea5afe9e529efb4be3690.tar.zst
freebsd-ports-gnome-51eb911abaef92c9082ea5afe9e529efb4be3690.zip
Don't install etc/rc.d/sshd.sh if sshd is being started from inetd.conf.
PR: 15691 Submitted by: Roger Marquis <marquis@roble.com> Reviewed by: maintainer
Diffstat (limited to 'security')
-rw-r--r--security/ssh2/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index 002bf70252e9..dcec14d0a452 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -55,11 +55,13 @@ post-install:
.endfor
.endif
#
- @if [ ! -f ${PREFIX}/etc/rc.d/sshd.sh ]; then \
+ @if [ "`grep ssh /etc/inetd.conf|grep -v ^#ssh`" = "" ]; then \
+ if [ ! -f ${PREFIX}/etc/rc.d/sshd.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/sshd.sh startup file."; \
${SED} -e 's+!!PREFIX!!+${PREFIX}+' < ${FILESDIR}/sshd.sh \
> ${PREFIX}/etc/rc.d/sshd.sh; \
${CHMOD} 751 ${PREFIX}/etc/rc.d/sshd.sh; \
+ fi; \
fi
.include <bsd.port.post.mk>