aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-12-18 20:25:01 +0800
committerrakuco <rakuco@FreeBSD.org>2015-12-18 20:25:01 +0800
commit530650a0b8184f653ef4e20a751a4e14ef415679 (patch)
treedf3613672ecb725185e65e71f09ab7b7deec6bab /security
parentabdc435a7fa6cd470a220d676c88f7643527cef6 (diff)
downloadfreebsd-ports-gnome-530650a0b8184f653ef4e20a751a4e14ef415679.tar.gz
freebsd-ports-gnome-530650a0b8184f653ef4e20a751a4e14ef415679.tar.zst
freebsd-ports-gnome-530650a0b8184f653ef4e20a751a4e14ef415679.zip
Add upstream commit to fix build errors with -pedantic.
This fixes at least devel/ccrtp's build on 9.3, which is currently broken: In file included from ccrtp/crypto/gcrypt/gcrypthmac.cpp:23: /usr/local/include/gcrypt.h:509: error: comma at end of enumerator list /usr/local/include/gcrypt.h:1346: error: comma at end of enumerator list Makefile:571: recipe for target 'gcrypthmac.lo' failed MFH'ing this is not necessary, this bug is only present in libgcrypt 1.6.4. PR: 205000 Approved by: maintainer timeout (15 days)
Diffstat (limited to 'security')
-rw-r--r--security/libgcrypt/Makefile2
-rw-r--r--security/libgcrypt/files/patch-git_f583228540
2 files changed, 41 insertions, 1 deletions
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index 5d487587387f..19116bdaed1f 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -2,7 +2,7 @@
PORTNAME= libgcrypt
PORTVERSION= 1.6.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= GNUPG
diff --git a/security/libgcrypt/files/patch-git_f5832285 b/security/libgcrypt/files/patch-git_f5832285
new file mode 100644
index 000000000000..cc2b6d3b9aea
--- /dev/null
+++ b/security/libgcrypt/files/patch-git_f5832285
@@ -0,0 +1,40 @@
+Fixes at least devel/ccrtp's build:
+ In file included from ccrtp/crypto/gcrypt/gcrypthmac.cpp:23:
+ /usr/local/include/gcrypt.h:509: error: comma at end of enumerator list
+ /usr/local/include/gcrypt.h:1346: error: comma at end of enumerator list
+
+From: Werner Koch <wk@gnupg.org>
+Date: Thu, 19 Mar 2015 09:43:55 +0000 (+0100)
+Subject: Fix two pedantic warnings.
+X-Git-Url: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commitdiff_plain;h=f5832285b0e420d77be1b8da10a1e1d86583b414
+
+Fix two pedantic warnings.
+
+* src/gcrypt.h.in (gcry_mpi_flag, gcry_mac_algos): Remove trailing
+comma.
+--
+
+Reported-by: Opal Raava <opalraava@hushmail.com>
+Signed-off-by: Werner Koch <wk@gnupg.org>
+---
+
+--- src/gcrypt.h.in
++++ src/gcrypt.h.in
+@@ -511,7 +511,7 @@ enum gcry_mpi_flag
+ GCRYMPI_FLAG_USER1 = 0x0100,/* User flag 1. */
+ GCRYMPI_FLAG_USER2 = 0x0200,/* User flag 2. */
+ GCRYMPI_FLAG_USER3 = 0x0400,/* User flag 3. */
+- GCRYMPI_FLAG_USER4 = 0x0800,/* User flag 4. */
++ GCRYMPI_FLAG_USER4 = 0x0800 /* User flag 4. */
+ };
+
+
+@@ -1372,7 +1372,7 @@ enum gcry_mac_algos
+ /* Flags used with the open function. */
+ enum gcry_mac_flags
+ {
+- GCRY_MAC_FLAG_SECURE = 1, /* Allocate all buffers in "secure" memory. */
++ GCRY_MAC_FLAG_SECURE = 1 /* Allocate all buffers in "secure" memory. */
+ };
+
+ /* Create a MAC handle for algorithm ALGO. FLAGS may be given as an bitwise OR