aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>2005-09-03 00:25:29 +0800
committerse <se@FreeBSD.org>2005-09-03 00:25:29 +0800
commit531b1a7cb4590edf2953baf8c99b31a4cfe2c7e2 (patch)
tree454ebdc835576d31ea7bbde92bc9183d6da51f50 /security
parent9b15301507dfd8b7137e9eaa28c911ce76d71179 (diff)
downloadfreebsd-ports-gnome-531b1a7cb4590edf2953baf8c99b31a4cfe2c7e2.tar.gz
freebsd-ports-gnome-531b1a7cb4590edf2953baf8c99b31a4cfe2c7e2.tar.zst
freebsd-ports-gnome-531b1a7cb4590edf2953baf8c99b31a4cfe2c7e2.zip
Fix build on 4-stable: Use ports version of libpcap since system version
is too old.
Diffstat (limited to 'security')
-rw-r--r--security/yersinia/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/security/yersinia/Makefile b/security/yersinia/Makefile
index 71cbc88e8719..26098562a107 100644
--- a/security/yersinia/Makefile
+++ b/security/yersinia/Makefile
@@ -14,9 +14,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= se@FreeBSD.org
COMMENT= Layer 2 vulnerability scanner (switches, spanning tree, 802.1q ...)
+.include <bsd.port.pre.mk>
+
# Dependency on file that is not also installed by libnet (1.0.2) port!
BUILD_DEPENDS= ${LOCALBASE}/share/examples/libnet/ip_raw.c:${PORTSDIR}/net/libnet-devel
+.if ${OSVERSION} < 500000
+BUILD_DEPENDS= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -30,4 +36,4 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/yersinia ${PREFIX}/sbin/
${INSTALL_MAN} ${WRKSRC}/yersinia.8 ${PREFIX}/man/man8/
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>