aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2021-01-19 12:26:12 +0800
committerJason E. Hale <jhale@FreeBSD.org>2021-01-19 12:26:12 +0800
commit54557556437e82b0ffd1912584b4895cfe301ba9 (patch)
treea0889819c82e505a0706a1bb9caa9b42b73d7526 /security
parent8d24cbd5ac2baaeea3b84291de205269a0837fcd (diff)
downloadfreebsd-ports-gnome-54557556437e82b0ffd1912584b4895cfe301ba9.tar.gz
freebsd-ports-gnome-54557556437e82b0ffd1912584b4895cfe301ba9.tar.zst
freebsd-ports-gnome-54557556437e82b0ffd1912584b4895cfe301ba9.zip
security/cryptopp: Update to 8.4.0
Bump PORTREVSION on all consumers. ABI-breaking changes were introduced and recompile of consumers is necessary. Remove unused cryptopp dependency from devel/xeus. Upstream migrated to OpenSSL several releases ago. [1] [1] https://github.com/jupyter-xeus/xeus/commit/c98c44c174cafcf424f4203dc3c61564118feb3e Changes: https://www.cryptopp.com/release840.html
Diffstat (limited to 'security')
-rw-r--r--security/cryptopp/Makefile2
-rw-r--r--security/cryptopp/distinfo6
-rw-r--r--security/cryptopp/files/patch-GNUmakefile10
-rw-r--r--security/cryptopp/files/patch-misc.h12
-rw-r--r--security/cryptopp/pkg-plist16
5 files changed, 31 insertions, 15 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 69af1df44886..0184c80eb3f5 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cryptopp
-PORTVERSION= 8.2.0
+PORTVERSION= 8.4.0
CATEGORIES= security
MASTER_SITES= http://www.cryptopp.com/
DISTNAME= cryptopp${PORTVERSION:S/.//g}
diff --git a/security/cryptopp/distinfo b/security/cryptopp/distinfo
index 15f72bee6bcf..21123d931fae 100644
--- a/security/cryptopp/distinfo
+++ b/security/cryptopp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1575820181
-SHA256 (cryptopp820.zip) = 03f0e2242e11b9d19b28d0ec5a3fa8ed5cc7b27640e6bed365744f593e858058
-SIZE (cryptopp820.zip) = 8859815
+TIMESTAMP = 1610559898
+SHA256 (cryptopp840.zip) = c0f5e5cd2c693c8160e9c51666e95949a1c19fd4fe4fef874af2ec1e42757b9a
+SIZE (cryptopp840.zip) = 9124180
diff --git a/security/cryptopp/files/patch-GNUmakefile b/security/cryptopp/files/patch-GNUmakefile
index 3e73b7ea6372..1fc8ef2b3017 100644
--- a/security/cryptopp/files/patch-GNUmakefile
+++ b/security/cryptopp/files/patch-GNUmakefile
@@ -2,9 +2,9 @@ We need to export the CRYPTOPP_DISABLE_ASM flag if cryptopp was not built
with SIMD support. Certain functions prototypes are guarded by this
flag and build failures will arise in other ports if not set appropriately.
---- GNUmakefile.orig 2019-04-28 23:36:50 UTC
+--- GNUmakefile.orig 2021-01-01 17:22:45 UTC
+++ GNUmakefile
-@@ -57,7 +57,7 @@ ifeq ($(SYSTEMX),)
+@@ -71,7 +71,7 @@ ifeq ($(SYSTEMX),)
SYSTEMX := $(shell uname -s 2>/dev/null)
endif
@@ -13,7 +13,7 @@ flag and build failures will arise in other ports if not set appropriately.
IS_HURD := $(shell echo "$(SYSTEMX)" | $(GREP) -i -c -E "GNU|Hurd")
IS_MINGW := $(shell echo "$(SYSTEMX)" | $(GREP) -i -c "MinGW")
IS_CYGWIN := $(shell echo "$(SYSTEMX)" | $(GREP) -i -c "Cygwin")
-@@ -742,7 +742,7 @@ endif
+@@ -795,7 +795,7 @@ endif
# Use -pthread whenever it is available. See http://www.hpl.hp.com/techreports/2004/HPL-2004-209.pdf
# http://stackoverflow.com/questions/2127797/gcc-significance-of-pthread-flag-when-compiling
@@ -22,8 +22,8 @@ flag and build failures will arise in other ports if not set appropriately.
ifeq ($(XLC_COMPILER),1)
ifeq ($(findstring -qthreaded,$(CXXFLAGS)),)
TPROG = TestPrograms/test_pthreads.cxx
-@@ -1341,7 +1341,7 @@ libcryptopp.pc:
- @echo 'Version: 8.2' >> libcryptopp.pc
+@@ -1450,7 +1450,7 @@ libcryptopp.pc:
+ @echo 'Version: 8.4' >> libcryptopp.pc
@echo 'URL: https://cryptopp.com/' >> libcryptopp.pc
@echo '' >> libcryptopp.pc
- @echo 'Cflags: -I$${includedir}' >> libcryptopp.pc
diff --git a/security/cryptopp/files/patch-misc.h b/security/cryptopp/files/patch-misc.h
index 194061634cb6..165720d6bef7 100644
--- a/security/cryptopp/files/patch-misc.h
+++ b/security/cryptopp/files/patch-misc.h
@@ -2,12 +2,12 @@ This fixes a warning triggered by testing an unsigned parameter
against 0. The patch solves this by creating a different template
for signed case. (PR: 178827)
---- misc.h.orig 2018-04-08 08:47:11 UTC
+--- misc.h.orig 2021-01-01 17:03:59 UTC
+++ misc.h
-@@ -572,8 +572,10 @@ inline bool SafeConvert(T1 from, T2 &to)
+@@ -700,8 +700,10 @@ inline bool SafeConvert(T1 from, T2 &to)
/// \param value the value to convert
/// \param base the base to use during the conversion
- /// \returns the string representation of value in base.
+ /// \return the string representation of value in base.
+template<bool> struct IsUnsigned {};
+
template <class T>
@@ -15,8 +15,8 @@ for signed case. (PR: 178827)
+std::string IntToStringImpl(T value, unsigned int base, IsUnsigned<true>)
{
// Hack... set the high bit for uppercase.
- static const unsigned int HIGH_BIT = (1U << 31);
-@@ -584,12 +586,6 @@ std::string IntToString(T value, unsigned int base = 1
+ const unsigned int HIGH_BIT = (1U << 31);
+@@ -712,12 +714,6 @@ std::string IntToString(T value, unsigned int base = 1
if (value == 0)
return "0";
@@ -29,7 +29,7 @@ for signed case. (PR: 178827)
std::string result;
while (value > 0)
{
-@@ -597,9 +593,28 @@ std::string IntToString(T value, unsigned int base = 1
+@@ -725,9 +721,28 @@ std::string IntToString(T value, unsigned int base = 1
result = char((digit < 10 ? '0' : (CH - 10)) + digit) + result;
value /= base;
}
diff --git a/security/cryptopp/pkg-plist b/security/cryptopp/pkg-plist
index 39c7b05697ba..846df409789b 100644
--- a/security/cryptopp/pkg-plist
+++ b/security/cryptopp/pkg-plist
@@ -6,6 +6,7 @@ include/cryptopp/aes.h
include/cryptopp/aes_armv4.h
include/cryptopp/algebra.h
include/cryptopp/algparam.h
+include/cryptopp/allocate.h
include/cryptopp/arc4.h
include/cryptopp/argnames.h
include/cryptopp/aria.h
@@ -29,6 +30,16 @@ include/cryptopp/cham.h
include/cryptopp/channels.h
include/cryptopp/cmac.h
include/cryptopp/config.h
+include/cryptopp/config_align.h
+include/cryptopp/config_asm.h
+include/cryptopp/config_cpu.h
+include/cryptopp/config_cxx.h
+include/cryptopp/config_dll.h
+include/cryptopp/config_int.h
+include/cryptopp/config_misc.h
+include/cryptopp/config_ns.h
+include/cryptopp/config_os.h
+include/cryptopp/config_ver.h
include/cryptopp/cpu.h
include/cryptopp/crc.h
include/cryptopp/cryptlib.h
@@ -131,12 +142,16 @@ include/cryptopp/salsa.h
include/cryptopp/scrypt.h
include/cryptopp/seal.h
include/cryptopp/secblock.h
+include/cryptopp/secblockfwd.h
include/cryptopp/seckey.h
include/cryptopp/seed.h
include/cryptopp/serpent.h
include/cryptopp/serpentp.h
include/cryptopp/sha.h
+include/cryptopp/sha1_armv4.h
+include/cryptopp/sha256_armv4.h
include/cryptopp/sha3.h
+include/cryptopp/sha512_armv4.h
include/cryptopp/shacal2.h
include/cryptopp/shake.h
include/cryptopp/shark.h
@@ -169,6 +184,7 @@ include/cryptopp/words.h
include/cryptopp/xed25519.h
include/cryptopp/xtr.h
include/cryptopp/xtrcrypt.h
+include/cryptopp/xts.h
include/cryptopp/zdeflate.h
include/cryptopp/zinflate.h
include/cryptopp/zlib.h