aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2021-05-21 23:11:07 +0800
committerCharlie Li <vishwin@FreeBSD.org>2021-05-21 23:11:07 +0800
commit58a2c0b4b774c28cdb023d5cab9c1179b7f88af3 (patch)
tree8da76b518b7de2d338a7e3628fb547e41deed902 /security
parentbbca650855a2ab1d5af084bd83ea080ec80d83e1 (diff)
downloadfreebsd-ports-gnome-58a2c0b4b774c28cdb023d5cab9c1179b7f88af3.tar.gz
freebsd-ports-gnome-58a2c0b4b774c28cdb023d5cab9c1179b7f88af3.tar.zst
freebsd-ports-gnome-58a2c0b4b774c28cdb023d5cab9c1179b7f88af3.zip
security/py-cryptography: fix build on FreeBSD 11
The LibreSSL 3.3.2+ patch does not and was never intended to apply with older py-cryptography 2.9.2 that we offer for FreeBSD 11 using base OpenSSL. For now, make the LibreSSL 3.3.2+ patch conditional on SSL_DEFAULT=libressl* until FreeBSD 11 goes EOL. Reported by: dvl Fixes: 6f05c9c07cff security/py-cryptography: fix build with LibreSSL 3.3.2+ Pointy hat to: vishwin Approved by: koobs (maintainer, implicit), fluffly (mentor, implicit) PR: 255241
Diffstat (limited to 'security')
-rw-r--r--security/py-cryptography/Makefile6
-rw-r--r--security/py-cryptography/files/extra-patch-Fix-build-with-LibreSSL-3.3.2-5988 (renamed from security/py-cryptography/files/patch-Fix-build-with-LibreSSL-3.3.2-5988)0
2 files changed, 6 insertions, 0 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 6f9273719204..0e8e8337092e 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -54,6 +54,12 @@ EXTRA_PATCHES= ${PATCHDIR}/openssl102u
. endif
.endif
+# Apply LibreSSL upstream patch that conflicts with above patch for 2.9.2
+# XXX convert back to unconditional when FreeBSD 11 goes EOL
+.if ${SSL_DEFAULT:Mlibressl*}
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-Fix-build-with-LibreSSL-3.3.2-5988
+.endif
+
.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
post-patch:
@${REINPLACE_CMD} -e 's|"-Wno-error=sign-conversion"||' \
diff --git a/security/py-cryptography/files/patch-Fix-build-with-LibreSSL-3.3.2-5988 b/security/py-cryptography/files/extra-patch-Fix-build-with-LibreSSL-3.3.2-5988
index deb9c6408832..deb9c6408832 100644
--- a/security/py-cryptography/files/patch-Fix-build-with-LibreSSL-3.3.2-5988
+++ b/security/py-cryptography/files/extra-patch-Fix-build-with-LibreSSL-3.3.2-5988