aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2014-04-19 04:30:09 +0800
committercs <cs@FreeBSD.org>2014-04-19 04:30:09 +0800
commit59e2741ba78919e74431c2e8d472172a5f88a94a (patch)
tree78c68698a37280a7026b95fd6ab8376580e08e46 /security
parent63dc53b959f8dd7f5d4aea39483bfd12e4eef4ed (diff)
downloadfreebsd-ports-gnome-59e2741ba78919e74431c2e8d472172a5f88a94a.tar.gz
freebsd-ports-gnome-59e2741ba78919e74431c2e8d472172a5f88a94a.tar.zst
freebsd-ports-gnome-59e2741ba78919e74431c2e8d472172a5f88a94a.zip
Meek is a transport that uses HTTP for carrying bytes and TLS for obfuscation.
Traffic is relayed through a third-party server (Google App Engine). It uses a trick to talk to the third party so that it looks like it is talking to an unblocked server. WWW: https://trac.torproject.org/projects/tor/wiki/doc/meek
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/meek/Makefile25
-rw-r--r--security/meek/distinfo2
-rw-r--r--security/meek/files/pkg-message.in13
-rw-r--r--security/meek/pkg-descr6
5 files changed, 47 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 9f992de2fff2..5e58d6a9e1f2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -313,6 +313,7 @@
SUBDIR += md5deep
SUBDIR += mdcrack
SUBDIR += medusa
+ SUBDIR += meek
SUBDIR += metasploit
SUBDIR += mhash
SUBDIR += mindterm-binary
diff --git a/security/meek/Makefile b/security/meek/Makefile
new file mode 100644
index 000000000000..f8c76557fa66
--- /dev/null
+++ b/security/meek/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= meek
+PORTVERSION= 0.4
+CATEGORIES= security
+MASTER_SITES= http://c-s.li/ports/
+
+MAINTAINER= cs@FreeBSD.org
+COMMENT= Pluggable transport proxy that relays through third-party server
+
+BUILD_DEPENDS= ${LOCALBASE}/${GO_LIBDIR}/git.torproject.org/pluggable-transports/goptlib.git.a:${PORTSDIR}/security/goptlib
+
+PLIST_FILES= bin/meek-client bin/meek-server
+SUB_FILES= pkg-message
+GO_PKGNAME= git.torproject.org/pluggable-transports/${PORTNAME}.git
+GO_TARGET= ${GO_PKGNAME}/${PORTNAME}-server \
+ ${GO_PKGNAME}/${PORTNAME}-client
+
+post-extract:
+ @${MKDIR} ${GO_WRKSRC:H}
+ @${LN} -sf ${WRKSRC} ${GO_WRKSRC}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/security/meek/distinfo b/security/meek/distinfo
new file mode 100644
index 000000000000..1ab6aa8ace30
--- /dev/null
+++ b/security/meek/distinfo
@@ -0,0 +1,2 @@
+SHA256 (meek-0.4.tar.gz) = 0dfc1323dc9f2037d4db25647beeda561bf2b4adaf9ff9783c3ba6de664517ca
+SIZE (meek-0.4.tar.gz) = 18490
diff --git a/security/meek/files/pkg-message.in b/security/meek/files/pkg-message.in
new file mode 100644
index 000000000000..f776f47aea6a
--- /dev/null
+++ b/security/meek/files/pkg-message.in
@@ -0,0 +1,13 @@
+================================================================================
+If you are using meek with tor, here are some instructions:
+
+As a client, add the following to %%PREFIX%%/etc/tor/torrc:
+
+ UseBridges 1
+ Bridge meek x.x.x.x:yyyy FINGERPRINT-OF-BRIDGE
+ ClientTransportPlugin meek exec ./meek-client \
+ --url=https://meek-reflect.example.com \
+ --front=www.example.com \
+ --log meek-client.log
+
+================================================================================
diff --git a/security/meek/pkg-descr b/security/meek/pkg-descr
new file mode 100644
index 000000000000..678d402116e1
--- /dev/null
+++ b/security/meek/pkg-descr
@@ -0,0 +1,6 @@
+Meek is a transport that uses HTTP for carrying bytes and TLS for obfuscation.
+Traffic is relayed through a third-party server (Google App Engine). It uses a
+trick to talk to the third party so that it looks like it is talking to an
+unblocked server.
+
+WWW: https://trac.torproject.org/projects/tor/wiki/doc/meek