aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2014-01-08 02:54:08 +0800
committergarga <garga@FreeBSD.org>2014-01-08 02:54:08 +0800
commit5d3cc39ec806e97fd9d7fad03b44450c6974e7db (patch)
treebbef4e56507f0d58384587bbc1d88cfc95d24aac /security
parent38bd148f1ab5ba5e6d6dfb67944dd71104502d70 (diff)
downloadfreebsd-ports-gnome-5d3cc39ec806e97fd9d7fad03b44450c6974e7db.tar.gz
freebsd-ports-gnome-5d3cc39ec806e97fd9d7fad03b44450c6974e7db.tar.zst
freebsd-ports-gnome-5d3cc39ec806e97fd9d7fad03b44450c6974e7db.zip
- Add a patch to fix bundled LLVM to build with libc++
- Remove USE_GCC=any PR: ports/185366 Submitted by: tijl@
Diffstat (limited to 'security')
-rw-r--r--security/clamav/Makefile3
-rw-r--r--security/clamav/files/patch-libclamav-c++-llvm72
2 files changed, 73 insertions, 2 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 2150afe4d51f..68a29e2c87f7 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -3,7 +3,7 @@
PORTNAME= clamav
PORTVERSION= 0.98
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MASTER_SITES= SF
@@ -44,7 +44,6 @@ IPV6_CONFIGURE_ENABLE= ipv6
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GCC= any
USES= gmake
USE_RC_SUBR= clamav-clamd clamav-freshclam
diff --git a/security/clamav/files/patch-libclamav-c++-llvm b/security/clamav/files/patch-libclamav-c++-llvm
new file mode 100644
index 000000000000..91c436b65f8b
--- /dev/null
+++ b/security/clamav/files/patch-libclamav-c++-llvm
@@ -0,0 +1,72 @@
+--- libclamav/c++/llvm/lib/Target/SubtargetFeature.cpp.orig
++++ libclamav/c++/llvm/lib/Target/SubtargetFeature.cpp
+@@ -18,6 +18,7 @@
+ #include <algorithm>
+ #include <cassert>
+ #include <cctype>
++#include <cstdlib>
+ using namespace llvm;
+
+ //===----------------------------------------------------------------------===//
+--- libclamav/c++/llvm/include/llvm/Support/CFG.h.orig
++++ libclamav/c++/llvm/include/llvm/Support/CFG.h
+@@ -27,8 +27,9 @@
+
+ template <class Ptr, class USE_iterator> // Predecessor Iterator
+ class PredIterator : public std::iterator<std::forward_iterator_tag,
+- Ptr, ptrdiff_t> {
+- typedef std::iterator<std::forward_iterator_tag, Ptr, ptrdiff_t> super;
++ Ptr, ptrdiff_t, Ptr*, Ptr*> {
++ typedef std::iterator<std::forward_iterator_tag, Ptr, ptrdiff_t, Ptr*,
++ Ptr*> super;
+ typedef PredIterator<Ptr, USE_iterator> Self;
+ USE_iterator It;
+
+@@ -40,6 +41,7 @@
+
+ public:
+ typedef typename super::pointer pointer;
++ typedef typename super::reference reference;
+
+ PredIterator() {}
+ explicit inline PredIterator(Ptr *bb) : It(bb->use_begin()) {
+@@ -50,7 +52,7 @@
+ inline bool operator==(const Self& x) const { return It == x.It; }
+ inline bool operator!=(const Self& x) const { return !operator==(x); }
+
+- inline pointer operator*() const {
++ inline reference operator*() const {
+ assert(!It.atEnd() && "pred_iterator out of range!");
+ return cast<TerminatorInst>(*It)->getParent();
+ }
+@@ -100,10 +102,11 @@
+
+ template <class Term_, class BB_> // Successor Iterator
+ class SuccIterator : public std::iterator<std::bidirectional_iterator_tag,
+- BB_, ptrdiff_t> {
++ BB_, ptrdiff_t, BB_*, BB_*> {
+ const Term_ Term;
+ unsigned idx;
+- typedef std::iterator<std::bidirectional_iterator_tag, BB_, ptrdiff_t> super;
++ typedef std::iterator<std::bidirectional_iterator_tag, BB_, ptrdiff_t, BB_*,
++ BB_*> super;
+ typedef SuccIterator<Term_, BB_> Self;
+
+ inline bool index_is_valid(int idx) {
+@@ -112,6 +115,7 @@
+
+ public:
+ typedef typename super::pointer pointer;
++ typedef typename super::reference reference;
+ // TODO: This can be random access iterator, only operator[] missing.
+
+ explicit inline SuccIterator(Term_ T) : Term(T), idx(0) {// begin iterator
+@@ -142,7 +146,7 @@
+ inline bool operator==(const Self& x) const { return idx == x.idx; }
+ inline bool operator!=(const Self& x) const { return !operator==(x); }
+
+- inline pointer operator*() const { return Term->getSuccessor(idx); }
++ inline reference operator*() const { return Term->getSuccessor(idx); }
+ inline pointer operator->() const { return operator*(); }
+
+ inline Self& operator++() { ++idx; return *this; } // Preincrement