aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-08-30 01:28:42 +0800
committerantoine <antoine@FreeBSD.org>2014-08-30 01:28:42 +0800
commit66d688539f8f60fe75eba85a92de97861fd2c673 (patch)
tree0e5d6fab51bd007b36c0cb572b0a1101d7343b04 /security
parent019d7cd2683659d7d0fc6c8a053ba9d6b9fc95fb (diff)
downloadfreebsd-ports-gnome-66d688539f8f60fe75eba85a92de97861fd2c673.tar.gz
freebsd-ports-gnome-66d688539f8f60fe75eba85a92de97861fd2c673.tar.zst
freebsd-ports-gnome-66d688539f8f60fe75eba85a92de97861fd2c673.zip
Convert a few ports to USES=python
Diffstat (limited to 'security')
-rw-r--r--security/py-cybox/Makefile5
-rw-r--r--security/py-plaso/Makefile5
-rw-r--r--security/py-volatility/Makefile5
-rw-r--r--security/wapiti/Makefile5
4 files changed, 8 insertions, 12 deletions
diff --git a/security/py-cybox/Makefile b/security/py-cybox/Makefile
index 1f5ee3408b9c..ce85161f0eb0 100644
--- a/security/py-cybox/Makefile
+++ b/security/py-cybox/Makefile
@@ -16,9 +16,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}lxml>=3.1:${PORTSDIR}/devel/py-lxml
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST=yes
+USES= python:2
+USE_PYTHON= distutils autoplist
PORTDOCS= README.rst
PORTEXAMPLES= *
diff --git a/security/py-plaso/Makefile b/security/py-plaso/Makefile
index 974279f808f7..6ebb5143ced1 100644
--- a/security/py-plaso/Makefile
+++ b/security/py-plaso/Makefile
@@ -39,9 +39,8 @@ RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}yaml>=0:${PORTSDIR}/devel/py-yaml
-USE_PYTHON= 2
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= python:2
+USE_PYTHON= distutils autoplist
PORTDOCS= ACKNOWLEDGEMENTS AUTHORS
PORTEXAMPLES= *
diff --git a/security/py-volatility/Makefile b/security/py-volatility/Makefile
index 62a0423a3173..5cbfc608208e 100644
--- a/security/py-volatility/Makefile
+++ b/security/py-volatility/Makefile
@@ -19,9 +19,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}distorm>=0:${PORTSDIR}/devel/py-distorm \
${PYTHON_PKGNAMEPREFIX}yara>=0:${PORTSDIR}/security/py-yara \
${PYTHON_PKGNAMEPREFIX}openpyxl>=0:${PORTSDIR}/textproc/py-openpyxl
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST=yes
+USES= python:2
+USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= DOCS
diff --git a/security/wapiti/Makefile b/security/wapiti/Makefile
index 4eb6974c9a28..6e38c5923d1e 100644
--- a/security/wapiti/Makefile
+++ b/security/wapiti/Makefile
@@ -15,8 +15,7 @@ LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup32>=0:${PORTSDIR}/www/py-beautifulsoup32 \
${PYTHON_PKGNAMEPREFIX}requests>=1.2.3:${PORTSDIR}/www/py-requests
-USE_PYTHON= 2
-USE_PYDISTUTILS=yes
-PYDISTUTILS_AUTOPLIST=yes
+USES= python:2
+USE_PYTHON= distutils autoplist
.include <bsd.port.mk>