aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-07-05 21:21:07 +0800
committerale <ale@FreeBSD.org>2013-07-05 21:21:07 +0800
commit68df37980efc945f616f73246a5aebaaf06cd9ab (patch)
treeeb31cf8b1d8503e88da879b4202c84a2d73876f3 /security
parentce0ea3d9081feced69cb5e02882bf8607ed59a33 (diff)
downloadfreebsd-ports-gnome-68df37980efc945f616f73246a5aebaaf06cd9ab.tar.gz
freebsd-ports-gnome-68df37980efc945f616f73246a5aebaaf06cd9ab.tar.zst
freebsd-ports-gnome-68df37980efc945f616f73246a5aebaaf06cd9ab.zip
Don't crash when backend cannot be signalled.
Update master sites. PR: ports/180291 Submitted by: Marcin Cieslak <saper@saper.info>
Diffstat (limited to 'security')
-rw-r--r--security/openct/Makefile5
-rw-r--r--security/openct/files/patch-ctapi.c15
2 files changed, 18 insertions, 2 deletions
diff --git a/security/openct/Makefile b/security/openct/Makefile
index 490c4a91bdd3..becc46b941e6 100644
--- a/security/openct/Makefile
+++ b/security/openct/Makefile
@@ -3,9 +3,10 @@
PORTNAME= openct
PORTVERSION= 0.6.20
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/ \
- http://www.opensc-project.org/files/${PORTNAME}/testing/
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= opensc/${PORTNAME}
MAINTAINER= ale@FreeBSD.org
COMMENT= Middleware framework for smart card terminals
diff --git a/security/openct/files/patch-ctapi.c b/security/openct/files/patch-ctapi.c
new file mode 100644
index 000000000000..02e7ef8e887d
--- /dev/null
+++ b/security/openct/files/patch-ctapi.c
@@ -0,0 +1,15 @@
+--- src/ctapi/ctapi.c 2006-04-25 23:58:06.000000000 +0200
++++ src/ctapi/ctapi.c 2013-07-05 10:08:41.000000000 +0200
+@@ -562,7 +562,11 @@
+ ct->next = cardTerminals;
+ cardTerminals = ct;
+ ct->cwd = &ct->mf;
+- ct_reader_info(pn, &info);
++ if (ct_reader_info(pn, &info) < 0) {
++ free(ct);
++ ct_error("ct_reader_info failed\n");
++ return ERR_INVALID;
++ }
+ ct->mf.id = 0x3f00;
+ ct->mf.gen = dir;
+ ct->mf.dir[0] = &ct->mf;