aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-08-30 15:12:43 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-08-30 15:12:43 +0800
commit6c2c873aa4768423da26f094bd70577302155587 (patch)
tree7857643ad585f6ca0f2e851502e3ae083c908f6c /security
parent359ea5d1be9dc49afa44dbde0c588be524b2d499 (diff)
downloadfreebsd-ports-gnome-6c2c873aa4768423da26f094bd70577302155587.tar.gz
freebsd-ports-gnome-6c2c873aa4768423da26f094bd70577302155587.tar.zst
freebsd-ports-gnome-6c2c873aa4768423da26f094bd70577302155587.zip
Add py-uhashring 1.2
uhashring implements consistent hashing in pure Python. Consistent hashing is mostly used on distributed systems/caches/databases as this avoid the total reshuffling of your key-node mappings when adding or removing a node in your ring (called continuum on libketama). WWW: https://github.com/ultrabug/uhashring
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-uhashring/Makefile21
-rw-r--r--security/py-uhashring/distinfo3
-rw-r--r--security/py-uhashring/pkg-descr7
4 files changed, 32 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 28c792f58dbb..a5cd60abe4c8 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -990,6 +990,7 @@
SUBDIR += py-trustme
SUBDIR += py-tuf
SUBDIR += py-txtorcon
+ SUBDIR += py-uhashring
SUBDIR += py-vici
SUBDIR += py-virustotal-api
SUBDIR += py-volatility3
diff --git a/security/py-uhashring/Makefile b/security/py-uhashring/Makefile
new file mode 100644
index 000000000000..97f6589fc3fe
--- /dev/null
+++ b/security/py-uhashring/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= uhashring
+PORTVERSION= 1.2
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Full featured consistent hashing python library
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-uhashring/distinfo b/security/py-uhashring/distinfo
new file mode 100644
index 000000000000..da2616917bb6
--- /dev/null
+++ b/security/py-uhashring/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1598605158
+SHA256 (uhashring-1.2.tar.gz) = f7304ca2ff763bbf1e2f8a78f21131721811619c5841de4f8c98063344906931
+SIZE (uhashring-1.2.tar.gz) = 17554
diff --git a/security/py-uhashring/pkg-descr b/security/py-uhashring/pkg-descr
new file mode 100644
index 000000000000..7b0f77fce0bd
--- /dev/null
+++ b/security/py-uhashring/pkg-descr
@@ -0,0 +1,7 @@
+uhashring implements consistent hashing in pure Python.
+
+Consistent hashing is mostly used on distributed systems/caches/databases as
+this avoid the total reshuffling of your key-node mappings when adding or
+removing a node in your ring (called continuum on libketama).
+
+WWW: https://github.com/ultrabug/uhashring