aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2019-05-06 12:15:27 +0800
committerkoobs <koobs@FreeBSD.org>2019-05-06 12:15:27 +0800
commit711c329dc5c1ece80faf5b72303d04df8fb0b351 (patch)
tree3a377b027bfdeda5517c9fa1f6a23aff2bfed363 /security
parent74c356eb6bb5370a5014bd54fcafffbad5d9d416 (diff)
downloadfreebsd-ports-gnome-711c329dc5c1ece80faf5b72303d04df8fb0b351.tar.gz
freebsd-ports-gnome-711c329dc5c1ece80faf5b72303d04df8fb0b351.tar.zst
freebsd-ports-gnome-711c329dc5c1ece80faf5b72303d04df8fb0b351.zip
security/py-libnacl: Update to 1.6.1
- Remove setup.py patch, use direct unittest invocation instead Changelog: https://libnacl.readthedocs.io/en/latest/topics/releases/index.html
Diffstat (limited to 'security')
-rw-r--r--security/py-libnacl/Makefile8
-rw-r--r--security/py-libnacl/distinfo6
-rw-r--r--security/py-libnacl/files/patch-setup.py10
3 files changed, 6 insertions, 18 deletions
diff --git a/security/py-libnacl/Makefile b/security/py-libnacl/Makefile
index 01675ff5e4ba..4ceab32a51a7 100644
--- a/security/py-libnacl/Makefile
+++ b/security/py-libnacl/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= libnacl
-PORTVERSION= 1.5.2
-PORTREVISION= 1
+PORTVERSION= 1.6.1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
-COMMENT= Python bindings for libsodium/tweetnacl based on ctypes
+COMMENT= Python bindings for libsodium based on ctypes
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -22,7 +21,6 @@ USE_PYTHON= autoplist distutils
NO_ARCH= yes
do-test:
- ${TOUCH} ${WRKSRC}/tests/__init__.py
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m unittest discover --start-directory tests -v
.include <bsd.port.mk>
diff --git a/security/py-libnacl/distinfo b/security/py-libnacl/distinfo
index c1df3bd1bb5c..bbae43bc5dc9 100644
--- a/security/py-libnacl/distinfo
+++ b/security/py-libnacl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1505406754
-SHA256 (libnacl-1.5.2.tar.gz) = c58390b0d191db948fc9ab681f07fdfce2a573cd012356bada47d56795d00ee2
-SIZE (libnacl-1.5.2.tar.gz) = 49573
+TIMESTAMP = 1557115419
+SHA256 (libnacl-1.6.1.tar.gz) = 9bac3d8867678c457d0c018f028052996ab567a6b4964e82a17072ed2cb2675b
+SIZE (libnacl-1.6.1.tar.gz) = 65443
diff --git a/security/py-libnacl/files/patch-setup.py b/security/py-libnacl/files/patch-setup.py
deleted file mode 100644
index 4f583b2a68f2..000000000000
--- a/security/py-libnacl/files/patch-setup.py
+++ /dev/null
@@ -1,10 +0,0 @@
---- setup.py.orig 2016-01-04 16:47:15 UTC
-+++ setup.py
-@@ -29,4 +29,6 @@ setup(name=NAME,
- 'Intended Audience :: Developers',
- 'Topic :: Security :: Cryptography',
- ],
-- packages=['libnacl'])
-+ packages=['libnacl'],
-+ test_suite='tests.runtests.run_suite',
-+)