aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2010-05-21 20:28:24 +0800
committergarga <garga@FreeBSD.org>2010-05-21 20:28:24 +0800
commit735bfc38a975c9c97cb7813d851bb77dce3c17a2 (patch)
tree76041d1889335f642273a71e589ea77230669a3d /security
parent370973b3f8656b957fdb1a4b76b0894270cf8e61 (diff)
downloadfreebsd-ports-gnome-735bfc38a975c9c97cb7813d851bb77dce3c17a2.tar.gz
freebsd-ports-gnome-735bfc38a975c9c97cb7813d851bb77dce3c17a2.tar.zst
freebsd-ports-gnome-735bfc38a975c9c97cb7813d851bb77dce3c17a2.zip
Gcc 4.2+ is only needed to build clamav with LLVM/JIT support, remove this
dependency when LLVM is not set. Submitted by: Guy Antony Halse <G.Halse@ru.ac.za>
Diffstat (limited to 'security')
-rw-r--r--security/clamav-devel/Makefile2
-rw-r--r--security/clamav/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index 12a72e9817c9..a9954c6dceee 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -27,7 +27,6 @@ OPTIONS= ARC "Enable arch archives support" On \
ICONV "Enable ICONV support" Off \
STDERR "Print logs to stderr instead of stdout" Off
-USE_GCC= 4.2+
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
@@ -144,6 +143,7 @@ CONFIGURE_ARGS+=--without-iconv
CONFIGURE_ARGS+=--enable-llvm
USE_PYTHON_BUILD= yes
USE_GMAKE= yes
+USE_GCC= 4.2+
.else
CONFIGURE_ARGS+=--disable-llvm
.endif
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index da354565bd80..5871126accf9 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -25,7 +25,6 @@ OPTIONS= ARC "Enable arch archives support" On \
STDERR "Print logs to stderr instead of stdout" Off \
EXPERIMENTAL "Build experimental code" Off
-USE_GCC= 4.2+
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
@@ -140,6 +139,7 @@ CONFIGURE_ARGS+=--without-iconv
CONFIGURE_ARGS+=--enable-llvm
USE_PYTHON_BUILD= yes
USE_GMAKE= yes
+USE_GCC= 4.2+
.else
CONFIGURE_ARGS+=--disable-llvm
.endif