aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-01-12 03:36:17 +0800
committerRene Ladan <rene@FreeBSD.org>2021-01-12 03:36:17 +0800
commit75d659b385e30935a659f6c63b86195f2b975175 (patch)
tree91ba938db95d41ba75ac2883a0f16259e0ecaa4a /security
parent3aaf6bb5547bf9e4cb3bfc37dab67b12e7323222 (diff)
downloadfreebsd-ports-gnome-75d659b385e30935a659f6c63b86195f2b975175.tar.gz
freebsd-ports-gnome-75d659b385e30935a659f6c63b86195f2b975175.tar.zst
freebsd-ports-gnome-75d659b385e30935a659f6c63b86195f2b975175.zip
Remove logic for Python < 3.6 for ports using Python 3.6+
Diffstat (limited to 'security')
-rw-r--r--security/py-mixbox/Makefile8
-rw-r--r--security/py-oauthlib/Makefile8
-rw-r--r--security/py-xmlsec/Makefile8
3 files changed, 3 insertions, 21 deletions
diff --git a/security/py-mixbox/Makefile b/security/py-mixbox/Makefile
index d1a41c740fb2..f83ba58a015b 100644
--- a/security/py-mixbox/Makefile
+++ b/security/py-mixbox/Makefile
@@ -20,10 +20,4 @@ NO_ARCH= yes
USES= python:3.6+
USE_PYTHON= distutils autoplist
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3400
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}weakrefmethod>=1.0.3:devel/py-weakrefmethod@${PY_FLAVOR}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/py-oauthlib/Makefile b/security/py-oauthlib/Makefile
index 0f7e31df8e3e..54f11074d7b7 100644
--- a/security/py-oauthlib/Makefile
+++ b/security/py-oauthlib/Makefile
@@ -35,13 +35,7 @@ USE_PYTHON= autoplist distutils
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3000
-TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
-.endif
-
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/py-xmlsec/Makefile b/security/py-xmlsec/Makefile
index d6f7ac4b1666..229db20c0275 100644
--- a/security/py-xmlsec/Makefile
+++ b/security/py-xmlsec/Makefile
@@ -27,16 +27,10 @@ USE_PYTHON= autoplist distutils flavors
INSTALL_TARGET= install-strip
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3400
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pathlib2>=0:devel/py-pathlib2@${PY_FLAVOR}
-.endif
-
post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/xmlsec*.so
do-test:
@cd ${WRKSRC} && ${LOCALBASE}/bin/pytest-${PYTHON_VER} tests
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>