aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordecke <decke@FreeBSD.org>2019-05-24 02:36:21 +0800
committerdecke <decke@FreeBSD.org>2019-05-24 02:36:21 +0800
commit75eec1d461670e0c11c65038f67bce0d76e122b0 (patch)
treebce30c5d9223aa6928f2c145733721574960f523 /security
parent3fcb08de4a5f1aad0e416951889e5f42aa96ebe5 (diff)
downloadfreebsd-ports-gnome-75eec1d461670e0c11c65038f67bce0d76e122b0.tar.gz
freebsd-ports-gnome-75eec1d461670e0c11c65038f67bce0d76e122b0.tar.zst
freebsd-ports-gnome-75eec1d461670e0c11c65038f67bce0d76e122b0.zip
Lua-bcrypt is a library providing OpenBSD's bcrypt hash function for the Lua
programming language. WWW: https://github.com/mikejsavage/lua-bcrypt/ PR: 237606 Submitted by: Manuel Wiesinger <mdw@FreeBSD.org>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/lua-bcrypt/Makefile26
-rw-r--r--security/lua-bcrypt/distinfo3
-rw-r--r--security/lua-bcrypt/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 6142f3fe4e51..84e628dd7b85 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -344,6 +344,7 @@ PORTREVISION= 1
SUBDIR += linux-c7-trousers
SUBDIR += log2timeline
SUBDIR += logcheck
+ SUBDIR += lua-bcrypt
SUBDIR += luasec
SUBDIR += luasec-51
SUBDIR += lxqt-openssh-askpass
diff --git a/security/lua-bcrypt/Makefile b/security/lua-bcrypt/Makefile
new file mode 100644
index 000000000000..dc698d3eb2c1
--- /dev/null
+++ b/security/lua-bcrypt/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= bcrypt
+PORTVERSION= 2.1
+CATEGORIES= security
+PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
+
+MAINTAINER= mdw@freebsd.org
+COMMENT= Library providing OpenBSD's bcrypt hash function for Lua
+
+LICENSE= ISCL
+
+USES= gmake lua
+
+USE_GITHUB= yes
+GH_ACCOUNT= mikejsavage
+GH_PROJECT= lua-bcrypt
+GH_TAGNAME= d64cdc8
+
+PLIST_FILES= ${LUA_MODLIBDIR}/bcrypt.so
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${LUA_MODLIBDIR}
+ ${INSTALL_LIB} ${WRKSRC}/bcrypt.so ${STAGEDIR}${LUA_MODLIBDIR}
+
+.include <bsd.port.mk>
diff --git a/security/lua-bcrypt/distinfo b/security/lua-bcrypt/distinfo
new file mode 100644
index 000000000000..969ec76c275a
--- /dev/null
+++ b/security/lua-bcrypt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1547819290
+SHA256 (mikejsavage-lua-bcrypt-2.1-d64cdc8_GH0.tar.gz) = 9fb5e557888f0cf2a2160757e837011a28617bd81fe1b43a825ca6487097d6f6
+SIZE (mikejsavage-lua-bcrypt-2.1-d64cdc8_GH0.tar.gz) = 41210
diff --git a/security/lua-bcrypt/pkg-descr b/security/lua-bcrypt/pkg-descr
new file mode 100644
index 000000000000..81199b4e152b
--- /dev/null
+++ b/security/lua-bcrypt/pkg-descr
@@ -0,0 +1,4 @@
+Lua-bcrypt is a library providing OpenBSD's bcrypt hash function for the Lua
+programming language.
+
+WWW: https://github.com/mikejsavage/lua-bcrypt/