aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-11-13 15:24:25 +0800
committerale <ale@FreeBSD.org>2006-11-13 15:24:25 +0800
commit76b077c01214f4f383c09f60de1d4f71ea65645d (patch)
tree54a1138b9607c5d1fc18d53e11c47f455be13a5a /security
parentc7014a48002015b4c02dde098135a56e1b6b8c1c (diff)
downloadfreebsd-ports-gnome-76b077c01214f4f383c09f60de1d4f71ea65645d.tar.gz
freebsd-ports-gnome-76b077c01214f4f383c09f60de1d4f71ea65645d.tar.zst
freebsd-ports-gnome-76b077c01214f4f383c09f60de1d4f71ea65645d.zip
Fix build on 4.x.
Diffstat (limited to 'security')
-rw-r--r--security/cryptlib/Makefile6
-rw-r--r--security/cryptlib/files/patch-makefile2
-rw-r--r--security/cryptlib/files/patch-tools_getlibs.sh11
3 files changed, 15 insertions, 4 deletions
diff --git a/security/cryptlib/Makefile b/security/cryptlib/Makefile
index 727411058ba2..cdb0a0cb9253 100644
--- a/security/cryptlib/Makefile
+++ b/security/cryptlib/Makefile
@@ -26,7 +26,7 @@ NO_WRKSUBDIR= yes
USE_GMAKE= yes
MAKEFILE= makefile
ALL_TARGET= default FreeBSD shared
-USE_GCC= 3.2+
+USE_GCC= 3.3+
USE_LDCONFIG= yes
PORTDOCS= README
@@ -39,8 +39,8 @@ post-patch:
.else
@${REINPLACE_CMD} -e 's/%%CFLAGS%%/${CFLAGS}/' ${WRKSRC}/makefile
.endif
- @${REINPLACE_CMD} -e 's/%%PTHREAD_CFLAGS%%/${PTHREAD_CFLAGS}/;s/%%PTHREAD_LIBS%%/${PTHREAD_LIBS}/' \
- ${WRKSRC}/makefile
+ @${REINPLACE_CMD} -e 's/%%PTHREAD_CFLAGS%%/${PTHREAD_CFLAGS}/' ${WRKSRC}/makefile
+ @${REINPLACE_CMD} -e 's/%%PTHREAD_LIBS%%/${PTHREAD_LIBS}/' ${WRKSRC}/tools/getlibs.sh
do-install:
${INSTALL_DATA} ${WRKSRC}/libcl.a ${WRKSRC}/libcl.so.${PORTVERSION}.0 \
diff --git a/security/cryptlib/files/patch-makefile b/security/cryptlib/files/patch-makefile
index 1838beb283d7..77e5ac4b40ec 100644
--- a/security/cryptlib/files/patch-makefile
+++ b/security/cryptlib/files/patch-makefile
@@ -5,7 +5,7 @@
@./tools/buildasm.sh $(AS) $(OBJPATH)
make $(DEFINES) EXTRAOBJS="$(ASMOBJS)" CFLAGS="$(CFLAGS) -DUSE_ASM \
- -fomit-frame-pointer -O3 -pthread"
-+ %%CFLAGS%% %%PTHREAD_CFLAGS%% %%PTHREAD_LIBS%%"
++ %%CFLAGS%% %%PTHREAD_CFLAGS%%"
NetBSD:
@./tools/buildasm.sh $(AS) $(OBJPATH)
make $(DEFINES) EXTRAOBJS="$(ASMOBJS)" CFLAGS="$(CFLAGS) -DUSE_ASM \
diff --git a/security/cryptlib/files/patch-tools_getlibs.sh b/security/cryptlib/files/patch-tools_getlibs.sh
new file mode 100644
index 000000000000..47154339a0f8
--- /dev/null
+++ b/security/cryptlib/files/patch-tools_getlibs.sh
@@ -0,0 +1,11 @@
+--- tools/getlibs.sh.orig Mon Nov 13 08:18:56 2006
++++ tools/getlibs.sh Mon Nov 13 08:19:14 2006
+@@ -92,7 +92,7 @@
+ echo "" ;;
+
+ 'FreeBSD'|'NetBSD')
+- echo "-lpthread" ;;
++ echo "%%PTHREAD_LIBS%%" ;;
+
+ 'HP-UX')
+ case `uname -r | sed 's/^[A-Z].//' | cut -f 1 -d '.'` in