aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2021-03-18 00:11:27 +0800
committerCy Schubert <cy@FreeBSD.org>2021-03-18 00:11:27 +0800
commit781097c15d89b9aa433ae35ef21bec5a6596027d (patch)
tree420f368198932f86f0649c5464a71ca8a2666b42 /security
parent2854a1f0a1c8f5a4ef9a8d024990f0bb7e78ae5d (diff)
downloadfreebsd-ports-gnome-781097c15d89b9aa433ae35ef21bec5a6596027d.tar.gz
freebsd-ports-gnome-781097c15d89b9aa433ae35ef21bec5a6596027d.tar.zst
freebsd-ports-gnome-781097c15d89b9aa433ae35ef21bec5a6596027d.zip
security/libgcrypt: Fix armv6 build
Armv6 fails to build jitterentropy-base.c without optimization, even though #pragma GCC optimization and #pragma clang optimization are specified. For now brute force disable building the jitter entropy generator on armv6. PR: 253698 Submitted by: yani _ pi-greece.eu Reported by: yani _ pi-greece.eu
Diffstat (limited to 'security')
-rw-r--r--security/libgcrypt/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/security/libgcrypt/Makefile b/security/libgcrypt/Makefile
index 2c9cc5115f60..2eafe4eab032 100644
--- a/security/libgcrypt/Makefile
+++ b/security/libgcrypt/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libgcrypt
PORTVERSION= 1.9.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= GNUPG
@@ -38,6 +39,10 @@ OPTIONS_DEFINE= DOCS
CONFIGURE_ARGS+= --disable-asm
.endif
+.if ${ARCH} == "armv6"
+CONFIGURE_ARGS+= --disable-jent-support
+.endif
+
post-patch:
@${RM} ${WRKSRC}/doc/gcrypt.info*
@${REINPLACE_CMD} -e 's|ALIGN (3)|ALIGN (2)|g' ${WRKSRC}/mpi/i386/*.S