aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2019-04-21 14:35:41 +0800
committerkoobs <koobs@FreeBSD.org>2019-04-21 14:35:41 +0800
commit7c92357e022513261530381e02724f043d3508dc (patch)
tree219a9d34c4da686af531923ad5f7d70ef4a53bfb /security
parent21b13f269f9108f41af06a1e186e789510081e02 (diff)
downloadfreebsd-ports-gnome-7c92357e022513261530381e02724f043d3508dc.tar.gz
freebsd-ports-gnome-7c92357e022513261530381e02724f043d3508dc.tar.zst
freebsd-ports-gnome-7c92357e022513261530381e02724f043d3508dc.zip
security/py-ecdsa: Update to 0.13.2
- Include more information than COMMENT in pkg-descr - Pet portlint (NO_ARCH in USE(S) section) Changelog: https://github.com/warner/python-ecdsa/blob/python-ecdsa-0.13.2/NEWS PR: 237402 Approved by: <kyuupichan gmail com> (maintainer, drop maintainership)
Diffstat (limited to 'security')
-rw-r--r--security/py-ecdsa/Makefile6
-rw-r--r--security/py-ecdsa/distinfo5
-rw-r--r--security/py-ecdsa/pkg-descr17
3 files changed, 22 insertions, 6 deletions
diff --git a/security/py-ecdsa/Makefile b/security/py-ecdsa/Makefile
index c455a02a49b8..f004fcbe1dad 100644
--- a/security/py-ecdsa/Makefile
+++ b/security/py-ecdsa/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ecdsa
-PORTVERSION= 0.11
-PORTREVISION= 1
+PORTVERSION= 0.13.2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,9 +15,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= python
USE_PYTHON= distutils autoplist
+
NO_ARCH= yes
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/security/py-ecdsa/distinfo b/security/py-ecdsa/distinfo
index 4d4e3a730c49..994c8ee4e951 100644
--- a/security/py-ecdsa/distinfo
+++ b/security/py-ecdsa/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ecdsa-0.11.tar.gz) = 8e3b6c193f91dc94b2f3b0261e3eabbdc604f78ff99fdad324a56fdd0b5e958c
-SIZE (ecdsa-0.11.tar.gz) = 45689
+TIMESTAMP = 1555739427
+SHA256 (ecdsa-0.13.2.tar.gz) = 5c034ffa23413ac923541ceb3ac14ec15a0d2530690413bff58c12b80e56d884
+SIZE (ecdsa-0.13.2.tar.gz) = 61595
diff --git a/security/py-ecdsa/pkg-descr b/security/py-ecdsa/pkg-descr
index f427096df42b..75d2c28950ab 100644
--- a/security/py-ecdsa/pkg-descr
+++ b/security/py-ecdsa/pkg-descr
@@ -1,3 +1,18 @@
-ECDSA cryptographic signature library (pure python).
+This is an easy-to-use implementation of ECDSA cryptography (Elliptic Curve
+Digital Signature Algorithm), implemented purely in Python, released under
+the MIT license. With this library, you can quickly create keypairs (signing
+key and verifying key), sign messages, and verify the signatures. The keys
+and signatures are very short, making them easy to handle and incorporate
+into other protocols.
+
+Features
+
+This library provides key generation, signing, and verifying, for five
+popular NIST "Suite B" GF(p) curves, with key lengths of 192, 224, 256, 384,
+and 521 bits. The "short names" for these curves, as known by the OpenSSL
+tool (`openssl ecparam --list_curves`), are: prime192v1, secp224r1,
+prime256v1, secp384r1, and secp521r1. It also includes the 256-bit curve used
+by Bitcoin, whose short name is secp256k1. No other curves are included, but
+it would not be too hard to add more.
WWW: https://github.com/warner/python-ecdsa