aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-18 21:09:09 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-18 21:09:09 +0800
commit7d9d665267e5e94978b4e2fb8fe297c82daec40e (patch)
tree9c568ec71e2eac91bc58e1402a67ba92206b3c78 /security
parent22179565dd0445cf4c782ef077f3f2d403697341 (diff)
downloadfreebsd-ports-gnome-7d9d665267e5e94978b4e2fb8fe297c82daec40e.tar.gz
freebsd-ports-gnome-7d9d665267e5e94978b4e2fb8fe297c82daec40e.tar.zst
freebsd-ports-gnome-7d9d665267e5e94978b4e2fb8fe297c82daec40e.zip
- Update to 3.5.0 [1]
- OPTIONSify - Use USE_PERL5_RUN - Add missing pcre dependency - Do not use -static PR: ports/82346 [1] Submitted by: maintainer [1]
Diffstat (limited to 'security')
-rw-r--r--security/ftimes/Makefile54
-rw-r--r--security/ftimes/distinfo4
-rw-r--r--security/ftimes/pkg-plist14
3 files changed, 59 insertions, 13 deletions
diff --git a/security/ftimes/Makefile b/security/ftimes/Makefile
index af3f1b408b9d..0a29ff1790e5 100644
--- a/security/ftimes/Makefile
+++ b/security/ftimes/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ftimes
-PORTVERSION= 3.4.0
+PORTVERSION= 3.5.0
CATEGORIES= security sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ftimes
@@ -15,24 +15,56 @@ EXTRACT_SUFX= .tgz
MAINTAINER= klm@uidzero.org
COMMENT= A system baselining and evidence collection tool
-GNU_CONFIGURE= YES
+GNU_CONFIGURE= yes
+USE_PERL5_RUN= yes
-.if defined(WITHOUT_SSL)
-CONFIGURE_ARGS+= --without-ssl
+MAN1= ftimes.1
+
+OPTIONS= DIG_TOOLS "install dig tools" on \
+ HASHDIG_TOOLS "install hashdig tools" on \
+ MAP_TOOLS "install map tools" on \
+ PCRE "PCRE support" on \
+ SSL "OpenSSL support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DIG_TOOLS)
+PLIST_SUB+= DIG_TOOLS=""
+CONFIGURE_ARGS+= --with-dig-tools
.else
-USE_OPENSSL= YES
-CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
+PLIST_SUB+= DIG_TOOLS="@comment "
.endif
-.if defined(NO_STATIC)
-CFLAGS+=
+.if defined(WITH_HASHDIG_TOOLS)
+PLIST_SUB+= HASHDIG_TOOLS=""
+CONFIGURE_ARGS+= --with-hashdig-tools
.else
-CFLAGS+= -static
+PLIST_SUB+= HASHDIG_TOOLS="@comment "
.endif
-MAN1= ftimes.1
+.if defined(WITH_MAP_TOOLS)
+PLIST_SUB+= MAP_TOOLS=""
+CONFIGURE_ARGS+= --with-map-tools
+.else
+PLIST_SUB+= MAP_TOOLS="@comment "
+.endif
+
+.if defined(WITH_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+CONFIGURE_ARGS+= --with-pcre=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --without-pcre
+.endif
+
+.if defined(WITH_SSL)
+# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
+.else
+CONFIGURE_ARGS+= --without-ssl
+.endif
post-install:
${STRIP_CMD} ${PREFIX}/bin/ftimes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/ftimes/distinfo b/security/ftimes/distinfo
index 1d44d3c0b028..2fe3db3b36d6 100644
--- a/security/ftimes/distinfo
+++ b/security/ftimes/distinfo
@@ -1,2 +1,2 @@
-MD5 (ftimes-3.4.0.tgz) = 99ed52a7db1985803fd380c1c94f38ec
-SIZE (ftimes-3.4.0.tgz) = 321605
+MD5 (ftimes-3.5.0.tgz) = 4debca298c5e4040fa0bad427cfea597
+SIZE (ftimes-3.5.0.tgz) = 400650
diff --git a/security/ftimes/pkg-plist b/security/ftimes/pkg-plist
index 7b017c8119dc..8da9c062ad45 100644
--- a/security/ftimes/pkg-plist
+++ b/security/ftimes/pkg-plist
@@ -1,3 +1,17 @@
+%%DIG_TOOLS%%bin/ftimes-dig2ctx.pl
+%%DIG_TOOLS%%bin/hipdig.pl
+%%HASHDIG_TOOLS%%bin/hashdig-bash.pl
+%%HASHDIG_TOOLS%%bin/hashdig-bind.pl
+%%HASHDIG_TOOLS%%bin/hashdig-dump.pl
+%%HASHDIG_TOOLS%%bin/hashdig-filter.pl
+%%HASHDIG_TOOLS%%bin/hashdig-harvest-sunsolve.pl
+%%HASHDIG_TOOLS%%bin/hashdig-harvest.pl
+%%HASHDIG_TOOLS%%bin/hashdig-make.pl
+%%HASHDIG_TOOLS%%bin/hashdig-resolve-sunsolve.pl
+%%HASHDIG_TOOLS%%bin/hashdig-stat.pl
+%%HASHDIG_TOOLS%%bin/hashdig-weed.pl
+%%MAP_TOOLS%%bin/ftimes-map2dbi.pl
+%%MAP_TOOLS%%bin/ftimes-map2mac.pl
bin/ftimes
etc/digfull.cfg.sample
etc/diglean.cfg.sample